exchange 2k3 sp2 eseutil error
config running exchange 2k3 sp2 on server 2003 r2 standard edition sp2 exchange program files installed to the default location on c: information stores installed to: d:\exchsrvr\mdbdata\ background Ive run eseutil in the past and havent had problems, although I cant remember the last time I did so (probably 2 years). I run it mainly after large amounts of data have been removed. such is the case this time. the current size of the private information store is about 60GB, but I know weve removed at least 10GB, so Id like to run a defrag. issues the public store (which is very small, only about 33MB) finishes quickly and without issue. its the private store that fails. the problem is that I get the following error about 20% of the way through the process: unable to find the callback library jcb.dll (or one of its dependencies). copy in the file and hit OK to retry, or hit Cancel to abort. and then once Ive cancelled: Operation terminated with error -2102 (JET_errCallbackNotResolved, A callback function could not be found) after 2417.63 seconds. running eseutil when running eseutil, Ive gone to c:\program files\exchsrvr\bin and run the following command: eseutil /d d:\exchsrvr\mdbdata\pub1.edb /t d:\tempdfrgpub1.edb eseutil /d d:\exchsrvr\mdbdata\priv1.edb /t d:\tempdfrgpriv1.edb I have plenty of room free on D: (more than 200GB). troubleshooting methods Ive tried Ive faced this callback issue before and was able to resolve it by copying several files from the \bin directory (Eseutil.exe, Ese.dll, jcb.dll, Exosal.dll, and Exchmem.dll )into the database directory (d:\exchsrvr\mdbdata). this no longer does the trick. I could sure use some insight here, thanks. ross
June 9th, 2009 10:14am

Please ensure the path includes "c:\program files\exchsrvr\bin". Alternatively you can try copying the required files including jcb.dll to c:\Windows\system32 folder.The other option would be to reinstall Exchange SP2.Bhargav Shukla|PFE : Messaging |Exchange Server TechCenter|Microsoft Exchange Team Blog | My Threads|My Blog
Free Windows Admin Tool Kit Click here and download it now
June 9th, 2009 11:24am

This worked for me on SBS 2003 R2 Reinstallation and remounting of old Exchange store into new installation environment. Priv1 worked fine but got above error on pub1 and after trying to copy file jcb.dll option (failed) I tried BootINI option and restarted and it work like a charm. Thanks FD Smarthost Design Technologies LLC
September 9th, 2011 1:08am

Good options to check from the others, I have also have seen a corrupt Pagefile do this, as well as a pagefile located on SAN storage. so you might ensure its on a local disk, that has plenty of room and if that's already the case, re-create it to see if that solves the issueTroy Werelius Search, Recover, & Extract Mailboxes, Folders, & Email Items from Offline EDB's and Live Exchange Servers with Lucid8's DigiScope
Free Windows Admin Tool Kit Click here and download it now
September 9th, 2011 3:03pm

A bit late coming to the party on this one but I hope this solution will help others... Our Exch DB had reached its maximum file size and I need to run a defrag after removing old mailboxes and trimming down some of the users emails, but kept getting "2102 call back not resolved" error and "jcb.dll not found". I read on other posts and from microsoft to try the hotfix: ...didnt work for me... also tried the /3GB switch in the boot.ini....didnt work either. My fault was, despite the exchange server and DB being located on the d: and running eseutil from there, there was another copy of exchange on the c:... So, to resolve, I ran eseutil from the c: like so: C:\progra~1\exchsrvr\bin>eseutil /d d:\progra~1\exchsrvr\mdbdata\priv1.edb /td:\progra~1\exchsrvr\bin\temp1138.edb (I specified the /t switch as my c partition was not more that 110% of the size of the exchange DB) Tested with the Public mailstore and so far so good, running the Private mailstore now... 75GB so I'll post back in a couple of days once its finished!!! Hope it helps! Paul
August 27th, 2012 7:03am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics