Unable to install Exchange 2007 Single Copy Cluster to volume mount point
I have been fighting with this problem for several days now, and I am unable to make heads or tails of it.. I'd like to know if anybody has seen this before, or has any advice. A quick fix would be preferred :-D Attempting to install Exchange 2007 on Server 2003 x64 with clustering enabled. When I get to the part of setup where it asks me for the Role, I choose 'Active Clustered Mailbox Role.' Leaving the default path of 'C:\Program Files\Microsoft\Exchange Server', I hit next. I choose 'single copy cluster', choose clustered mailbox server name of 'exchange', enter IP address, then change my path for database files to 'x:\sgdb01\mailbox'. Now, this X drive is a mounted virtual disk provided by Netapp ONTap & Snapdrive. The \sgdb01\ folder is a volume mounted drive within the X drive, for another virtual disk provided via the same service. The idea here is that, as we'll have more than 26 database & log storage points, volume-mounting them under an X & Y drive gives us more storage places than the alphabet can provide.. I'm sure this concept is old news, but I wanted to make sure that part is clear. So, when I hit next, it does the little pretest thingy, and comes back with: [ERROR] The storage path 'X:\sgdb01\mailbox' for a single copy cluster must be a clustered disk. Please specify a different path for the shared storage. ... So, what I'm not understanding, is what part of this whole thing does it NOT understand about it being a clustered disk? Within the Cluster Management, I see the disk. I can 'Move Group' and watch it become instantly available on its brother server. I can create/delete/modify files within this folder, 'move group' it, and watch it show up on the other side. I just see no clues as to why this setup doesn't think its clustered, other than the setup doesn't support mount points. To further muck this up, if I turn back time a bit and change the path of the database to 'x:\mailbox' (not using the \sgdb01\ mount point) THEN IT WORKS PERFECTLY. However, that's not what we want, nor what the best practices call for. It's starting to feel to me that the Exchange setup doesn't detect that volume mount point as an individual drive. I will allow this wall of text to sync into your brains, and will follow up with subsequent posts including text logs & whatnots for your further viewing pleasure. Any help possible would be appreciated. This is one of those instances where 'it worked like a charm in the lab environment, and now it's mental'. Thanks! Gabe
February 2nd, 2008 8:33am

Output from exchange install log: [2/1/2008 11:28:50 PM] [0] **************[2/1/2008 11:28:50 PM] [0] Setup will run the task 'test-setuphealth'[2/1/2008 11:28:50 PM] [1] Setup launched task 'test-setuphealth -DomainController 'palpatine.xxxxx.ad' -DownloadConfigurationUpdates $false -ExchangeVersion '8.0.685.25' -Roles 'ClusterMailbox' -ScanType 'PrecheckInstall' -SetupRoles 'AdminTools','Mailbox','ClusterMailbox' -CmsName 'exchange' -CmsDataPath 'X:\sgdb01\mailbox' -CmsIPAddress '' -CmsSharedStorage $true -CreatePublicDB $false' [2/1/2008 11:28:50 PM] [1] Beginning processing.[2/1/2008 11:28:52 PM] [1] Beginning processing.[2/1/2008 11:28:52 PM] [1] NewClusteredMailboxServerObjects InternalValidate entered.[2/1/2008 11:28:52 PM] [1] Dumping the cluster named: .[2/1/2008 11:28:52 PM] [1] Groups[2/1/2008 11:28:52 PM] [1] group: Cluster Group [Cluster Quorum Group, PreferredOwners = qsc-mb-01][2/1/2008 11:28:52 PM] [1] OwnerNode: QSC-MB-01[2/1/2008 11:28:52 PM] [1] State: Online[2/1/2008 11:28:52 PM] [1] Resource: Cluster IP Address [Online, type = IPAddress, PossibleOwners = qsc-mb-01,qsc-mb-02 ][2/1/2008 11:28:52 PM] [1] IpAddress = [][2/1/2008 11:28:52 PM] [1] Resource: Cluster Name [Online, type = NetName, PossibleOwners = qsc-mb-01,qsc-mb-02 ][2/1/2008 11:28:52 PM] [1] NetName = [EXCLUSTER-01][2/1/2008 11:28:52 PM] [1] Resource: Disk Z: [Online, type = Disk, PossibleOwners = qsc-mb-01,qsc-mb-02 ][2/1/2008 11:28:52 PM] [1] Resource: Disk X:\ [Online, type = Disk, PossibleOwners = qsc-mb-02,qsc-mb-01 ][2/1/2008 11:28:52 PM] [1] Resource: Disk Y:\ [Online, type = Disk, PossibleOwners = qsc-mb-02,qsc-mb-01 ][2/1/2008 11:28:52 PM] [1] Resource: Disk x:\sgdb01\ [Online, type = Disk, PossibleOwners = qsc-mb-02,qsc-mb-01 ][2/1/2008 11:28:52 PM] [1] Resource: Disk y:\sglog01\ [Online, type = Disk, PossibleOwners = qsc-mb-02,qsc-mb-01 ][2/1/2008 11:28:52 PM] [1] Nodes[2/1/2008 11:28:52 PM] [1] node: QSC-MB-01 [ state = Up ][2/1/2008 11:28:52 PM] [1] node: QSC-MB-02 [ state = Up ][2/1/2008 11:28:52 PM] [1] CheckNewCmsParametersAndFillInDefaults() -- verifying the parameters are valid.[2/1/2008 11:28:52 PM] [1] Verifying that the cluster does not contain a single copy cluster and a clustered mailbox server using cluster continuous replication.[2/1/2008 11:28:52 PM] [1] CountServersAndCheckCmsOwner(): group 'Cluster Group' has a network name of 'EXCLUSTER-01'.[2/1/2008 11:28:52 PM] [1] CountServersAndCheckCmsOwner() found 0 servers.[2/1/2008 11:28:52 PM] [1] NewClusteredMailboxServerObjects InternalValidate left.[2/1/2008 11:28:52 PM] [1] Ending processing.[2/1/2008 11:28:52 PM] [1] [ERROR] The storage path 'X:\sgdb01\mailbox' for a single copy cluster must be a clustered disk. Please specify a different path for the shared storage.[2/1/2008 11:28:52 PM] [1] Ending processing.
Free Windows Admin Tool Kit Click here and download it now
February 2nd, 2008 8:36am

I would like to update this thread with what I've found. I contact microsoft tech support via phone, and after 3 hours of working through this issue, he suggested that the problem is a bug in the exchange installation software. Here is the official response: -------------------------------- Hi Gabriel, I am writing a follow up mail with conversation we had on phone regarding SCC error for mount point drive. Mount Point drives are supported in Exchange 2007 SCC cluster. However it is not supported during installation. If we point database path which is mount point drive, setup will error out. This is identified as a bug no E12 bug 104102. However there is no public article which is published for this issue. We can tackle this problem by following either one of the method given below. 1) While installation select database path which is not a mount point drive and once setup finishes you can change database path to mount point drive 2) If you run setup from Exchange 2007 Service pack 1 CD then you will not get error if you select mount point drive to pint database path If you have any further queried please fell free to write to me. -------------------------------- So, after using method 1, it seems to move us past the initial problem. Tomorrow, we're going to redo the whole installation and attempt #2, and see if installating directly from the SP1 disc works. I'll update again when I know more.
February 5th, 2008 2:05am

Did either of these solve your issue? I have the same issue but it is only on one of my nodes in the cluster. I can install the Active Node to the other server in the cluster just fine if I want but I can't install to just this one. I tried the SP1 DVD and I get the same issue. Haven't been able to find any other links about this issue either. Thanks.
Free Windows Admin Tool Kit Click here and download it now
May 16th, 2008 7:40am

Hmmm... with the MIcrosoft focus on CCR clustering I'm afraid this is going to be an annoying issue.... I'm trying to install an Exchange 2007 SP1 SCC cluster at a customer on Windows Server 2003 Enterprise. We're using an EMC SAN with iSCSI and we're not using Volume Mount Points. But I cannot get the cluster installed, it fails with the "must be a clustered disk" error. Unfortunately it happens on both nodes... Anyone outthere experiencing the same issue? Thanks, Jaap Wesselius
July 8th, 2008 11:23am

I was lucky, solved the issue in my specific scenario.... I deleted all disk resources and deleted all volumes in 'disk management'. Rebooted both servers. Recreated only one volume in disk management and made it a disk resource in the cluster administrator. Reran the Exchange 2007 SP1 setup et voila, it works. Didn't touch the other volumes yet, will do when setup finishes the installation and my cluster is up and running. Cheers Jaap
Free Windows Admin Tool Kit Click here and download it now
July 8th, 2008 11:47am

Yeah, I'm experiencing it with a Lefthand iSCSI SAN. Not using mount points. I'm befuddled at this point.
October 22nd, 2008 10:14pm

I was receiving these same symptoms. I was installing Exchange 07 SP1 to a hyper-v virtual server with pass-through iSCSI for the system disk. I was installing exchange to the system disk. The cluster disks were also iSCSI mounts (EMC Celerra). When I would run the active cluster node install I would receive an error at the "Clustered Mailbox Server Prerequisites" step, "Object reference not set to an instance of an object". The exchange setup log (along with a watson log) reported the following: Code Snippet[10/27/2008 3:38:57 PM] [0] **************[10/27/2008 3:38:57 PM] [0] Setup will run the task 'test-setuphealth'[10/27/2008 3:38:57 PM] [1] Setup launched task 'test-setuphealth -DomainController 'myserver.domain.local' -DownloadConfigurationUpdates $false -ExchangeVersion '' -Roles 'ClusterMailbox' -ScanType 'PrecheckInstall' -SetupRoles 'AdminTools','Mailbox','ClusterMailbox' -CmsName 'name' -CmsDataPath 'R:\Exchange' -CmsIPv4Addresses '' -CmsSharedStorage $true -CreatePublicDB $true' [10/27/2008 3:38:57 PM] [1] Beginning processing.[10/27/2008 3:39:01 PM] [1] Beginning processing.[10/27/2008 3:39:01 PM] [1] NewClusteredMailboxServerObjects InternalValidate entered.[10/27/2008 3:39:01 PM] [1] Dumping the cluster named: .[10/27/2008 3:39:01 PM] [1] Groups[10/27/2008 3:39:01 PM] [1] [WARNING] An unexpected error has occurred and debug information is being generated: Object reference not set to an instance of an object.[10/27/2008 3:39:01 PM] [1] [ERROR] Object reference not set to an instance of an object.[10/27/2008 3:39:02 PM] [1] [ERROR] Clustered Mailbox Server installation cannot continue: Object reference not set to an instance of an object.[10/27/2008 3:39:02 PM] [1] Ending processing.[10/27/2008 3:58:38 PM] [0] End of Setup In addition, the following event log entry would appear: Source: MSExchange CommonID: 4999Description: Code Snippet Code SnippetThe description for Event ID 4999 from source MSExchange Common cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer. If the event originated on another computer, the display information had to be saved with the event. The following information was included with the event: 3312E12c-RTL-AMD6408.01.0240.006ExSetupUIM.E.C.ReplayM.E.C.C.Group.IsClusterGroupSystem.NullReferenceException6c2a08.01.0240.005False the message resource is present but the message is not found in the string/message table This indicated to me that setup's checkwas failing when trying to do something with my cluster configuration. Prior to running the Exchange setup I had done some monkying around with the cluster: I changed its name and IP address, I assigned it a name that was too long for NetBIOS, and I deleted a disk resource and recreated it. So, I thought maybe there was some configuration that might be inaccurate. So, I completely destroyed the cluster (as it was only setup for this purpose) and recreated it. After doing so, setup passed this check with flying colors.
Free Windows Admin Tool Kit Click here and download it now
October 27th, 2008 11:14pm

Jaap's suggestion (Posted on Tuesday, July 08, 2008 4:47:08 AM) worked for me.
February 26th, 2009 7:13pm

Jaap,Thanks... In my case your solution works too. You save my day!
Free Windows Admin Tool Kit Click here and download it now
March 6th, 2009 5:42pm

Hi AllI came accross the same problem while installing passive node in SCC cluster.I had two diskd in one resource group, I moved one disk to other resource group and then ran the exchange 2007 SP1 setup on passive node. This time setup was successful. I think the issue was two disks in same resource group. But logically I did not understand why setup was not able to read two disks. ThanksPrashant Channe
May 20th, 2009 12:11pm

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics