Unable to Uninstall EXchange 2010
Hi, I'm trying to unsinstall Exchagne 2010 but it is failing because it thinks there is an active mailbox. I had moved a test mailbox to the location and since removed it. However when I attempt to uninstall I get this error below. Mailbox Role Prerequisites Failed Error: Uninstall cannot continue. Database 'Mailbox Database 2103615544': This mailbox database contains one or more mailboxes or arbitration mailboxes. To get a list of all mailboxes in this database, run the command Get-Mailbox -Database <Database ID>. To get a list of all arbitration mailboxes in this database, run the command Get-Mailbox -Database <Database ID> -Arbitration. Before you can remove this mailbox database, you must disable, move, or remove user mailboxes and move arbitration mailboxes. Recommended Action: http://go.microsoft.com/fwlink/?linkid=30939&l=en&v=ExBPA.4&id=4a96fd69-9cec-4a48-9571-5c9e8ab3cfe9 Elapsed Time: 00:01:06 Any suggestions on how to work thorugh this. Thanks, ADam
April 27th, 2010 10:25pm

Run this command first to disable the arbitration mailboxes: Get-Mailbox -Arbitration | disable-mailbox -arbitraion -DisableLastArbitrationMailboxAllowed:$true
Free Windows Admin Tool Kit Click here and download it now
April 27th, 2010 10:32pm

Hi Mike, Thanks for your reply. I get the error below when I run the command PS] C:\Windows\system32>Get-Mailbox -Arbitration | disable-mailbox -arbitraion -DisableLastArbitrationMailboxAllowed:$t rue The input object cannot be bound to any parameters for the command either because the command does not take pipeline in put or the input and its properties do not match any of the parameters that take pipeline input. + CategoryInfo : InvalidArgument: (Microsoft Exchange Approval Assistant:PSObject) [Disable-Mailbox], Par ameterBindingException + FullyQualifiedErrorId : InputObjectNotBound,Disable-Mailbox The input object cannot be bound to any parameters for the command either because the command does not take pipeline in put or the input and its properties do not match any of the parameters that take pipeline input. + CategoryInfo : InvalidArgument: (Microsoft Exchange:PSObject) [Disable-Mailbox], ParameterBindingExcept ion + FullyQualifiedErrorId : InputObjectNotBound,Disable-Mailbox The input object cannot be bound to any parameters for the command either because the command does not take pipeline in put or the input and its properties do not match any of the parameters that take pipeline input. + CategoryInfo : InvalidArgument: (Microsoft Exchange Approval Assistant:PSObject) [Disable-Mailbox], Par ameterBindingException + FullyQualifiedErrorId : InputObjectNotBound,Disable-Mailbox
April 27th, 2010 10:59pm

Sorry, typo in parameter name, it should be: Get-Mailbox -Arbitration | Disable-Mailbox -Arbitration -DisableLastArbitrationMailboxAllowed:$true
Free Windows Admin Tool Kit Click here and download it now
April 27th, 2010 11:10pm

I've got the command to run without error and I can now see the removed mailbox in disconnected mailboxes. Although I still can't progress through to uninstall Exchange. I"m still getting the orginal error message.
April 27th, 2010 11:37pm

And you have no user mailboxes? If you run Get-Mailbox does anything else show up? Also, delete any move requests: get-moverequest | remove-moverequest
Free Windows Admin Tool Kit Click here and download it now
April 28th, 2010 12:01am

THat's given me a list of all mailboxes in the domain. None of which have been moved. These users are also visible in EMC under mailboxes. The process thus far had been to intall Exchange 2010 and move a single mailbox which at the time was visible along with the other mailboxes. I sent a test email whilst the 2010 box is off sucessfully as a test to ensure that my mailbox was still on the 07 machine. Other then completing the install of 2010 and moving a single test mailbox no other changes have been undertaken at this stage. Thanks, Adam
April 28th, 2010 12:25am

Get-Mailbox -Server Server_Name -- Ed Crowley MVP "There are seldom good technological solutions to behavioral problems." . "Agilbert2003" wrote in message news:17f1a288-8970-4b76-b41a-bdf48dd8a3c1... THat's given me a list of all mailboxes in the domain. None of which have been moved. These users are also visible in EMC under mailboxes. The process thus far had been to intall Exchange 2010 and move a single mailbox which at the time was visible along with the other mailboxes. I sent a test email whilst the 2010 box is off sucessfully as a test to ensure that my mailbox was still on the 07 machine. Other then completing the install of 2010 and moving a single test mailbox no other changes have been undertaken at this stage. Thanks, Adam Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
Free Windows Admin Tool Kit Click here and download it now
April 28th, 2010 12:35am

Thanks Ed I was getting stuck on the DiscoverySearchMailbox.
April 28th, 2010 1:09am

HI, YOu can remove discovery mailbox using below Command. get-mailbox -Identity *discovery* | Remove-Mailbox Regards Chinthaka Shameera | MCITP: EA | MCSE: M | http://howtoexchange.wordpress.com/
Free Windows Admin Tool Kit Click here and download it now
April 28th, 2010 9:44am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics