The WinRM client received an HTTP server error status (500)
windows server 2008, ex2010 level : rollup 3v3 exchangepath : C:\Program Files\Microsoft\Exchange Server\V14\ WinRM II Extension installed VERBOSE: Connecting to EX2010T.holding.local [ex2010t.holding.local] Connecting to remote server failed with the following error message : The WinRM client received an HTTP server error status (500), but the remote service d id not include any other information about the cause of the failure. For more information, see the about_Remote_Troubleshooting Help topic. + CategoryInfo : OpenError: (System.Manageme....RemoteRunspace:RemoteRunspace) [], PSRemotingTransportException + FullyQualifiedErrorId : PSSessionOpenFailed VERBOSE: Connecting to EX2010T.holding.local [ex2010t.holding.local] Connecting to remote server failed with the following error message : The WinRM client received an HTTP server error status (500), but the remote service d id not include any other information about the cause of the failure. For more information, see the about_Remote_Troubleshooting Help topic. + CategoryInfo : OpenError: (System.Manageme....RemoteRunspace:RemoteRunspace) [], PSRemotingTransportException + FullyQualifiedErrorId : PSSessionOpenFailed VERBOSE: Connecting to EX2010T.holding.local [ex2010t.holding.local] Connecting to remote server failed with the following error message : The WinRM client received an HTTP server error status (500), but the remote service d id not include any other information about the cause of the failure. For more information, see the about_Remote_Troubleshooting Help topic. + CategoryInfo : OpenError: (System.Manageme....RemoteRunspace:RemoteRunspace) [], PSRemotingTransportException + FullyQualifiedErrorId : PSSessionOpenFailed Failed to connect to an Exchange server in the current site. Enter the server FQDN where you want to connect.: VERBOSE: Connecting to New-PSSession : Cannot bind parameter 'ConnectionUri'. Cannot convert value "http:///powershell?serializationLevel=Full;ExchClientVer=14.1.218.15" to type "System.Uri". Error: "In valid URI: The hostname could not be parsed." At line:1 char:29 + New-PSSession -ConnectionURI <<<< "$connectionUri" -ConfigurationName Microsoft.Exchange -SessionOption $so + CategoryInfo : InvalidArgument: (:) [New-PSSession], ParameterBindingException + FullyQualifiedErrorId : CannotConvertArgumentNoMessage,Microsoft.PowerShell.Commands.NewPSSessionCommand
July 6th, 2011 4:47am

Hi Do you try to read this blog “Connecting to remote server failed with the following error message: The WinRM client received an HTTP server error status (500)” paragraph, and follow the suggestion.
Free Windows Admin Tool Kit Click here and download it now
July 6th, 2011 8:21pm

exchangepath : C:\Program Files\Microsoft\Exchange Server\V14\ WinRM II Extension (re)installed, WinRM Quickconfig done anonymous auth op iis/powershell : disabled kerbauth : local / native Windows firewall : off get-user : the term is not recognized as a command i've read http://blogs.technet.com/b/exchange/archive/2010/02/04/3409289.aspx in system-log : Log Name: System Source: Microsoft-Windows-WinRM Date: 7/07/2011 9:13:23 Event ID: 10153 Task Category: None Level: Error Keywords: Classic User: N/A Computer: EX2010T.holding.local Description: The WSMan IIS module failed to read configuration. The error received was -2144108477: %%-2144108477 The configuration XML is not valid. The XML element: "Plugin" is expected but not found.. User Action Make sure both the schema and validation files are present and valid. Event Xml: <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event"> <System> <Provider Name="Microsoft-Windows-WinRM" Guid="{A7975C8F-AC13-49F1-87DA-5A984A4AB417}" EventSourceName="WinRM" /> <EventID Qualifiers="7">10153</EventID> <Version>0</Version> <Level>2</Level> <Task>0</Task> <Opcode>0</Opcode> <Keywords>0x80000000000000</Keywords> <TimeCreated SystemTime="2011-07-07T07:13:23.000Z" /> <EventRecordID>456781</EventRecordID> <Correlation /> <Execution ProcessID="0" ThreadID="0" /> <Channel>System</Channel> <Computer>EX2010T.holding.local</Computer> <Security /> </System> <EventData> <Data Name="errorcode">-2144108477</Data> <Data Name="errordetail">The configuration XML is not valid. The XML element: "Plugin" is expected but not found.</Data> </EventData> </Event>
July 7th, 2011 1:22am

Hi one similar case . http://social.technet.microsoft.com/Forums/en-US/exchange2010/thread/4493710b-73b2-44cf-8fdb-b137db7ee039/
Free Windows Admin Tool Kit Click here and download it now
July 7th, 2011 2:26am

Hi I just find new clue. another reason for the error : Connecting to remote server failed with the following error message: The WinRM client received an HTTP server error status (500), but the remote service did not include any other information about the cause of the failure. For more information, see the about_Remote_Troubleshooting Help topic. It was running the command 'Discover-ExchangeServer -UseWIA $true -SuppressError $true' Can be a result of a change of the Application Pool for Powershell (e.g. after installation of CRM). This blog is about Resolving WinRM errors and Exchange 2010 Management tools startup failures. Maybe it is helpful to you. http://blogs.technet.com/b/exchange/archive/2010/12/07/3411644.aspx
July 7th, 2011 9:21am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics