Slow Delivery Outbound Queue (SMTP Smart Host)
Hello Please Help, I have an Exchange 2003 Organization that was originally existing with exchange 5.5. I have since moved out all 5.5 server and only have in my Organization all Exchange 2003 Servers. Recently I experience very slow delivery with outbound emails. Delivery to an Hot mail account now takes about 20 minutes instead of the ususal swift delivery. The email would remain in the queue for some time and then delivers just fine. I even noticed email destined to users within the same organization stuck within the queue. I am in the process of transitioning to Exchange 2010 and have already run the exchange analyzer that showed my Organization as being in Mixed mode. I have changed my Organization from Mixed to native about two days ago. At that time after I change to Native, all mail appears to be flowing just fine until recently. It seems like my Org. has some kind of routing problems. I am not sure whether it had something to do with the change from Mixed to native, but this is the only thing that I have done. Before this change every thing seem to be working just fine. Any assistance would be greatly appreciated. Andrew
July 6th, 2010 11:43pm

Andrew, Did you try to run the Exchange BPA en Troubleshoot assistent to investigate this issue ? My advice is to run this tools first before diving deeper. Regards, JohanExchange-blog:
Free Windows Admin Tool Kit Click here and download it now
July 7th, 2010 12:36am

When you click on the message stuck in the queue in the queue viewer in ESM, then it should give you a reason message in the "Additional Queue Information" box. That may give a clue why the messages are stuck. It could be something as simple as DNS, or more complex, which the Exchange Troubleshooting Assistant as previously mentioned should identify. Simon. Simon Butler, Exchange MVP
July 7th, 2010 2:12am

Hey Simon, The only thing that was done before I experience this problem was to raise the Exchange 2003 functional level from Mixed to Native in preparation for exchange as recommended by the 2010 Exchange Deployment Analyzer Tool. I will try the exchange Troubleshooting Assistant as recommended. Could I run this tool from the Exchange Server, or thousl I install on a non exchange server then run? Thanks Andrew
Free Windows Admin Tool Kit Click here and download it now
July 7th, 2010 4:56pm

Hello Sembee, I ran the tool and got this error below. What I also noticed in my smtp queue that is using a smart host rather than Dns to send messages to the internet are emails destined for the same organization. These same email will eventually end up in the "Messages with unreachable destination" queue. I am still trying to figure out how messages destined for persons in the same organization takes the route to the smtp that is configured for the smart host. I guess I am having some kind of routine issues. Error Message The 'Messages with an unreachable destination' queue (CurrentlyUnreachableLink) on server neptune holds one or more messages. Source: 'Default SMTP Virtual Server'. Number of messages in the queue: 2. This may indicate that no alternative available route exists to a connector or remote destination"
July 7th, 2010 7:22pm

If all the messages that are queuing are for the same organisation, then it would tend to indicate there is a routing issue. However if you think you are using a smart host, then the messages shouldn't even be on the Exchange server. T Therefore I would check that you Don't have a smart host on the SMTP virtual server. The SMTP connectors are configured correctly. If you have an SMTP Connector that is called IMC or similar, then that is a throwback to Exchange 5.5. I would delete it and recreate it. While you do so, outbound email will simply queue. Simon.Simon Butler, Exchange MVP. ,
Free Windows Admin Tool Kit Click here and download it now
July 7th, 2010 7:40pm

Thanks everyone for the responses. The problem was with our Internal Iron Port Server that we use to route email to the internet. Andrew
September 1st, 2010 9:27pm

hi AndrewMoss we have the same problem , can you tell me how you have resolve the problem , wh you say that the problem was your internal iron port server have change something in configuration of iron port. Have you resolve the problem ??
Free Windows Admin Tool Kit Click here and download it now
May 20th, 2011 2:41am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics