PFDAVAdmin Error Message
Hello folks,I've been trying to use PFDAVAdmin but everytime I get this error message:---------------------------PFDAVAdmin---------------------------PFDAVAdmin could not be initialized. Exception: Request for the permission of type System.Security.Permissions.RegistryPermission, mscorlib, Version=1.0.5000.0, Culture=neutral, PublicKeyToken=b77a5c561934e089 failed.Stack trace: at System.Security.CodeAccessSecurityEngine.CheckHelper(PermissionSet grantedSet, PermissionSet deniedSet, CodeAccessPermission demand, PermissionToken permToken) at System.Security.CodeAccessSecurityEngine.Check(PermissionToken permToken, CodeAccessPermission demand, StackCrawlMark& stackMark, Int32 checkFrames, Int32 unrestrictedOverride) at System.Security.CodeAccessSecurityEngine.Check(CodeAccessPermission cap, StackCrawlMark& stackMark) at System.Security.CodeAccessPermission.Demand() at Microsoft.Win32.RegistryKey.CreateSubKey(String subkey) at pfdavadmin.RegistryAccess..ctor() at pfdavadmin.Form1..ctor()---------------------------OK ---------------------------I'm running Exchange 2k3 on Win2k3 SP1 both with all patches and etc.Does anybody know why this is happening or, even better, how to get it resolved?Thanks!
September 1st, 2008 12:27am

Hi, The error seems indicate thatyour logon account do not have full permission to Process .Net Framework components. Therefore, Please check if you have the local administrator permission. Meanwhile, it may also bee caused by some corrupted .Net Framework component.If this is the case, you may update or reinstall .Net framework 1.1 for a test. more information about PFDAVAdmin: -Jason
Free Windows Admin Tool Kit Click here and download it now
September 2nd, 2008 2:04pm

Thanks for your promptly answer Jason, but I figured out what was wrong:Someone had pfdavadmin previously installed on the C: drive, therefore all of its registry keys were pointing to that path. On my case I was trying to use it from a different drive. Since I didn't have the appropriated permissions to get those keys updated, the tool was giving me that error message.Once got it back to the C: drive it worked like a champ! Once again, thanks for your help Regards
September 2nd, 2008 10:38pm

I have the same problem.Exchange 2003 which is working wothout problemI have tried installingPFDAVAdmin on the server as a domain admin or on my own workstation with the same resultException: Request for the permission of type System.Secuirty.Permsissions.RegistryPermission, mscorlib, Version=1.0.5000.0, Culture=neutral, PublicKeyToken=b77a5c561934e089 failedAny ideas ?I just need to make some changes to about 10 calender persmissions, prefeable without diturbing the users.Any help appreciated.
Free Windows Admin Tool Kit Click here and download it now
February 2nd, 2009 2:41pm

I too was getting this error even though I tried many different servers, with 2003, 2008, etc. They had .net1.1, etc. I finally realized, it was because I was trying to launch the exe from a UNC path. As soon as I copied the PFDAVadmin directory to my C drive, the program ran without a problem.
April 29th, 2010 3:10am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics