Outlook keeps prompting users for password.

We have 2 Exchange 2010 servers and our users run Outlook 2010.  Last week we had a power outage.  After power was restored and the servers were brought back online I had users complaining about Outlook prompting them for a password.  I have seen this issue before and usually a restart of Outlook will take care of it.  Anyway after restarting Outlook some users are still prompted for a password.  If they click Cancel, Outlook would work but it may show "Need Password" in the bar at the bottom of Outlook.  Click the "Need Password" and it would go away and Outlook would work.  However at a later time Outlook may prompt for the password again.  Same process over again.

So I looked at turning off the "Outlook over http" which I have seen cause this issue before especially for clients over a WAN connection that may be a little slow to connect to the Exchange server.  After turning off the "Outlook over http" option Outlook works perfectly.  Only problem is after a little time Outlook will automatically turn "Outlook over http" on again and will eventually prompt the user for a password again.

This is driving me and my users crazy.  I am not sure what to do.  How can I permanently turn off the "Outlook over http" option?  I might try restarting both email servers again too.  Please help me with this issue.         thanks

August 3rd, 2015 5:33pm


You should try these steps:

  1. Open MS Outlook >> Click on File Tab >> Info >> Account Settings >> Double click the Exchange Account >> More Settings >> Security Tab >> Always Prompt for Logon Credentials >> Close MS Outlook.
  2. Now enter username and password >> click on Remember my Credentials >> Close Outlook and repeat and don't forget to click on Remember my Credentials.   
  3. Go back into More Settings >> Security Tab >> and Remove the check from the Always Prompt for Logon Credentials >> Close "Outlook".
  4. Go to "Control Panel" >> "User Accounts" >>Manage your credentials; under "Generic Credentials" you will see your Outlook Saved Password. I am sure that password saved in this area is invalid.  Remove the saved password and log on to Outlook 2010. 

I hope this will be helpful for you.

Note: Improve community discussions by marking the answers helpful.

Thanks & Regards

Clark Kent

Free Windows Admin Tool Kit Click here and download it now
August 4th, 2015 12:37am

I will make these changes you have suggested and reply with results.  thanks
August 4th, 2015 10:08am

After looking at your steps and giving it some thought, even if this "makes" it work this is something that should not have to be done at all.  I think it indicates another issue that needs to be corrected.  Thanks for your help but this issue is happening with several users (probably 10) and that makes me think it is server related.
Free Windows Admin Tool Kit Click here and download it now
August 4th, 2015 10:26am

You can also try to Disable Cache Exchange Mode once:

To do so:

Open "MS Outlook" >> "File" tab >> "Account Settings" >>"Account Settings" >> Click twice on your Exchange Account >> Disable the option: "Use Cache Exchange Mode" >> Click "Next" & "Finish" >> Restart.

For more information, read this article: http://www.msoutlook.info/question/cancelling-exchange-password-shows-emails

Thank & Regards

Clark Kent

August 5th, 2015 1:01am

Hi Poly,

Outlook keeping prompting for password issue could be caused due to many reasons. On Outlook client side, we can consider troubleshooting the issue as per described in the following forum article:


Since this issue happening with multiple users and you think it's more server related, I'd recommend you post a new question in the Exchange Server forum for further assistance:


The reason why we recommend posting appropriately is you will get the most qualified pool of respondents, and other partners who read the forums regularly can either share their knowledge or learn from your interaction with us. Thank you for your understanding.

Steve Fan

Forum Support

Free Windows Admin Tool Kit Click here and download it now
August 5th, 2015 1:37am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics