Exchange 2013, CAS role allready installed after cold removal Exchange VHD installation


I am setting up a new network with recently bought hardware. Installed exchange mailbox role on SVR-EXCH01 and on the SVR-WEB01 the CAS role. When opening ECP on the SVR-WEB01 i only get my personal options and email page. I logged in with the administrator account, wich is a member of the domain admins, and the Exchange security groups. The Exchange mgmgt shell did not recognize many exchange commands. Here is where i went wrong;

To see if i could get ECP to work localy, i installed it ontop of the SVR-EXCH01 mailbox role.... That resulted in nothing more then with the separate CAS installation on the SVR-WEB01.

Unistalling Exchange on the SVR-EXCH01 resulted in an error message "Error:Uninstall can't continue. Database Mailbox Database 2067414591 : This mailbox database contains one or more mailboxes, mailbox plans, archive mailboxes, public folder mailboxes or arbitration mailboxes. To get a list of all mailboxes in this database, run the command Get-Mailbox -Database <Database ID>. To get a list of all mailbox plans in this database, run the command Get-MailboxPlan, etc, etc......."

Then i removed the two virtual instances svr-web01 and svr-exch01 from MS Hyper-V and the VHD files for the two servers. Removed the accounts from active directory. To start with the installation from scretch.

The latest status is as follows, I installed the two servers, with exactly the same name. Walk thru te installation procedure describbed in the following url; At the point of preping the domain (again) the following is displayed.

"PS F:\> ./setup /ps /IAcceptExchangeServerLicenseTerms

Welcome to Microsoft Exchange Server 2013 Unattended Setup
Copying Files...
File copy complete. Setup will now collect additional information needed for installation.
Client Access role: Front End Transport service
Client Access role: Client Access Front End service

Performing Microsoft Exchange Server Prerequisite Check

    Configuring Prerequisites                                                                         COMPLETED
    Prerequisite Analysis                                                                             FAILED
     The Client Access server role is already installed on this computer.
     For more information, visit

The Exchange Server setup operation didn't complete. More details can be found in ExchangeSetup.log located in the
<SystemDrive>:\ExchangeSetupLogs folder."

I would like to manually remove any registration of the CAS Role in my domain. Or is there any other way to recover my newly installed domain?

Help would be more than appriciated!

Kind regards,

Bart Assink

New development, i managed to de-install the relations with adsiedit configuration. I did not know how to connect to the configuration before.

Running a new installation, so now the only mystery left is. Howto connect the SVR-WEB01 (CAS-Role) to the SVR-EXCH01 (Mailbox-role). So that my Exchange management commands are working and i can manage exchange with the ECP.

Again help would be much appreciated, so i can enjoy my first exchange 2013 installation in a live enviroment! :)



February 25th, 2013 11:03am

   I don't konw your purpose clearly.
   You can try remote shell.
Free Windows Admin Tool Kit Click here and download it now
February 26th, 2013 6:52am

Thank you for your reaction to my thread! I got it working, guess i missed the installation feature for AD services in the prerequisets. Because now i get to create new mailboxes. As before i only got my personal email options en email. First did the remove procedure with ADSIEDIT. Then got to reinstall it all.


February 26th, 2013 9:54am

many thanks for the solution. I had the same error when uninstalling and trying to installed as well. however i got tired and started from scratch but glad to hear ADSIEDIT worked
Free Windows Admin Tool Kit Click here and download it now
April 24th, 2013 2:25pm

I know this thread is old, but I want to reply to it to ask how this is done within ASDI.  My scenario is similar in that I've wiped out my VM's and started from scratch. 

I ran Setup.exe /PrepareSchema /IAcceptExchangeServerLicenseTerms

The configuring prereq's check completed, however, the prereq analysys failed with the message:

"The Client Access server role is already installed on this computer.  For more information, visit:

Any assistance would be much appreciated.  Thanks.

July 31st, 2015 11:13am

I should also note that I have Exchange 2007 running in production, (which I plan to migrate to a Exchange 2013 DAG environment one I can get it configured.

With that said, I can't do a blanket delete of Exchange in ASDI, as outlined here:

Free Windows Admin Tool Kit Click here and download it now
July 31st, 2015 11:21am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics