Exchange 2007 > PrepareAD > Impersonation Level is invalid
Problem: When running setup /preparead or /prepareschema for Exchange 2007 Beta2, the organization preparation process fails. I get the following error: An unexpected error has occurred and a Watson dump is being generated: Either a required impersonation level was not provided, or the provided impersonation level is invalid. I have scanned the threads in this forum and have seen similar issues, but have yet to find one quite like this. The test environment I'm working inis as follows: 1 DC/GC/DNS/WINS server running Windows 2003 R2 1 Exchange 2003 Server SP2 running on Windows 2003 R2 member server Planning to install Exchange 2007 on another Windows 2003 R2 member server. Same error occurs if I run the "preparead" on DC or member server where I want to install Exchange 2007 Prereqs check out okay. "preparelegacyexchangepermissions" was successful. Any assistance would be greatly appreciated. Thanks
September 29th, 2006 5:38am

I've about spent all the time I can afford to spend on this issue. I think I've tried everything possible (or at least what might make sense) with regard to ASP.NET 2.0 and impersonation. After giving up on this, I created a second DC in my test environment and transferred the schema master role to this DC. I then retried setup /preparead from this DC. This time, Ireceived the following error message: The process cannot access the file "C:\ExchangeSetupLogs|ExchangeSetup.log" because it is being used by another process. Research showed that others having been getting this same error, but that it was due to "remoteregistry" being disabled. This is not the case for me. RemoteRegistry is enabled on both of my DCs. As some posts have suggested, I've also tried killing dw20.exe, then re-running setup / no avail. So when running setup \preparead from my first DC or a member server, I get the "impersonation" error. And when running setup \preparead from my second DC, I get the aforementioned error. Couple of other notes: (1) The account I'm using has domain admin, enterprise admin, and schema admin permissions. (2) I've tried various combinations of FSMO roles / GC functionality on each of the domain controllers. (3) The DCs are pretty much just that. No additional applications running. (4) The use of network monitor didn't reveal very much as far as what's going on in the background. (5) I've tried running setup from command prompt and MSH.
Free Windows Admin Tool Kit Click here and download it now
October 3rd, 2006 6:28am

Found a tid in Spanish. Translated it. Had a hunch. Disabled NetBIOS over TCP/IP on the member server where I was planning to install Exchange 2007. Reran setup, everything worked. Really don't know why though. Even though I'm not installing into a cluster, would this have anything to do with CCR where I believe you have to disable NetBIOS over TCP/IP?
October 6th, 2006 8:05pm

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics