Exchange 2003 - Delivery restrictions don't  apply?
Hello,In my Small Business Server 2003 SP2 environment I need to forbid domain users to send email to anywhere outside of the domain. (though they will need to be able send email with their distribution group's email address each user having "send as" permission on a particular distribution group).I know I need to open the properties of my SMTP connector, and on the Delivery Restrictions tab I add user(s) or group(s) to the "Reject messages from" text field.I did, and I also applied the registry modifications explained in - for testing, I used my own user, added myself to the "Reject messages from" field, restarted the exchange routing and smtp services, and tried sending email to an external address. Which I perfectly could. Is there any other conditions under which the Delivery Restrictions do not apply?Thanks.
February 27th, 2009 5:57pm

Hi,How did you add the value name in the registry? Copy the words from the KB or input manually?Please note: If you copy the"CheckConnectorRestrictions" from the KB, there will has a space. Then, it will cause the registry not function.ThanksAllen
Free Windows Admin Tool Kit Click here and download it now
March 2nd, 2009 10:52am

Hello,thanks for your reply - but unfortunately this is not the case: I edited the registry manually, double-checked it, it seems okay.d.szabolcs
March 2nd, 2009 12:34pm

Hi,Whether the SMTP connector has only one bridgehead or one more? Please ensure you had added this value in the registry on all the bridgeheads which associated with the SMTP connector.ThanksAllen
Free Windows Admin Tool Kit Click here and download it now
March 2nd, 2009 12:43pm

Hello,only one bridgeheadthanks,d.szabolcs
March 2nd, 2009 1:08pm

Hi,Now I suggest we remove the current SMTP connector and recreate a new one, then restart the relevant services and test this issue.ThanksAllen
Free Windows Admin Tool Kit Click here and download it now
March 3rd, 2009 5:35am

hi,thanks very much for your help - but the issue solved itself - there was a long overdue restart of the server yesterday (because of updates) and after booting up everything works fine.
March 4th, 2009 10:49am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics