Deleting public folder in Exchange 2010
Long story short, we're trying to uninstall a test version of Exchange 2010 so we can install a production version somewhere else. And the latest in a series of hurdles we need to jump is deleting the public folder store. We get this error when we try to delete the one and only solder store: The public folder database "Public Folder Database 1559829565" contains folder replicas. Before deleting the public folder database, remove the folders or move the replicas to another public folder database. For detailed instructions about how to remove a public folder database, see I see all sorts of help on this topic but it all seems to be for dismantling Exchange 2003 and 2007 ... 2010 has a different topology that doesn't apply.
July 22nd, 2010 12:54am

Hi, See this post, and see the public folder removal section: same steps required to remove Ex 2010 pf db. regards,Laeeq Qazi|Team Lead(Exchange + Sharepoint + BES + DynamicsCRM)
Free Windows Admin Tool Kit Click here and download it now
July 22nd, 2010 12:57am

Thanks for this, unfortunately this procedure isn't working for me. It still says there's replicas despite running that script. I think I'm going to start a microsoft support case for this.
July 22nd, 2010 1:48am

Please check if there’s any replica on the exchange 2010 server Get-PublicFolder -Recurse | Ft -Wrap Name,Replicas Get-PublicFolder -Identity \NON_IPM_SUBTREE -Recurse | Ft -Wrap Name,Replicas Quote: “It still says there's replicas despite running that script” Which script do you try to use, MoveAllReplicas.ps1? Have you tried the cmdlet in this article, including the “ErrorAction” and “Server” parameter?James Luo TechNet Subscriber Support ( If you have any feedback on our support, please contact
Free Windows Admin Tool Kit Click here and download it now
July 22nd, 2010 8:44am

As I see this thread as been unanswered I have a similar problem. SBS2011 std with Exchange 2010 all SP installed and upto date. Public folder has a few contact lists that is used extensivly and that crashed when a remote user was accessing it. Fails to mount. Restore using built in MS backup (storage) did not work. Tried to delete but says no still using OAB (offline address book)which must be removed 1st. Searched and read every article I can find but nothing "easy" and do not want to reinstall exchange as the server is live. Any ideas of what to do to get a new Public Folder running. I do have backups separatly for the contact data that was in there.
August 14th, 2011 3:09am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics