Creating a Scorecard with data from SQL table returns only one row instead of the rows the have in the table


after creating the datasource looking against a SQL table and previewing it fine on its View Data properly (with more than 1 row),

We try to use drag and drop the Property (Objective)  or even in the Named Set Objective All to the Scorecard (bellow or in front of the KPI) and the update is retrieving only one row from the source instead of showing all rows/objectives we have in the data source.

We dont understand whats going on. We have other server which we do the same process and it works fine, showing all rows on the KPI created.

It shows Eg:

              Actual, Target


   Objective 1, 10, 9 (o), 10%

Istead of

              Actual, Target


   Objective 1, 10, 9 (o), 10%

   Objective 2, 10, 9 (o), 10%

   Objective 3, 10, 9 (o), 10%

Any clues?


Alex Ber

October 9th, 2012 7:46pm

Hi Folks,

After applying the last Sharepoint 2010 update "office2010-kb2687353-fullfile-x64-glb" we could reproduce the error above.

It means there is a bug in the Sharepoint update. The problem is we cant rollback the update anymore and we are already running it in production environment.

Do you guys have any idea about how to fix it instead of reinstalling all the server and implement our solution again?

Thanks and Regards,

Alex Berenguer

Free Windows Admin Tool Kit Click here and download it now
October 11th, 2012 7:28pm


Any new information about this? I'm having the same issue. I also have the August 2012 CU installed. I'm not sure what else you tried, but I'm having this issue with an Excel Services data connection and a SharePoint List data connection.


October 12th, 2012 9:13pm


I was wondering if you ever figured this out.  I am getting this error also. 


Free Windows Admin Tool Kit Click here and download it now
January 31st, 2013 10:16pm

Hi Matthew, yes I do.

Its a bug of Sharepoint 2010 update. You must keep your Sharepoint without the update  "office2010-kb2687353-fullfile-x64-glb".

I dont know if Microsoft has fixed it. But try to use a Sharepoint installation without run any update.


Alex Berenguer

February 1st, 2013 4:27pm


Thx for your response.  I was afraid of this.  I already have these updates installed.  I guess you can't back it out so I will be on a holding pattern until there is a fix (hopefully, soon).  Thx again.

Free Windows Admin Tool Kit Click here and download it now
February 1st, 2013 9:25pm

The February 12, 2012 cumulative update fixed this issue for me.;EN-US;2767793

Issue that this hotfix package fixes

After you apply hotfix 2687353 in Microsoft SharePoint Server 2010, the New Dimension Filter lists only one member of a SharePoint list data source in PerformancePoint 2010 Dashboard Designer.
February 20th, 2013 8:21pm

Thank you so much, KWEINRICH, we will try that.

Free Windows Admin Tool Kit Click here and download it now
February 20th, 2013 8:47pm

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics