Cannot remove first Exchange 2007 server in the site
We evaluated Exchange 2007 by installing it on a desktop PC with HT, CAS and MB roles. This created the new Administrative Group (FYDIBOHF23SPDLT) and the new Routing Group (DWBGZMFD01QNBJR) - all as expected. We created some test mailstores and a test public folder store on the test "serverMX6" machine. Now we have implemented proper Exchange servers and need to decomission the desktop PC that was the first Exchange 2007 server in the site. I have been able to remove all mailstores, but not the Public Folder database. I get the error; Code Snippet The public folder database 'Public Folder Database' cannot be deleted. The public folder database "ServerMX6\Second Storage Group\Public Folder Database" contains folder replicas. Before deleting the public folder database, remove the folders or move the replicas to another public folder database. For detailed instructions about how to remove a public folder database, see I have tried the instructions on use the scripts from the installation CD, but there do not appear to be any Public Folders at all on this server - there are definitely none that have been replicated to it and none that were created on this server. I have checked all Public Folders' replication settings, and none are replicated to "ServerMX6". I can only assume that it is a "hidden" system public folder that I cannot get to. Running Get-PublicFolder results in just one result, IPM_SUBTREE - which I cannot delete. Running Get-PublicFolderStatistics results in just the Offline Address Books which have no replicas on this server, and no itemcount. When I go to Public Folder Management Console, and try to deleted EX:/o=ExchOrg/ou=Exchange Administrative Group (FYDIBOHF23SPDLT), I get the following error; Code Snippet Action 'Remove' could not be performed on object 'EX:/o=ExchOrg/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)'. EX:/o=ExchOrg/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)FailedError:Cannot delete the object '\NON_IPM_SUBTREE\SCHEDULE+ FREE BUSY\EX:/o=ExchOrg/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)'. Please make sure that you specified the correct identity and that you have the correct permissions to delete it. MapiExceptionPartialCompletion: Unable to delete folder. (hr=0x40680, ec=0)Diagnostic context: Lid: 18969 EcDoRpcExt2 called [length=54] Lid: 27161 EcDoRpcExt2 returned [ec=0x0][length=85][latency=0] Lid: 23226 --- ROP Parse Start --- Lid: 27962 ROP: ropDeleteFolder [29] Lid: 17082 ROP Error: 0x80070005 Lid: 19297 Lid: 21921 StoreEc: 0x80070005 Lid: 27962 ROP: ropNone [0] Lid: 26881 Lid: 21817 ROP Failure: 0x80070005 Lid: 24721 Lid: 20625 StoreEc: 0x80070005 How do I get rid of this server? Would it be easier just to destroy the server and then clean up AD through ADSIedit or another tool?
November 27th, 2008 9:13am

Have you reviewed this?
Free Windows Admin Tool Kit Click here and download it now
November 27th, 2008 11:19am

Hi, Please follow kb 927464 to remove the replicas from the public folder store. After that, you may need to wait between 15 minutes and two hours for the moves to be completed physically. Detail information share with you: How to remove Exchange 2007 from a computer Hope it helps. Xiu
November 27th, 2008 12:42pm

Thanks, but I have already reviewed and followed both links. I have waited for 2 weeks for replication to ocurr, and on the server that I am trying to remove, the folders are listed as having no items and no size, so replication must have alreadyhappened. When I try to delete the folders with either Get-PublicFolder -server "ServerMX6" | Remove-PublicFolder -server "ServerMX6" or the command Get-PublicFolder -Server "ServerMX6" "\Non_Ipm_Subtree" -Recurse -ResultSize:Unlimited | Remove-PublicFolder -Server"ServerMX6" -Recurse both result in the same error as before - but I think that it is permissions. I have Full Administrator permissions in Exchange, I have All Extended Rights over all Public Folders, both to my username directly and I am a member of the Exchange Full Admins user group. As these folders are empty and there are other Exchange 2007 servers, and I just want to get rid of the server, is there any harm in me deleting it through ADSIedit? What impact would that have? How would I do it? Thanks
Free Windows Admin Tool Kit Click here and download it now
November 28th, 2008 6:49am

Hi, Please ensure that you do not need all resource from that server before you delete the server entry in ADSIedit. Active Directory Backup and Restore Regards, Xiu
December 2nd, 2008 7:53am

I solveda problem like this by moving the AD entry for CN=Public Folders to it's default location.See: a possible solution.I don't know why it was created in the "wrong container"by the first installed test server, I would consider this a defect in the installation, but I cannot confirm this.
Free Windows Admin Tool Kit Click here and download it now
June 18th, 2009 9:18am

Hi I solved the same problem with public folder replication in this tread: In the link i used the script ReplaceReplicaOnPFRecursive.ps1, because it's the script activated by the MoveAllReplicas.ps1script. :NoteIt seems that the problem is caused by the first installation placing theCN=Public Folders in the wrong container.After moving the container to the default location the script to move replicas works and all information about the public folders for Exchange servers in the organisation is displayed in the >Exchange Management Console -> Toolbox -> Public FOlders Management Console.And the scripts to move the replicas MoveAllReplicas.ps1 works without any errors so I'm able to remove the server role MBX and uninstall the first Exchange in the organisation.
June 18th, 2009 9:35am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics