Can't remove one public folder
I'm trying to replace an Exchange2007, SP1CCR server. I have moved the mailboxes to the new server and removed the databases that contained them, then removed the respectivestorage groups. However, I cannot remove the public folder database because I can't move or delete one of the PFs. I used moveallreplicas.ps1 several times over more than 24 hours and manuallyremoved some remainingStoreEvents PFs in the PF Mgmt Console.Here is the error message I get for the one I can't remove:--------------------------------------------------------Microsoft Exchange Error--------------------------------------------------------Action 'Remove' could not be performed on object 'EX:/o=MyCompany/ou=First Administrative Group'. EX:/o=MyCompany/ou=First Administrative GroupFailedError:Cannot delete the object '\NON_IPM_SUBTREE\SCHEDULE+ FREE BUSY\EX:/o=MyCompany/ou=First Administrative Group'. Please make sure that you specified the correct identity and that you have the correct permissions to delete it. MapiExceptionPartialCompletion: Unable to delete folder. (hr=0x40680, ec=0)Diagnostic context: Lid: 18969 EcDoRpcExt2 called [length=50] Lid: 27161 EcDoRpcExt2 returned [ec=0x0][length=81][latency=0] Lid: 23226 --- ROP Parse Start --- Lid: 27962 ROP: ropDeleteFolder [29] Lid: 17082 ROP Error: 0x80070005 Lid: 19297 Lid: 21921 StoreEc: 0x80070005 Lid: 27962 ROP: ropNone [0] Lid: 26881 Lid: 21817 ROP Failure: 0x80070005 Lid: 24721 Lid: 20625 StoreEc: 0x80070005--------------------------------------------------------OK--------------------------------------------------------Judging from the name of it, maybe it shouldn't be deleted. What do I need to do to get this moved orremoved?Thanks.
May 20th, 2009 2:37am

We cannot manually delete the system folder, otherwise, the error window you encountered will occur. If we need to remove an Exchange 2007 public folder store, what we need to do is to remove all replicas on that store including system folders Just because we run MoveAllReplicas.ps1, does not mean the public folder does not exist in the old database, until public folder replication completes successfully we wont be able to remove the old database Troubleshooting: 1. Firstly, please use Set-EventLogLevel to set "MSExchangeIS\9001 Public\Replication Incoming Messages" and "MSExchangeIS\9001 Public\Replication Outgoing Messages" to Expert level in EMS on the old server and new server 2. Please use Get-PublicFolderStatistics to check what is still left, there may have two EX:/o=MyCompany/ou=First Administrative Group folders, one of them is the replica. If the replica of this folder has been removed, we may only see one with 0 ItemCount, if there are two, please go to step 3 3. Please go to the PF Mgmt Console, locate the EX:/o=MyCompany/ou=First Administrative Group folder, right-click it and select Properties. In the Replication tab, verify if old database still exists in the replica list, if yes, please remove it 4. Now, please dismount and remount the old database, and use Get-PublicFolderStatistics to check again. see if theres only one EX:/o=MyCompany/ou=First Administrative Group folder with 0 ItemCount, if yes, we can remove the database now, if not, please go to step 5 5. Please check the replication incoming/outcoming event between old server and new server, please refer to this article Resources: How to Get Statistics for Public Folders
Free Windows Admin Tool Kit Click here and download it now
May 20th, 2009 6:31am

Thanks for the quick response.Before I proceed, I should mention that there is only one "EX:/o=MyCompany/ou=First Administrative Group folder, butthe item count is "2".
May 20th, 2009 2:19pm

Ok, that shall be the replica of the folder, please troubleshoot the issue based on the steps
Free Windows Admin Tool Kit Click here and download it now
May 21st, 2009 1:33am

Thanks.The old server was not in the replication list for the problemPF, so I couldn't use that as a solution. In fact there were no servers in the list.After reading just a short bit from the article you sent, it gave me an idea. I added the old server back to the replication list of the problem PF and I ran MoveAllReplicas.ps1 again. After about 15 minutes, when I ran GetPublicFolderStatistics the folder was finally gone. I was then able to delete the PF database and the store.
May 22nd, 2009 2:15pm

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics