xml schema not working in excel 2010 - xml corrupt

I originally posted this thread in Microsoft Answers but was suggested to post here...

I upgraded from xl2003 to xl2010. I'm trying to map xml schemas to xl2010 (using the source pane just as I did for xl2003) and the mapping works fine until I save the file and reopen it. Once I reopen the file and try accessing the map through the XML source pane, I get an error identifying the xml map is corrupt as follows:

"The operation cannot be completed because the XML map is corrupt

To fix this problem, remove the associated xml map from the workbook and then add the XML map back to the workbook.

/schecma/element[1][@name = 'returnData']/complextype[1]/complexContent[1]/extension[1]Undefined <complexType>, '{http://www.....' is used as a base type."

I've tried this in xl2007 and it works fine. I also read some blogs about xl2010 xml features and in some I found that this new version has enhanced security xml features.

Any help would be appreciated.

"innovation is the key to success"

November 22nd, 2011 3:10am

Thanks for your feedback.
After checking our internal database, the issue had been delivered to our development team and they have already tried to repair it.
The problem might be fixed in Office Hotfix recently or next service pack release.

Thanks.


Free Windows Admin Tool Kit Click here and download it now
November 24th, 2011 6:19am

Any Update from Microsoft on this.

It is over a year since this was posted and I cannot find a fix or a non-programatic work-around to this problem which I am also experiencing.

October 30th, 2012 11:41am

I am also recently having this issue after upgrading from Office 2003 to Office 2010
Free Windows Admin Tool Kit Click here and download it now
November 5th, 2012 8:26pm

Hi,
The same problem in Excel 2013, so the problem isn't solved.

Greetings

Danny Van Neyghem

July 31st, 2013 3:59pm

Interesting to note this is still a problem, but even more interesting is as to why Excel works fine the first time you bring in the xsd, but not after you save it.  I found information that says it's related to resolving externally referenced xsds, which is fine, but again, why does it work the first ime and not the second?   If it were a problem with external xsds then it should never work at all so I think that answer is bogus.

Something has to be getting corrupted on the save and it's not important enough to MS to spend the time to fix it.


  • Edited by SDL-USA Monday, March 31, 2014 9:14 PM
  • Proposed as answer by KilgoreTrout1 Wednesday, May 07, 2014 3:22 PM
Free Windows Admin Tool Kit Click here and download it now
March 31st, 2014 9:13pm

I was able to resolve this by flattening the schema in XMLSpy first and then loading it into Excel.  Hope that helps!
May 7th, 2014 3:24pm

Hi SDL-USA,

Did you ever get a resolution to this problem? I'm having a similar issue at the moment.

Paul.

Free Windows Admin Tool Kit Click here and download it now
May 19th, 2014 1:35pm

I am still facing this issue.

I am trying since last week. It is letting you map the XML shema properly and also allowing you to import the XML without any error but after save, If I try to import it is thrwing the XML MAP IS CORRUPT error. And the same map is working fine with the EXCEL 2007.

Can we have resolution on this?

And above of it is not allowing me even to delete the existing map.

August 28th, 2015 3:49am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics