reset search index generates "target principal name is incorrect" error

HI guys,

Im getting an issue on crawling my content sources on a SharePoint 2013 Farm whereby the full crawl is not completing and indefinetely crawling. to try to resolve issue I stopped the crawl and tried resetting my search index. now I'm getting below error:


Grateful if you could help! Below is unexpected level ULS logs:

05/26/2015 11:37:16.84 w3wp.exe (0x1EF4) 0x13C0 SharePoint Foundation General ajlz0 High Getting Error Message for Exception System.InvalidOperationException: Failed to connect to system manager. SystemManagerLocations: net.tcp://<Server name>/6C4FB2/AdminComponent1/Management ---> System.ServiceModel.Security.SecurityNegotiationException: A call to SSPI failed, see inner exception. ---> System.Security.Authentication.AuthenticationException: A call to SSPI failed, see inner exception. ---> System.ComponentModel.Win32Exception: The target principal name is incorrect     --- End of inner exception stack trace --- 
    at System.Net.Security.NegoState.StartSendAuthResetSignal(LazyAsyncResult lazyResult, Byte[] message, Exception exception) 
    at System.Net.Security.NegoState.StartSendBlob(Byte[] message, LazyAsyncResult lazyResult) 
    at System.Net.Security.NegoState.CheckCompletionBeforeNextSend(Byte[] message, LazyAsyncResult lazyResult) 
    at System.Net.Security.NegoState.ProcessReceivedBlob(Byte[] message, LazyAsyncResult lazyResult) 
    at System.Net.Security.NegoState.StartSendBlob(Byte[] message, LazyAsyncResult lazyResult) 
    at System.Net.Security.NegoState.ProcessAuthentication(LazyAsyncResult lazyResult) 
    at System.Net.Security.NegotiateStream.AuthenticateAsClient(NetworkCredential credential, String targetName, ProtectionLevel requiredProtectionLevel, TokenImpersonationLevel allowedImpersonationLevel) 
    at System.ServiceModel.Channels.WindowsStreamSecurityUpgradeProvider.WindowsStreamSecurityUpgradeInitiator.OnInitiateUpgrade(Stream stream, SecurityMessageProperty& remoteSecurity)     --- End of inner exception stack trace ---    Server stack trace:  
    at System.ServiceModel.Channels.WindowsStreamSecurityUpgradeProvider.WindowsStreamSecurityUpgradeInitiator.OnInitiateUpgrade(Stream stream, SecurityMessageProperty& remoteSecurity) 
    at System.ServiceModel.Channels.StreamSecurityUpgradeInitiatorBase.InitiateUpgrade(Stream stream) 
    at System.ServiceModel.Channels.ConnectionUpgradeHelper.InitiateUpgrade(StreamUpgradeInitiator upgradeInitiator, IConnection& connection, ClientFramingDecoder decoder, IDefaultCommunicationTimeouts defaultTimeouts, TimeoutHelper& timeoutHelper) 
    at System.ServiceModel.Channels.ClientFramingDuplexSessionChannel.SendPreamble(IConnection connection, ArraySegment`1 preamble, TimeoutHelper& timeoutHelper) 
    at System.ServiceModel.Channels.ClientFramingDuplexSessionChannel.DuplexConnectionPoolHelper.AcceptPooledConnection(IConnection connection, TimeoutHelper& timeoutHelper) 
    at System.ServiceModel.Channels.ConnectionPoolHelper.EstablishConnection(TimeSpan timeout) 
    at System.ServiceModel.Channels.ClientFramingDuplexSessionChannel.OnOpen(TimeSpan timeout) 
    at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout) 
    at System.ServiceModel.Channels.ServiceChannel.OnOpen(TimeSpan timeout) 
    at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout) 
    at System.ServiceModel.Channels.ServiceChannel.CallOnceManager.CallOnce(TimeSpan timeout, CallOnceManager cascade) 
    at System.ServiceModel.Channels.ServiceChannel.EnsureOpened(TimeSpan timeout) 
    at System.ServiceModel.Channels.ServiceChannel.Call(String action, Boolean oneway, ProxyOperationRuntime operation, Object[] ins, Object[] outs, TimeSpan timeout) 
    at System.ServiceModel.Channels.ServiceChannelProxy.InvokeService(IMethodCallMessage methodCall, ProxyOperationRuntime operation) 
    at System.ServiceModel.Channels.ServiceChannelProxy.Invoke(IMessage message)    Exception rethrown at [0]:  
    at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg) 
    at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type) 
    at Microsoft.Ceres.CoreServices.Services.Node.INodeControllerManagementAgent.get_NodeName() 
    at Microsoft.Ceres.CoreServices.Tools.Management.Client.AbstractSystemClient.TryConnect(Uri nodeManagementUri, ICollection`1 locationsToTry, ICollection`1 triedLocations, ICollection`1 nodeSystemManagerLocations)     --- End of inner exception stack trace --- 
    at Microsoft.Office.Server.Search.Internal.UI.SearchCentralAdminPageBase.ErrorHandler(Object sender, EventArgs e) 
    at Microsoft.Office.Server.Search.Internal.UI.SearchCentralAdminPageBase.OnError(EventArgs e) 
    at System.Web.UI.Page.HandleError(Exception e) 
    at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) 
    at System.Web.UI.Page.ProcessRequest(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) 
    at System.Web.UI.Page.ProcessRequest() 
    at System.Web.UI.Page.ProcessRequest(HttpContext context) 
    at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()     at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) 1c150a9d-96a8-f02f-ff0a-c9d3f7a40f76

May 26th, 2015 10:09am

Hi,

Do you have multiple domains on this server?

Free Windows Admin Tool Kit Click here and download it now
May 26th, 2015 10:13am

If you are using Hyper-V machine for SharePoint 2013. Please check below links.

http://www.jrjlee.com/2013/01/the-target-principal-name-is-incorrect.html

http://www.bradcoe.com/wordpress/?p=35


May 26th, 2015 10:14am

Thanks for the reply Narula. I checked this article but the Central Administration Works fine. Its just when I am trying to reset index that I am having the error.

I tried restarting the server and trying to reset search index again but had same error only when clicking on search index.

The farm belongs only to one Domain environment.

Can the issue described in the link relate to only the search application?


Free Windows Admin Tool Kit Click here and download it now
May 26th, 2015 12:36pm

Hi RhyanM,

Firstly, make sure that the search service account have dbowner role on all search databases, then restart the server, compare the result.

If this issue still exists, please check the service accounts of SharePoint Timer Service and SharePoint Search Host Controller service, add a SPN entry for each the service account as the following command:

Setspn.exe -A HTTP/<the name of SharePoint server> <service account>

After the above, do an IISREST.

Here is a similar post for your reference:
https://social.technet.microsoft.com/Forums/systemcenter/en-US/9deb1d13-088a-421b-b926-2f9034795e01/sharepoint-2013-error-admin-component-is-not-up-and-running?forum=sharepointsearch

Thanks,

Wendy

May 27th, 2015 3:48am

Hi,

based on the log, I would actually rather check if SPNs on the SQL side are correct. You need to check if SPN is registered and if it is registered on the right SQL account.

run command:

SETSPN -Q MSSQLSvc/[sql server name]

if you have instance for SharePoint, run the following command

SETSPN -Q MSSQLSvc/[sql server name]\[instance name]

Check the results and be careful to which account this SPN is registered.

Go to your SQL server and check if the instance is running under account that SPN is registered to.

Hope this helps

Free Windows Admin Tool Kit Click here and download it now
May 28th, 2015 2:14am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics