datasource error using ssrs
Hi I am working on the migration of our production servers. I have one problem with SSRS its configured and working however when i try to run the report from any client machine it gives me following error message . This problem is only on client machines not on local server the same report works on live database server . An error has occurred during report processing. (rsProcessingAborted) Cannot create a connection to data source 'MyDataSource'. (rsErrorOpeningConnection) For more information about this error navigate to the report server on the local server machine, or enable remote errors We have SQL server 2005 (Standard Edition 64-Bit) running on Windows 2008 Server R2 Regards Tabbasi
November 24th, 2011 3:45am

Hi, Use proper credentials which has access to the database server. If reports are deployed in native mode report server then open report manager datasource property. Configure any of the below options with correct credentials which has access rights to data. Credentials supplied by the user running the report Use as Windows credentials when connecting to the data source Credentials stored securely in the report server Windows integrated security Credentials are not required Please check your datasource property from report manager. Hope this helps..Regards, Senthil
Free Windows Admin Tool Kit Click here and download it now
November 24th, 2011 4:11am

Hi, With security only on Reports and there is no data level security on the DataSource then, - For window integrated security, use Impersonation by 1. Configure the "Credentials stored securely in the report server" by providing Windows credentails and check the "Use as Windows credentials when connecting to the data source" and "Impersonate the authenticated user after a connection has been made to the data source" checkbox. 2. If your organisation has a execution account setup, then configure the SSRS execution account in Reporting Services onfiguration Manager and set the "Connection Using" as "Credentials are not required". This intern uses the configured execution account. -For SQL authentication, the SSRS configure the imprersonation details for SQL Authentication on data source by using "Credentials stored securely in the report server" option. Thanks, Suhas Hsuhas
November 24th, 2011 4:29am

Hi Thanks for your prompt replies . I did the following operations on new server . 1: Deleted and restored all databases . Reconfigured the user Mappings with respect to old production server . 2 Now using the reporting services configuration tools i re created all virtual directories , On configuring the Windows Service Identity i am getting the following error message . System.Data.SqlClient.SqlException: Could not locate entry in sysdatabases for database 'ReportServerSQL'. No entry found with that name. Make sure that the name is entered correctly. at System.Data.SqlClient.SqlConnection.OnError(SqlException exception, Boolean breakConnection) at System.Data.SqlClient.SqlInternalConnection.OnError(SqlException exception, Boolean breakConnection) at System.Data.SqlClient.TdsParser.ThrowExceptionAndWarning(TdsParserStateObject stateObj) at System.Data.SqlClient.TdsParser.Run(RunBehavior runBehavior, SqlCommand cmdHandler, SqlDataReader dataStream, BulkCopySimpleResultSet bulkCopyHandler, TdsParserStateObject stateObj) at System.Data.SqlClient.SqlCommand.RunExecuteNonQueryTds(String methodName, Boolean async) at System.Data.SqlClient.SqlCommand.InternalExecuteNonQuery(DbAsyncResult result, String methodName, Boolean sendToPipe) at System.Data.SqlClient.SqlCommand.ExecuteNonQuery() at Microsoft.ReportingServices.Common.DBUtils.ApplyScript(String connectionString, String script) at ReportServicesConfigUI.SqlClientTools.SqlTools.ApplyScript(String connectionString, String script) any ideas about that ??? Regards Tabbasi
Free Windows Admin Tool Kit Click here and download it now
November 24th, 2011 6:53am

Hi I set the data source with no Credentials but still same problem . Tabbasi
November 24th, 2011 8:43am

Did you delete the ReportServer database and restore it? Looks like you need to map the database in the SSRS Report Server Configuration to the restored database. on the initial problem, the connectivity is the problem. There could be multiple reasons. 1. Reports were deployed with option to take the logged in user credentials. if that is the scenario, then, the user needs to have permission on the database. that will be a problem and better to change it to a common user. 2. There is a problem in connecting to the database from the client machine. Probably different network or a WAN or Firewall issues. This could be a minor chance. But, better probe that option.
Free Windows Admin Tool Kit Click here and download it now
November 24th, 2011 9:16am

Hi Well i am using the reporting services on same network. Any was the second problem solved i re created the service database and that problem solved . First problem is solved i removed every user from database removed the virtual directories from IIS then re configured the reporting services , re mapped the users on database now problem is solved . Strange thing is i did the same things before however it was not solved . Thank you all for your prompt replies . Regards Tabbasi
November 25th, 2011 3:46am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics