Windows Service not discovered on one of the servers

 Hi experts,

    I have a following problem - on one of the servers SCOM 2012 does not discover the windows service, that is supposed to be monitored by Windows Service template monitor I created. Service is present and discovered properly on any other servers running it. Any hints were to start looking for solution? Everything else seems healthy on the server, no relevant Warnings in Ops Mgr event log, object is green in SCOM

May 29th, 2015 8:17am

try to clear agents cache and flush it's state on the server where it fails to discover service.
Free Windows Admin Tool Kit Click here and download it now
May 29th, 2015 8:36am

    Forgot to say - this was already done of course. Service stopped, health service state folder rwmoved, service restarted. No changes
May 29th, 2015 8:41am

Is the service startup Automatic? Or Manual? If it's manual, you will need to override the monitor to monitor manual-startup services.
Free Windows Admin Tool Kit Click here and download it now
May 29th, 2015 3:39pm

May be your service in this machine is not run automatic. By default, Windows Service template monitor only monitor automatic windows service. If your windows service is not run automatic, you should modify your windows service template monitor by clearing "monitor only automatic service" option.

Roger

May 31st, 2015 2:21pm

Hi There,

As mentioned above, please see if the startup type of the windows service is set to automatic, as SCOM will not monitor the service if it is in Disabled or Manual state.

Also can you check the override summary if you are using a unit monitor for basic service monitoring ?

Also what is the status of the monitor VIA Health explorer is it Healthy or is it Not Monitored ?

Post the results here.

Free Windows Admin Tool Kit Click here and download it now
May 31st, 2015 4:38pm

 Hi guys, thank you for input. Yes the service is set up to Automatic. The whole object is healthy, but the monitor does not even show up under local application roll-up on this particular server. As for the "Unit Monitor for Basic Service Monitoring" I think I didn't get the question, could you please elaborate a bit more? The Windows Service tamplate monitor is active for a group, and the server is a member of this group
June 2nd, 2015 3:19am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics