Windows Process Activation Service is not running
Hi Guys, First of all thanks to you all for giving time to go through this. I am in a very typical problem here, and need a bit of your help. I am having a machine with below configuration: Processor: Intel Core i5 @1.6 GHz; Storage: 128 GB SSD, RAM: 8 GB; I installed a fresh Windows Server 2008 R2 64 bit on this machine, then installed IIS 7, then installed SQL Server 2008 R2, then installed all SharePoint Server 2010 Prerequisites from external HDD store, then installed SharePoint Server 2010; then ran the Configuration wizard. I ha no complaint regarding the speed of the machine until I installed SharePoint 2010. Post installation and configuration I got the default SP Page launched. Then I restarted the machine. Here from the problem starts. Find below the issues - 1. It took 1 hr 15 mins to get restarted an show me the Desktop. 2. Though system got restarted but lots of Services were stopped. Like WAS, W3SVC etc... I launched the inetmgr, and observed all the application pools are stopped, I gone to start some of them but it thrown - 'Application pools cannot be started unless the Windows Process Activation Service (WAS) is running.' Then I tried check thru EventViewer regarding the WAS Log. but I couldn't get anything logged regarding the same. I did a lot of things to start the WAS but no luck. I tried from the Service list as well but it thrown 'Error:1053...The service is not responded in a timely manner...'. So now I am standing here being very helpless. Can any one of you please help me a bit in this regard. Any help is highly appreciated. Thanks Preetam
July 24th, 2012 4:55am

Guys any answer to this?Preetam
Free Windows Admin Tool Kit Click here and download it now
July 24th, 2012 5:34am

Hi Preetam, Welcome to the forums and thanks for your post. It's often good form to wait a day or so before bumping for a response. These forums are for the most part manned by volunteers outside of an SLA, so response times can vary. MS staff and paid Technet support staff also post in the pre-2010 forums, and I suspect they'll answer this when it becomes visible to them. First thing I'd suggest is logging into Central Admin and seeing what the Health Analyzer tells you. It's odd tha some of the services aren't running. I'd aslo suggest looking into the dedicated 2010 administration forums and running a search. Lots of good suggestions in there. Steven Andrews | SharePoint Professional | |
July 24th, 2012 6:29am

Hi Andrews Thanks for u rply. Central Admin can't work when the associated App Pool is stopped. So I cudnt hv a look thr.Preetam
Free Windows Admin Tool Kit Click here and download it now
July 24th, 2012 6:42am

Good spot. You didn't generate any errors in the configuration wizard?Steven Andrews | SharePoint Professional | |
July 24th, 2012 7:06am

No there were no errors during Configuration Wizard steps...It completed Successfully.Preetam
Free Windows Admin Tool Kit Click here and download it now
July 24th, 2012 7:18am

Guys, There is one thing that I would like to mention - last night when I restarted the machine it took huge time to restart as I mentioned above. Then I hibernated the system, today morning few hours back when I powered on and restarted the machine it's so fast that I can't imagine. But, still the problem is there WAS is not running and neither the AppPools as well. Then I decided to have a comparison look with an another real time environment. Please find below under the Dependencies tab, I saw that WAS depends upon RPC service. Which is being displayed in that List field control. But, in my environment RPC is not being displayed in that field. And in that another environment under RPC there are two other sub processes are listed DCOMServerProcessLauncher and RPC Endpoint Mapper. So, this was regarding WAS service dependency. Now, regarding the Services which depends on WAS to Start. According to that remote environment there are 4 processes, which depends on WAS to start; these are - Net MSMQ listener Adapter, Net Pipe listener Adapter, Net TCP listener Adapter, W3SVC. But, in my case none of these are listed in the respective field. Please note - this remote environment is having MOSS 2007 installed on Windows Server 2008 R2. One another thing that I would like to mention, whenever I am going to view my System Properties - most of the info is being displayed as Not Available. Is it also bcoz of any service unavaibility, since previously there were no such problem. Please suggest on it. Preetam
July 24th, 2012 10:46am

Friends, please reply...feeling very helpless.Preetam
Free Windows Admin Tool Kit Click here and download it now
July 30th, 2012 1:28pm

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics