Windows 7 Enterprise won't complete "Checking for Updates"
Fresh install of Windows 7 Enterprise 32bit w/ SP1.  When either the Automatic Updates run or you manually run Windows Update, SVCHOST.EXE process shoots to 100% CPU, RAM climbs to 700mb on the same PID, and the system just stalls.  I've spent 3 days searching every forum I can find, running every fix, hotfix, script etc.  I can't figure it out.  Thanks in advance.  
July 23rd, 2015 2:22am

I've also now tested Windows 7 Professional 32bit w/SP1.  Same issue.  If I install vanilla Windows 7 of either version it works fine until I put SP1 on.  I'm at a loss.  
  • Edited by Dolarin Thursday, July 23, 2015 4:07 AM
Free Windows Admin Tool Kit Click here and download it now
July 23rd, 2015 4:07am


Regarding to your posts, I understand that you main issue is that CPU usages reached 100% when you are checking updates after you installed SP1.

For checking updates, the related services is Windows update service. If the service is corrupted, we may encounter such issue as never stopping checking updates and high CPU usage.

Please run following commands to scan and repair system, make sure to run as administrator:


And command:

dism /online /cleanup-image /restorehealth

If we cannot fix this issue by above commands, please try to use Process explorer to view which other certain process which called svchost use much CPU.

Process Explorer 

Once you download it, just run the exe file as it does not have to be installed. Hover your mouse over the svchost process and youll get a popup showing you which services are running under that process. If you noticed any 3<sup>rd</sup> part process or driver related process, please disable or remove and reinstall to fix this issue.

In addition, if the issue still persists, please try to reinstall SP1 via standalone installer in clean boot mode to check if the issue still persists.

July 24th, 2015 7:42am

Tried both of those.  All is clean.  Have reinstalled both Ent and Pro 15 times, same result each time.  Have also verified this issue on existing machines.  Is there something going on with the Windows Update service?  I talked to our ISP (we have 500mb fiber) and they said they are seeing the same issues.  Their only conclusion is that this is something with Microsoft gearing up for the Windows 10 implementation.  Can anyone speak to this?  We can't be the only ones dealing with this, but I can't find any recent posts anywhere about people having this issue.  Any help would be great as I'm basically stuck not being able to run Windows Updates.  Thanks. 
Free Windows Admin Tool Kit Click here and download it now
July 24th, 2015 3:31pm

This may be related?

If you use WSUS or ConfigMgr, also read this:

July 25th, 2015 2:46am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics