Where does Report Builder 2.0 save credentials?
Hello, In which folder does Report Builder 2.0 save credentials, when "save credentials" checkbox is checked? There is no way to delete saved credentials from Report Builder 2.0 or find the folder where it stored the credentials. Report Builder 2.0 automatically logs in using the saved credentials and does not prompt or give an opportunity to alter/delete the saved credentials. This causes a lot of confusion while testing security and among adhoc reporting users (end users) because Report Builder 2.0 doesn't share the session with the currently logged in user on the SSRS server who invoked Report Builder, but automatically logs in using saved credentials which could be a different user. Thanks
November 30th, 2010 7:56pm

Hi James, Report Builder 2.0 is just a report authoring tool. We can grant proper permissions to the users to determine whether they can use or not. While the credentials should be associated with reports, the report datasource credential type determines how the users are authenticated to access reports. thanks, Jerry
Free Windows Admin Tool Kit Click here and download it now
December 1st, 2010 9:58pm

maybe you're referring to the browser dialog box for the credentials. Clear the browser cache and passwords and see if that works.Laura Rogers, MCSE, MCTS SharePoint911: SharePoint Consulting Blog: http://www.sharepoint911.com/blogs/laura Twitter: WonderLaura Beginning SharePoint 2010: Building Business Solutions with SharePoint
December 1st, 2010 11:15pm

Hi Jerry and Laura, I think I haven't expressed well the problem I am facing. Users use Report Builder 2.0 to author adhoc reports. When Report Builder 2.0 is invoked, it pops up a "login" window to authenticate users. User can then enter username and password and everything is sweet after that. However, the same login window has an option "save credentials" (or "save password"). If the user selected this checkbox, Report Builder 2.0 saves the username/password to some settings file locally and next times it doesn't show the login window at all. This is all good until the user wants to log in with different username/pasword (for example, to test security).
Free Windows Admin Tool Kit Click here and download it now
December 8th, 2010 7:47pm

Hi Jerry and Laura, I think I haven't expressed well the problem I am facing. Users use Report Builder 2.0 to author adhoc reports. When Report Builder 2.0 is invoked, it pops up a "login" window to authenticate users. User can then enter a username and a password and everything is sweet after that. However, the same login window has an option "save credentials" (or "save password"). If the user selects this checkbox, Report Builder 2.0 saves the username/password to some settings file locally and next times it doesn't show the login window at all. This is all good until the user wants to log in with a different username/pasword (for example, to test permissions).
December 9th, 2010 3:45am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics