When accessing SharePoint or Central Administration 3.0 a "503 Service Unavailable" error is returned, App Pools stop.
I am running a MOSS 2007 server in a test environment. I have been off building other aspects of the environment, but I come back today and notice that SharePoint is no longer working. Whenver I try to access it or the Central Administration area I recieve a "503: Service Unavailable" error.I have also notice that after an IISRESET that the applications pools that are associated with the SharePoint sites (Extranet, Intranet, Sharepoint - 21075, and Central Administration fail to start on their own. I can start the manually. They are all running under the DOMAIN\Administrator account (as are ALL of the SharePoint related features. I know, I know, but that is what the requestor of this test environment requested).Additionally the following error codes are logged (NOTE: These are translated from German):-----------------------------------------Event ID: 6641Source: Office Sharepoint Server-----------------------------------------The SSP timer Mandate for import distribution lists did not execute.Reason: Registration failed: The user does not have the required logon on this computer.-----------------------------------------Event ID: 2424Source: Office Server Search-----------------------------------------The update cannot be started because there is no access to the content sources. To correct the mistakes and start updating again.Context: Application 'SharedServices1' Catalog 'Portal_Content'Also, I am seeing in the security log:-----------------------------------------Event ID: 4625Source: Microsoft Windows Security Auditing-----------------------------------------Basically this shows that there was a logon failure for account "DOMAIN\Administrator" from process C:\Programme\Common Files\Microsoft Shared\Web Server Extensions\12\BIN\OWSTIMER.EXE-----------------------------------------Event ID: 5059Source: System-----------------------------------------The application pool "Sharepoint - Intranet80" has been disabled. Error in the Windows Activation Process Service (WAS) at the start of a working process for the application pool.I get one of the above errors for each of the pools associated with SharePoint.The SharePoint server is also a DC. I have also noticed that after I manually restart the Application Pools, if I then try to visit "Intranet" (for example) that the application pool associated with that site immediatly stops.
July 29th, 2008 1:17am

I suspect that the password was changed for the administrator account.--Paul Galvin of www.Conchango.com @ http://feeds.feedburner.com/PaulGalvinsSharepointSpace
Free Windows Admin Tool Kit Click here and download it now
July 29th, 2008 2:46am

Good guess, that is what most of the articles that I have looked at have implied, but this is not the case. I even tried reentering the password via the stsadm "updatefarmcredential" method to no avail.Thank you for responding though and I would be interested in any other suggestions you might offer.
July 29th, 2008 2:54am

I have also noticed that even when I try to change the account that the SharedServices1 app pool runs under that it changes itself back to the domain Administrator account.
Free Windows Admin Tool Kit Click here and download it now
July 29th, 2008 3:04pm

use this commmand for update SSP credential:stsadm.exe -o editssp -title SharedServicesProviderName -ssplogin DomainName\UserName -ssppassword NewPasswordor use the GUI.It's also seems that administrator don't have access to SQL Server 2005 (error 2424), don't have logon privileges (6641,4625)Are you sure you don't have change Administrator password in AD? if not try to create a new User with domain admin privilegies and change service account with this user. (Attention!! change ALL service account with stsadm or with GUI!!!)Regards,Francescowww.sharepointinside.it
July 29th, 2008 3:22pm

So I just want to confirm the process.1) Create new user.2) Add that user to the Domain Administrator group (It is on a DC so no Local Admin).3) Give that user permission to the appropriate databases.4) Use the command you posted to change the SharedService1 SSP to run under the authority of the new account.5) Change the application pools for the sites associated with SharedService1 to that same account.Is that all? Do I have to change any of the Sharepoint services to run under the new account? Any other clean up work that you can think of?
Free Windows Admin Tool Kit Click here and download it now
July 29th, 2008 3:41pm

So I just want to confirm the process.1) Right!2) Right!3) If you add the user to Domain Admin and SQL in on the server, the account should beDb:ower for all DB..4) No.. change all services that Run with DOMAIN\Administrator with the new User (stsadm or GUI is indifferent)5) See 4Follow this article, for change ALL services and application pool that run withDOMAIN\Administratorhttp://support.microsoft.com/kb/934838/en-usRegards,Francescowww.sharepointinside.it
July 29th, 2008 3:52pm

Thank you very much for you quick response.I will try to implement your suggestion and report back the results.Again, thank you.Best Regards,Richard
Free Windows Admin Tool Kit Click here and download it now
July 29th, 2008 3:54pm

1) Created new domain account "SPSrv".2) Added account "SPSrv" to the "Domain Admins" group.3) I changed the "Office SharePoint Server Search", "Windows SharePoint Services Search", and "Windows SharePoint Services Timer" services to run under the new "SPSrv" account. They were all running under the "DOMAIN\Administrator" account previously.4) I go tohttp://support.microsoft.com/kb/934838/en-usand complete all the parts of step 1. When I try to launch the Sharepoint Central Administration area I still receive the "HTTP Error 503. The Service is unavailabe." Error.I can see in the Application Pool listing in the IIS Manager that the Central Administration pool has changed to run under the new account, but the SharedServices1 pool is still running under the DOMAIN\Administrator account. Does this need to be changed as well before I can launch the Central Administration area and continue on with the steps that you recommended?I appreciate your help and experience.Best Regards,Richard
July 29th, 2008 4:10pm

Oh, I should also add that after I tried to launch the Central Administration area and then went back to look at the application pool I noticed it had stopped, just as before.
Free Windows Admin Tool Kit Click here and download it now
July 29th, 2008 4:11pm

If it helps, here (http://img292.imageshack.us/img292/9040/apppoolscreenuz5.jpg) is a link to a screen shot of the Application Pool area in IIS. The server is in German, but it is still easy to understand.
July 29th, 2008 4:27pm

It's in German.. but it's also WIN2008! :) i think this is very important!is MOSS 2007 in Sp1?www.sharepointinside.it
Free Windows Admin Tool Kit Click here and download it now
July 29th, 2008 4:59pm

Yes it is a German Server 2008. Is that important?It is MOSS 2007 SP1.I went through the steps in KB article #934838 (the one you posted) except for steps 2.A and 2.B (because I cannot access the Central Admininstration area and I still came back with the same 503 error.All Sharepoint Services and application pools are now running under the account you had me create.
July 29th, 2008 5:10pm

Yes, it's very important!try this workaround Disable IPv6 on the NICRemoved the entry from the hosts file. (if there are)Restart the serverThe entries are then added back using the IPv4 address (if there are)Broken again by enabling ipv6Removing the ipv4 entry from the hosts fileRestarting the Windows SharePoint Services Search and Office SharePoint Services Search serviceNow restart the application pools in IIS and you should be able to browse the sites. Regards,Francescowww.sharepointinside.it
Free Windows Admin Tool Kit Click here and download it now
July 29th, 2008 5:19pm

So I restarted the server so I could see if that made a difference, I still am getting the same 503 error.Application Log:-----------------------------------------------------The event 6641 which says (translated):"The SSP-Timer Mandate for import distribution lists did not execute.Reason: Registration failed: The user does not have the required logon on this computer"-----------------------------------------------------Security Log:-----------------------------------------------------Event 4625I am seeing failed logins for the new account we created "SPSrv".The referenced process name is the OWSTIMER.exe process. The source is Microsoft Windows Security Auditing.-----------------------------------------------------System Log-----------------------------------------------------Error 5059Still seeing the WAS errors in the system log. There is an 5059 error forEACH of the sharepoint sites that is part of SharedServices1."The application pool "Sharepoint -intranet80" has been disabled. Error in the Windows activation process service (WAS) at the start of a working process for the application pool"-----------------------------------------------------
July 29th, 2008 5:21pm

Have you tried my new solution, it seems that NIC IPv6 generates this problem only on windows server 2008.www.sharepointinside.it
Free Windows Admin Tool Kit Click here and download it now
July 29th, 2008 5:25pm

I am trying it now. Thank you. I will report in a few minutes.
July 29th, 2008 5:26pm

What entries should I be removing in the host file? The only ones that I had were the IPv4 and IPv6 "localhost" entries.
Free Windows Admin Tool Kit Click here and download it now
July 29th, 2008 5:28pm

Ok... that was not a good idea.When I tried to restart the server it hung on the stopping services step. I had to do a hard reboot and it wouldn't allow me access to any of the applets or mmc areas. I was able to browse to the hosts file and uncomment the two localhost entries that I commented out. I tried to restart again and it hung so I had to do another hard reboot, god I hope this isn't messed up now =X
July 29th, 2008 5:39pm

Sorry Richard,i think to comment only NOT STANDARD IPv6 entry on host file.www.sharepointinside.it
Free Windows Admin Tool Kit Click here and download it now
July 29th, 2008 5:41pm

Yes.... now nothing works. Even after logging into Safe Mode and uncommenting the host file, then re-enabling IPv6, rebooting. I cannot access any menus, windows, mmcs, after about 15 seconds even the start menu becomes un-responsive....
July 29th, 2008 5:55pm

Well, that was interesting. I walked away for a brief moment to go punch a wall and when I came back it had resolved itself. Now I am back where I started. 503 Errors, App Pools stopping on its own. At least I can interact with the desktop now! =]
Free Windows Admin Tool Kit Click here and download it now
July 29th, 2008 5:59pm

Try to complete the action plan!my solution is also reported here:http://blogs.msdn.com/jmacleod/archive/2008/06/25/iis7-sharepoint-2007-fails-with-503-service-unavailable-errors.aspxand in same microsoft Service Request.www.sharepointinside.it
July 29th, 2008 6:12pm

Yeah, I don't think that is applicable because I don't have those entries in my host file, I also am not running any 64 bit equipment. Also the event log errors I am seeing are a little bit different.Best Regards,Richard
Free Windows Admin Tool Kit Click here and download it now
July 29th, 2008 7:05pm

From the sound of it the account you are using to run the SharePoint App Pools with has not been granted the log on as a service and log on as a batch job rights.I'm not sure which one is needed but enabling both shouldn't cause any issues.This can either be done locally or via group policy.Not sure if this will solve the problem but thought I would post this as I was getting the same problems and that fixed it.RobinRobin Wilson
August 15th, 2008 10:36pm

Same symptoms. In fact I was not able to open the default site too (which had nothing to do with Sharepoint) and I still got 503 error and the Default AppPool stopped. There were no errors for the same in the eventlog. I found the issue to be with the host file. I was trying to setup dedicated index server which added an entry to the host file. I deleted the extra entry from the host file and all started working again.Thanks!siaj
Free Windows Admin Tool Kit Click here and download it now
September 29th, 2009 12:30am

Open Service.msc from the runprompt and verify for any service which has log on as the domain users. Check all the app pools in Internet Information ServicesManager Log on Identity value and make it to local id or network service if any are there with domain user. Check the default credentials with which sites are able to access the Database and verify manually whether still the same credentials are working for connecting Database. Last but not least please check the host hard drive has atleast 2GB of harddisk in the active partition. Regards, Nagendra
October 1st, 2009 9:43am

Hi, I got 503 service unavailable error. I think this happens due to (atleast in mycase) domain password change. here is what I did to fix it after researching around.- Go to the "app pool" that is of interest to you > right click > "Advanced settings" > click "..." button > click Set... button > enter your user name and password.- Go to services.msc console and locate all sql related services and change the re-enter the password and start the services.- IISReset.try now.thx,Praveen Chettypally
Free Windows Admin Tool Kit Click here and download it now
October 16th, 2009 11:38pm

I ran into this as well and tore my hair out trying to figure out what was going wrong including, repair install of SP, removing windows updates, reconfiguring sharepoint and resetting all users for all web apps and services. Still did not work. The one thing that did the trick was that we implemented IPv6 1 week ago and windows updates came in. I unchecked the IPv6 option in the NIC and poof, everything came back (of course issuing an IISRESET and restarting all services dealing MS SQL and SharePoint for good measure.). Hope this helps. Remove IPv6 from your NIC. I am running Windows Server 2008 R2, MS SQL 2008 and SP 2007 SP1. Seems to only be a Windows 2008 R2 issue with SharePoint. --TR
January 23rd, 2010 2:27am

All,I confirm that enabling IPv6 will bugger MOSS SP1 (12.0.0.6219) running Windows Server Enterprise 2008 SP1 (non R2).Disabling IPv6 and rebooting the machine is the quickest fix; however, I'd like to understand why this happens and if there is a process to enable IPv6 w/o having this issue.I've not tried building the a MOSS server with IPv6 enabled; perhaps this works. In this instance it was disabled prior to installation of MOSS and enabling caused the issue.Regards,Kim
Free Windows Admin Tool Kit Click here and download it now
February 22nd, 2010 1:15pm

I just bumped into this issue (and this is probably the 10th MOSS 2007 server running on Windows Server 2008 64-bit I've built) in an environment where IPv6 and Group Policy are in use. I realize this is an older issue but I thought I would chime in anyways. Removing enhanced network functionality (read: IPv6) from the network server was not an applicable solution in my case, especially for the mid- to long-term. I found RobinWilson16's suggestion much more useful: Allow the AppPool account(s) to run as a Service and as a Batch job. This way IPv6 can remain enabled and after an IISRESET the WebApp(s) will stay started and the SSP will function correctly. In a domain envirnoment where GPOs are used, you'll need to get acquainted with a domain administrator with enough rights to add the accounts to the effective GPO (use GPRESULT /R to figure out which GPO(s) are applied to the MOSS server). Outside of a domain environment the rights shouldn't get trampled unless someone has been editing the local policy with a tool like SECPOL.MSC. Also, I'd recommend against using a hosts file for two reasons: 1) Environments tend to change, hosts files do not :) 2) Who remembers to remove those hostfile entries when they need to? I can't tell you how many times I've help users with "weird" name resolution problems that came down to bad entries in the hosts file either due to 'fat fingering' or because an IP address changed. :)MCP
April 20th, 2010 9:33pm

First Case#1: Interface IP configuration problem. Look your local driver E:\Windows\System32\drivers\etc\host If you see any entry like this: fe80::9069:9334:813e:868 ComputerName # Added by Office SharePoint Server Search (6/8/2010 4:45 AM). It means office sharepoint server is removing your ip 4 entry. Then you have problem of IP 4 & 6 conflicts so to solve it disactivate the IP V6 of your interface and remove the entry in host file, and run IISRESET. The problem has gone. Then your sp search is becoming stopping working because it has still the ip 6 address, and all your searching doesn-t work. to solve i just create new sp service and configure it. That is all every thing must work as before. Was it helpfull
Free Windows Admin Tool Kit Click here and download it now
June 9th, 2010 7:13am

I have the same problem too. To my surprise, i followed our friends suggestion to disable the IPv6 and restart the server. And now, i can access my site again.. if i found this thread earlies, i wont have to waste my time to disconnect and reconnect again sharepoint wizard.
July 19th, 2010 4:59pm

disabling ipv6 did the trick for me. thank you all for this thread.Drasko Popovic
Free Windows Admin Tool Kit Click here and download it now
November 2nd, 2010 9:28am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics