When Clicking a Document, Not Prompting with 'Read Only or Edit?'
Dear AllWe've had SharePoint 2007 for about 6 months. During that time if a user clicked on a document in a document library, they would receive a "Read only or edit" prompt. About a month ago, almost all of our users stoppedgetting this prompt. Now it says "Some files may harm your computer." If you click OK it goes straight into the document in read only mode.I've spent hours looking into it, to see if it was an XP service pack, Office service pack, in different versions of IE6 -- but I can't find anything. Yesterday, I tried so many things and managed to get it working again on my Vista machine - but I can't even work out how.I notice that when people are going into document libraries, they are no longer receiving the yellow blocker at the top of the browser which says "Run ActiveX control..." in SharePoint, even on laptops which have never been on our SharePoint site before.I dont believe it is security settings on the laptop though, because I've tried loads of different settings, including temporarily testing on the lowest setting.Please, please can anyone offer any assistance at all? I would be very grateful.Kind regardsDaniel
September 5th, 2008 11:54am

Normal you get the "read only or Edit" option if you have an Officer 2007 application install on the local machine, i.e. visio viewer 2007 for exampe.Unsure why it should stop showing. Where version of office are you using?
Free Windows Admin Tool Kit Click here and download it now
September 5th, 2008 12:40pm

We use Office 2003 here.I've tested Office with and without the latest service packs but it doesn't seem to be affected by that either. I also wondered if it might be related to the Alternate Access Mappings - that our web app needs to be in a particular zone for it to work but again I've tried varies combinations (Default, Internet, Intranet etc) but nothing.I've spent sooooo long on this issue :(
September 5th, 2008 12:45pm

found this ....."Office 2003 and 2007 Office documents open read-only in Internet Explorer".http://support.microsoft.com/kb/870853It does mention different security zones. Have you tried installing any 2007 apps just to see what happens?
Free Windows Admin Tool Kit Click here and download it now
September 5th, 2008 1:03pm

Thank you for looking that up. Unfortunately, I've been there and tried it already. The article stresses that it will not work with SharePoint sites but I gave it a shot anyway:"Important The following steps will have no effect when you open documents and hyperlinks from a Microsoft SharePoint Services site or a Microsoft Office SharePoint Portal Server site."It doesn't seem to make any difference.I've not tried installing 2007 -we are not in a financial position to upgrade everyone at the moment as we are a comprehensive school.I appreciate your help though latitude505
September 5th, 2008 5:56pm

Have you checked the library settings for that libraryunder advanced settins > require check out before edit..?Daniel Bugday Web: http://www.sharepointforum.com/ Blog: http://www.sharepointforum.com/en-US/Blog/
Free Windows Admin Tool Kit Click here and download it now
September 7th, 2008 2:55pm

Thanks for your message Daniel. Yes I have. I've tried both forcing the checkout before editing and with it turned off. Makes no difference.The problem isn't confined to one document library either. It happens everywhere throughout my SharePoint site :-( on all document libraries on a lot (possibly most) clients. Other clients are ok.Daniel
September 7th, 2008 3:00pm

Is there any difference between the clients that are working and those that are not? (version of office, client operating system etc)Try this on one of the clients that are not working: Go to Windows explorer under "Tools" --> "Folder options...", Select the "File types" option. Highlight the word file type (.doc and .docx) and click on the "advanced" button. The value corresponds to the first check box "Confirm open after download". If you remove this option, the files are opened without any prompt Daniel Bugday Web: http://www.sharepointforum.com/ Blog: http://www.sharepointforum.com/en-US/Blog/
Free Windows Admin Tool Kit Click here and download it now
September 7th, 2008 7:02pm

This makes the Word document open within the browser though doesn't it? I don't want the document to open within IE. I'd like it to prompt "Read only or edit" and then open it in Word, like it used to.I can't really find a trend with the machines that arent working. I've experienced this problem now on both Vista and XP, with IE 6 and IE7 with Office 2003, SP2 and SP3...I appreciate your help Daniel. It's one of those enormously frustrating ones.
September 7th, 2008 7:28pm

It's still going to open in word, but i'd like you to try the setting to see if it helpes you.Let me know,Daniel Bugday Web: http://www.sharepointforum.com/ Blog: http://www.sharepointforum.com/en-US/Blog/
Free Windows Admin Tool Kit Click here and download it now
September 7th, 2008 8:49pm

Thanks for that - I tried it out. It removes the "Some files may harm your computer..." message prompt and opens the document straight up in Word. But it is still not asking whether to open it in read only or edit. The document opens up in read only mode. So it doesn't really have any affect on this side.
September 10th, 2008 12:54am

Hi djs25ukWere you able to find a solution to this issue? Our MS Office 2003 users also reported the same issue. Any help will be highly appreciated. Thanks.
Free Windows Admin Tool Kit Click here and download it now
September 26th, 2008 9:00am

Hey Mavs, sorry I've had no luck on this issue at all, and have literally spent days on it now. I've tried every combination of OS, Office, service pack, IE and user I can think of and no luck.I can say for us, it definitely isn't a permissions issue on the document libraries as, for example, I get the 'edit/read' prompt on MY computer, but if I log on as me on, I don't get it - even though I'm attempting to access exactly the same documents.I have decided to train my users to use the 'Edit in Microsoft Word' option from the dropdown instead now as I can't spend any more time on it. Sorry I can't help more but if you ever find a solution, I'd be really grateful to hear from you.
September 26th, 2008 7:36pm

Me, too. I've spent weeks investigating this issue. And still, no luck until now. It seems to be working on my computer since I'm using SharePoint Designer 2007. But, others with MS Office 2003 installed are claiming that this prompt is working before.The context menu "Edit in Microsoft Word" seems not be a valid work-around for them. I'll try to investigate further and let you know if I find anything.
Free Windows Admin Tool Kit Click here and download it now
September 29th, 2008 4:46am

I am having the same issue with one difference. I get the prompt, except when I login with a user that has no rights (the site allows anonymous access). I have IE7 and Office 2003.
March 20th, 2009 12:16am

...but you wouldn't be prompted to open a document in read only or edit if the user is not logged in because anonymous users can't edit documents, right?It is my understanding that anonymous users can only read documents, list items and so on - they can't by default edit items. I know that for some lists like a Survey, it is possible to switch anonymous edits on but I'm not aware of that being possible for a document library.That is my understanding of it anyway :)
Free Windows Admin Tool Kit Click here and download it now
March 22nd, 2009 1:07am

Yes, but I was logged in. I think there are multiple different issue with this, and I don't see any really good answers. Sometimes it seems like a client-side thing due to the version of office, but then I see that different permissions can cause the prompt not to appear.
March 22nd, 2009 8:54pm

Yeahthat's true - the same issue seems to relate to a few different scenarios. You do need to have at least "Contribute" rights to be able to edit a document though, so it stands to reason that you won't see the prompt if you have anything less I guess.Our issue has been that even administrators with "Full Control" quite inconsistently get (or don't get) the prompt. We've learnt to work around the issue now really but I'd be interesting to hear if you ever crack it.
Free Windows Admin Tool Kit Click here and download it now
March 23rd, 2009 11:33pm

My clients have Sharepoint designer 2007 installed on their machines (2003) and get this "Read"/"'Edit" dialog box.Currently designer is a free download.Hope this helps
May 7th, 2009 8:50pm

Thanks for that - I'll give it a test tomorrow. I just thought I'd express how cheesed off I am for actually BUYING SharePoint Designer when now it's FREE! Thanks for that Microsoft...I'll let you know if it works:)
Free Windows Admin Tool Kit Click here and download it now
May 12th, 2009 10:15pm

I would suggest not installing designer as your resolve....in fact I block designer from being installed on the network because of the danger that makes for you because of what user will be able to do to their sites. I don't know if this will work for you or not but try this hotfix: http://support.microsoft.com/kb/938888/ Let me know if this does the trick.Kipp Sorensen http://justgeeking.net/blog
August 25th, 2009 11:48pm

Ran into this problem with one user who got his machine reimaged. Fixed by Add/Remove Programs --> Office 2007 Pro --> Repair.
Free Windows Admin Tool Kit Click here and download it now
January 4th, 2010 7:39am

First of all, to save you time, this behaviour is governed by an IE add-on called SharePoint OpenDocuments Class. There is nothing wrong in your SharePoint sor libraries. IInstead, this class /add-on (which comes with Office) determine the dialog box looks like. Different version of Office (XP, 2007) display differently. Debugging this problem can be tricky. Sometimes you might find that two machines with the same version of Office to have two different dialogs, When this happens, it is most likely because one of them has Office upgraded in place. When the upgrade happens, sometimes it fails to update the overlying DLL correctly (OWSSUPP.dll)Since this is a client side issue, you need to look into what version of Office is installed. If you really wanna drill down, you can browse to Office program folder and find the DLL. If you find a older version of the DLL, renaming them would make IE add-on to use the latest one, hence the correct dialog box.We had this problem before. Although knowing the cause, we couldn't find an acceptable and managable enviornment wide solution.
January 5th, 2010 8:54am

To resolve the problem with documents opening in read-only do the following steps:- go to my computer- select tools-> folder options-> file types- find the DOC extension- click the advanced button- disable "browse in same window"Works for any other document format that opens in a browser window rather than the application.
Free Windows Admin Tool Kit Click here and download it now
January 7th, 2010 7:22pm

Hey all,Problem Desc:I've been having the problem with NOT having the "Read Only" or "Edit" , which I'll call "ROE", MS Internet Explorer prompt as well. I administrate 3 different Sharepoint MOSS 2007 environments, DEV, UAT, and PRD. On DEV and PRD I do NOT get the ERO prompt on opening a document, it asks me to open the document only.On UAT I am prompted with the ROE screen. *****I want the ROE prompt in all environments.What I'm using to test:-Using IE7 running on 64 bit Vista-I am logged in as Administrator "Full Access" in all 3 environments when I experience this problem. (I get the ERO prompt only in UAT)-Users without full access also get the same prompts on all 3 environments. (They get the ERO prompt only in UAT)-The Sharepoint libraries I am testing this on are essentially the same, and in some cases have been copied between environments.-I have also experienced the same prompts on all environments when using a 32 bit VMWare Workstation Windows Server 2003 machine.Things I've tried:-The Core.js file - I've read a couple blogs about checking this - it appears to be the same across the environments-Run repair on Office 2007 - My VM does not have office installed on it but I still get the same prompts as my main machine that does have Office 2007. Office 2003 is also not installed here. Only MS Office 2003 Web Components (No repair option) and MS Sharepoint Designer 2007 (just recently installed) -I checked my IE settings for Local Intranet - The UAT environment is not listed here at all, nor is the DEV environment. -I ran ProcMon to see how it is accessing the files - on the line I think where the problem is I am getting the following DetailGood (With ROE prompt)Desired Access: Generic Read, Disposition: Open, Options: Synchronous IO Non-Alert, Non-Directory File, Attributes: N, ShareMode: Read, Write, AllocationSize: n/a, OpenResult: OpenedBad (Without ROE prompt)Desired Access: Generic Read, Disposition: Open, Options: Sequential Access, Synchronous IO Non-Alert, Non-Directory File, Attributes: N, ShareMode: Read, Delete, AllocationSize: n/a, OpenResult: OpenedInitial Thoughts:My gut is telling me its a client problem but since my machine acts differently depending on which environment I'd say that its telling me its a configuration problem on the DEV and PRD MOSS environments.Any help is appreciated. This has been a bugger of a problem.
January 25th, 2010 8:58pm

Further to my comments above I was just looking again this morning and found a couple more pieces of evidence. 1) My main computer (Non VM) is managed by the server guys so all IE security settings, permissions are managed. 2) My VM on the other hand is not - I have full admin privs on this VM. Looking at the IE settings on that I see there are no trusted sites setup. 3) I have Chrome and Firefox setup on my Non VM computer. Opening the Sharepoint site and clicking on the library item does not open the same way that IE does - it only gives the option to save - no ROE prompt on UAT where I'd expect it. So the ROE prompt appears to be a Microsoft IE thing.Since my VM has no specific Environment settings (DEV, UAT, or PRD) set up I'm leaning more to think that this is a configuration thing within MOSS. At least in the case I am experiencing. I'm sure IE settings have an impact but I think I've eliminated it as a problem in my case.Thoughts?
Free Windows Admin Tool Kit Click here and download it now
January 26th, 2010 9:08pm

Adafer: Please only propose good answers from *other people*. That is helpful for the Moderators here - proposing your own posts isn't. (moderator)FAQ sites: (SP 2010) http://wssv4faq.mindsharp.com; (v3) http://wssv3faq.mindsharp.com and (WSS 2.0) http://wssv2faq.mindsharp.com Complete Book Lists (incl. foreign language) on each site.
February 12th, 2010 11:27am

As Khimming has said this behaviour is controlled by the SharePoint OpenDocuments Class Add-On and is a client side issueName: SharePoint OpenDocuments ClassPublisher: Microsoft CorporationType: ActiveX ControlVersion: 12.0.6423.1000File date: Date last accessed: Today, February 12, 2010, 1 minute agoClass ID: {9203C2CB-1DC1-482D-967E-597AFF270F0D}Use count: 2536Block count: 0File: OWSSUPP.DLLFolder: C:\Program Files (x86)\Microsoft Office\Office12in IE8 go to Tools > Manage Add-Ons > Toolbars and Extensions > Double Click on SharePoint OpenDocuments Class > Choose Allow All Sites > Close IE and go to your favorite SharePoint Document Library > QA-Ivan Ivan Sanders My LinkedIn Profile, My Blog, @iasanders.
Free Windows Admin Tool Kit Click here and download it now
February 12th, 2010 5:56pm

How can one see this addon in IE 6 and 7. I am running a mixed environment. I think a recent security patch changed something, as my company has lost the ability for this pop up to appear in Office 2003 and 2007. On IE 8 and Office 2010, it seems normal
July 20th, 2010 12:53am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics