What do I delete?  - Moved index

I've 2 servers where the users only hits the WFE1

  • APP1
  • WFE1 

Due to low disk issues I've followed this 

http://softlanding.ca/blog/move-sharepoint-2013-search-index-location 

and ran it at the APP server - it succeded

When I run it on the WFE1 I get this error:

Set-SPEnterpriseSearchTopology : Topology activation failed. Removing index partitions from a non-empty is not supported

and what do I delete on C:\ in order to clean up? 

In the C:\Program Files\Microsoft Office Servers\15.0\Data\Office Server\Applications\Search\Nodes\<ID> - where it's the IndexComponent9 that fills up the C:\

How do I delete the Topology (not deleting the SSA) and is that the way forward? (will this delete these folders?) and then create a new topology? 

Right now it looks like this... 



  • Edited by JmATK 19 hours 1 minutes ago
May 21st, 2015 4:04am

Hi JmATK,

You do not need to delete anything directly in the local drive, the components need to be deleted with the PowerShell command:

Get-SPEnterpriseSearchComponent -SearchTopology $Clone | ? {($_.GetType().Name -eq "IndexComponent") -and ($_.ServerName -eq $($Instance.Server.Address)) -and ($_.RootDirectory -ne $IndexLocation)} | Remove-SPEnterpriseSearchComponent -SearchTopology $Clone -Confirm:$false;

Please make sure that you run the command with the right server where the search service instance runs.

And the PowerShell command will only move the index component.

Thanks,
Victoria

Free Windows Admin Tool Kit Click here and download it now
May 22nd, 2015 2:58am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics