WSS 3.0 and people picker "No exact match was found"
We have installed WSS 3.0 in a farm environment with several Web Applications and Top Level Site Collection. After running the stsadm.exe -o setproperty -pn "peoplepicker-searchadforests" . command we get error message "No exact match was found" when using WSS 3.0 Central Administration tocreate Site Collections Administrators by writing <ad name>\<uid>. Using the Address Book gives the error message "There was an error in the callback" . Creating users from IEworks.Somebodywho knowshow to solve our problem.
February 16th, 2009 3:25pm

Hello, Cause of your issue is that you are using PeoplePicker to add users across domains. If you want to get the people picker working, you need to configure following commands on SharePoint server: A. stsadm.exe -o setapppassword -password <somekey> - this command is use as encrypt\decrypt keyB. stsadm.exe o setproperty pn peoplepicker-searchadforests pv <list of forests or domains> -url <webapp> - this command is use to set the property for a specific web application. After running both commands above, run IISRESET to see if it will work. If the problems still exist, please feel free to let me know. Regards, JerryXing-Bing Yu
Free Windows Admin Tool Kit Click here and download it now
February 18th, 2009 5:46am

I'm a co worker of Anne BeateI now have seen this by myself. In the admin site you can create a group, and pick users ok. The remote ad replies ok, and in a standard group there is now problem. Then when we try to make a new site collection, we are asked for the site collection owner. And it looks as a standard lookup , same as in the group that worked 2 minutes earlier. But this is when the error occurs, only when trying to assign a site collection owner in the site collection creation process. So what is different when you pick a site colection owner from when you pick to a standard group ? Thomastr
February 24th, 2009 11:01am

Thomas,I am having this exact same issue. Were you able to resolve it?Thanks,Sean
Free Windows Admin Tool Kit Click here and download it now
May 6th, 2009 8:58pm

Hi, I got exactly the same problem using WSS 3.0. Everything is ok in Sharepoint Central Administration, but when I try to pick some people up from a site collection, I have the error message 'No exact match was found"... How did you resolve this problem ? Thanks
May 18th, 2009 11:16am

I just worked through the issue myself. On Central Administration under Application Management there is a category called Application Security. Click the Authetication Providers Link under there. Under the default zone change the authentication type from web single sign on to windows authenticationKeep your head in the Clouds as you're coding .NET http://azurecoding.net
Free Windows Admin Tool Kit Click here and download it now
May 20th, 2009 1:53pm

Thanks Jerry,It worked for me.Regards,Arash Aghajani
May 24th, 2009 1:19pm

I have the same issues..stsadm.exe -o setapppassword -password <somekey> worksbut the second command just gives me a syntax error stsadm.exe -o setproperty -pn peoplepicker-searchadforests -pvMYNI.EDU -url "http://servername.myuno.edu:41818/hpccdocsCommand line error. Usage: stsadm.exe -o <operation> [<parameters>] stsadm.exe -help [<operation>]....is there somethign wrong in my syntax ?
Free Windows Admin Tool Kit Click here and download it now
June 16th, 2009 9:50pm

Try to write -pv "domain:MYNI.EDU" instead of yours
March 10th, 2010 10:46am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics