VSTADTEProvider.Interop error while working with script transformation
Error: Could not load file or assembly 'VSTADTEProvider.Interop, Version=9.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. The system cannot find the file specified. (Microsoft.SqlServer.VSTAScriptingLib) I get the above error when I click on the edit button under script transformation. I'm using enterprise edition SQL Server 2008 R2. I tried reinstalling SQL Server, that did not help. I am trying to repair SQL Server and none of the paths I give for the Install folder works. Please help.
August 11th, 2011 7:35pm

Which version of SSIS/BIDS was used to develop the package?? What version are you using to open the package?? There are different versions of DLLs that SSIS uses between various SQL server assertions and sometimes cause a compatibility conflict. You can remove the existing script transform from your package, add a new one and copy-paste the code logic that you had in the original transform. Doing so will tell you whether the issue is due to a version conflict or not. The issue is also sometimes specific to the VSTA tools that get installed with SQL server. Uninstall these from Control Panel-? Add/Remove programs and repair SQL 08 R2 using the installation media. Also make sure to include Shared Components during repair. You can keep the default path for installation as the DLLs get installed in GAC and not to a specific folder path. Hope this helps. Cheers!! Muqadder.
Free Windows Admin Tool Kit Click here and download it now
August 11th, 2011 7:47pm

do you have previous versions of BIDS installed on this machine? could you uninstall them all and install SQL Server 2008 R2 again with SSIS and BIDS?http://www.rad.pasfu.com My Submitted sessions at sqlbits.com
August 12th, 2011 3:25am

Thanks for your response. I just have 2008 R2 version installed on my machine. I was actually trying to edit the SSIS package which was developed in 2008 R2. I tried all the methods stated above and the problem still persists. Please guide me. Regards.........
Free Windows Admin Tool Kit Click here and download it now
August 12th, 2011 2:53pm

Repairing the SQL Server is the solution. None of the paths work? The repair asks for the install folder which comes with the product/ installer? Happy to help! Thanks. Regards and good Wishes, Deepak. In a revamp of my Blog!
August 12th, 2011 4:04pm

Hi Deepak Tried repairing SQL installation yet that did not fix the issue. Regards
Free Windows Admin Tool Kit Click here and download it now
August 19th, 2011 3:10am

Thanks all for your inputs. Had it fixed by copying missing dll to the windows assembly folder. Regards
August 25th, 2011 2:09am

Hi, Can you just give some more details on this as to from where you got that dll
Free Windows Admin Tool Kit Click here and download it now
July 26th, 2012 7:25am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics