Unable to load client print control
I have a user that had previously installed the client print control and had been printing reports. He used some kind of PC cleanup tool and got the new Norton Antivirus and now he can no longer print and is getting the "Unable to load client print" control whenever he is clicking on the printer icon. He doesn't see any other messages on the screen saying that an Active X control is trying to be installed but is being blocked. What are the next steps that I should take to help him?
October 16th, 2008 12:01am

I also have this problem and so do some of my users. I am running on Vista and that seems to be trickier. For some reason the ActiveX Control shows up as a GUID in the C:\Windows\Downloaded Program Files. I managed to clean it up in the registry (very painfully) to get back to square 1. Then when i hit the print button it attempted to download the RS Print Client and then came up with the dialog "unable to load client print control".And of cours the GUID came back in the C:\Windows\Downloaded Program Files folder...instead of RSPrintClient In XP I Could sinply delete the ActiveX in the folder and try again. They took that functionality away in Windows Vista. And the control does not show up in Manage Add Ons...so i couldn't disable or delete it from there. Printing with SRS has workedfor me for months (7 months) on vista without a problem. I wonder what changed? Any help would be much appreciated.
Free Windows Admin Tool Kit Click here and download it now
October 16th, 2008 9:29am

Hi.I had the same problem.I think that the problem is that the RS print IS trying to install some component on the local computer and it fails.Is the user is an admin on this computer? If not, try to give him an admin privilage and ask him to try and print. Hopfully this will let him print the RS print component.Also, you can log in with another admin user and install the component needed.(I don't remembr exectly where those file are but you can manualy install them from the RS directory).Good luck.
October 16th, 2008 12:02pm

Seehttp://forums.microsoft.com/msdn/ShowPost.aspx?PostID=4006172&SiteID=1That has fixed it for me
Free Windows Admin Tool Kit Click here and download it now
October 16th, 2008 1:18pm

I too am getting the 'unable to load client print control' error message, but this is not consistent, e.g. my pc is at SP3, with IE7 and I get the error, last night I updated another pc to SP3 which has IE6 and that works fine. But there also some pc's with IE6 that get the error message. Any ideas? Rob
October 16th, 2008 1:35pm

It is KB956391. Uninstall that and all is OK.
Free Windows Admin Tool Kit Click here and download it now
October 16th, 2008 4:29pm

Uninstalling KB956391 worked for me too. For my clients...when i installed The Report Viewer Service Pack 1 on my server, it forced them to download and install the client print control again and that worked for them. They run on XP and I run on Vista. Microsoft Report Viewer Redistributable 2005 Service Pack 1 http://www.microsoft.com/downloads/details.aspx?FamilyID=82833f27-081d-4b72-83ef-2836360a904d&DisplayLang=en Also someone else found a registry hack if you don't want to uninstall KB956391 http://forums.microsoft.com/msdn/showpost.aspx?postid=4006172&siteid=1&sb=0&d=1&at=7&ft=11&tf=0&pageid=1
October 16th, 2008 7:51pm

Uninstalling KB956391 isn't fixing the problem you need to patch the server with the latest repoting services sp.http://forums.microsoft.com/msdn/ShowPost.aspx?PostID=4006172&SiteID=1
Free Windows Admin Tool Kit Click here and download it now
October 22nd, 2008 1:45pm

It is not a solution to uninstall KB956391!! This KBsolves a security problem and it is NOT very professional, to uninstall this!!
October 23rd, 2008 11:01am

Did anyone find any other option to slove this problem. Since KB956391 has releated fixes. My server has all latest patches. Only way to Print straight to printer is by removing kb956391, export to excel or pdf then print.
Free Windows Admin Tool Kit Click here and download it now
October 31st, 2008 6:20pm

To get rid of it totally: all programs, windows update then selecting custom it checks for updates then you select KB956391 untick the top box and tick don't show update again. It does say you've hidden important updates but that is from the people who created an update that is incompatable with Visual Studio & Report Manager, the way all reporting is going...
November 4th, 2008 5:55pm

There is a fix, you need latest Print Control and have to rename downloaded program files and recreate. Microsoft from what I was told is working on a easier fix. Sorry forgot link Latest Report Viewer control www.microsoft.com/downloads/details.aspx?FamilyID=bb196d5d-76c2-4a0e-9458-267d22b6aac6&DisplayLang=en
Free Windows Admin Tool Kit Click here and download it now
November 4th, 2008 6:10pm

If I am not prompted to download anything, then what is missing on the reportserver? How do I get it to istribute the Activex?
November 4th, 2008 10:03pm

There was a security update that fudges with the ActiveX Killbits ( p.MsoNormal, li.MsoNormal, div.MsoNormal {margin-top:0in;margin-right:0in;margin-bottom:10.0pt;margin-left:0in;line-height:115%;font-size:11.0pt;font-family:'Calibri','sans-serif';} .MsoChpDefault {;} .MsoPapDefault {margin-bottom:10.0pt;line-height:115%;} @page Section1 {size:8.5in 11.0in;margin:1.0in 1.0in 1.0in 1.0in;} div.Section1 {page:Section1;} KB956391). Your user or users probably have that update.We had this same problem, and installing this update on our SRS server fixed the problem, without having to uninstall the security updates. We even did it live as a hot-fix - it didn't require us to reboot as our SRS application is on a machine separate from our SQL instance.http://www.microsoft.com/downloads/details.aspx?familyid=4603C722-2468-4ADB-B945-2ED0458B8F47&displaylang=enHope this helps.
Free Windows Admin Tool Kit Click here and download it now
November 4th, 2008 10:37pm

Adam's fix worked for me. Thanks!
November 13th, 2008 12:18am

Hello Adam, Thank you very much, the problem was resolved.
Free Windows Admin Tool Kit Click here and download it now
November 19th, 2008 11:44pm

This is the listed steps for resolving the problem that I was provided. The link to the 2005 SP1 distributable fixed the problem on the server for me but I did uninstall all previous versions and ran an iisreset inbetween. Once repaired, I was able to reinstall KB956391 on both clients and servers.Nearly a week of frustration trying to resolve the issue so hopefully thissaves someone else from the same hassle. Trying to print from Report Manager fails: ============================================= 1. Verify that you has applied CU9 to the Reporting Services machine. If not then Report Manager is still using the kill bit'ed version of the RSClientPrint control. --Since its SQL Server 2005 SP2 9.0.3282, the CU9 is applied on your server. 2. If applying CU9 does not resolve the issue uninstall the RSClientPrint control from the client(s) machines by opening C:\windows\Downloaded Program Files and deleting the RSClientPrint item from the list. 3. If the RSClientPrint control is not in the list of programs in the "Downloaded Program Files" directory make sure there are no left over files that could be getting in the way. To do this follow these steps: a. Open a cmd prompt and change to the C:\windows\downloaded program files directory. b. If there is an RSClientPrint.dll file in this directory run "regsvr32 /u RSClientPrint.dll" before removing it. c. Remove all RSClientPrint*.rll, .dll and .inf files. d. See if there is a "Conflict.#" folder if there is cd to this directory and see if there are RSClientPrint files in here. If so follow steps b and c for this directory as well. e. Try printing again. Trying to Print from a SharePoint Integrated instance of Reporting Services: ====================================================================== 1. Install the updated version of the SharePointRS.msi on all Web Front Ends in the SharePoint farm. The new version of the add-in can be found here: http://www.microsoft.com/downloads/details.aspx?FamilyID=1e53f882-0c16-4847-b331-132274ae8c84&DisplayLang=en 2. You will need to install the GDR OR (not both) CU9(or higher) on the Reporting Services instance. --Youve installed CU9. 3. Verify that the Microsoft.ReportingServices.SharePoint.UI.WebParts.dll has been updated to the correct build of 9.00.3294 by looking at the version of this file in the C:\windows\assembly folder. If the above steps do not work you can try the following workarounds: 1. Roll back the 956391 hotfix from the client machines. 2. Instead of using the Client Print export the report to PDF or other format and print from there. Trying to print from a Custom ASP .NET application using the ReportViewer control: ====================================================================== 1. You will need to apply the GDR fixed version of the ReportViewer control. You can get the fix for the version of the control being used from the links below. ReportViewer 2005 SP1 (This is NOT the original 2005 SP1 download but a new one): http://www.microsoft.com/downloads/details.aspx?familyid=82833F27-081D-4B72-83EF-2836360A904D ReportViewer 2008 (This is NOT the original 2008 download but a new one): http://www.microsoft.com/downloads/details.aspx?familyid=6AE0AA19-3E6C-474C-9D57-05B2347456B1 2. If applying this does not work then you will need to verify that the customer is not copying the ReportViewer binaries along with their custom application. If they are then it will not use the fixed versions of the assemblies in the GAC. You will need to remove the local copies of the binaries and the fixed versions will be used in their place. 3. If this cannot be verified run Process Monitor during a failure on the web server and locate any instances of the ReportViewer binaries being loaded to verify that the correct versions are being used. Trying to print from a custom ASP / ASP .NET application using the RSClientPrint control directly: =========================================================================== 1. You will need to change the OBJECT tag to the new CLSID of the non-Kill Bit version of the Client Print control and point the CodeBase tag to a .cab file that contains the new version. This is the original line: <OBJECT ID="RSClientPrint" CLASSID="CLSID:FA91DF8D-53AB-455D-AB20-F2F023E498D3" CODEBASE="RSClientPrint.cab" VIEWASTEXT></OBJECT> Changes to: <OBJECT ID="RSClientPrint" CLASSID="CLSID:41861299-EAB2-4DCC-986C-802AE12AC499" CODEBASE="RSClientPrint.cab" VIEWASTEXT></OBJECT> Note: The CODEBASE for RSClientPrint.cab file will have to be pointed to the .cab file that contains the fixed files. This will be in the ReportingServices directory for an instance of ReportingServices that has had the GDR applied to it.
December 24th, 2008 8:06pm

GuysI got this working with out removing any patches.All I did was on the IIS server install the following patch and reset / restart the IIS server.This is not for report manager application. This is for any ASP.NET Web application developed in .net3.5 using VS2008http://www.microsoft.com/downloads/details.aspx?familyid=6AE0AA19-3E6C-474C-9D57-05B2347456B1&displaylang=en
Free Windows Admin Tool Kit Click here and download it now
April 22nd, 2009 2:06am

Hi All, I had the same problem but didn't have KB956391 installed. I found that uninstalling the following security update KB950760 did the trick so maybe have a look for that.
June 29th, 2009 5:48pm

This issue arose on 7/15/09 using XP SP2. Resolution was removal of recently downloaded KB973346.
Free Windows Admin Tool Kit Click here and download it now
July 22nd, 2009 9:34pm

HI Adam,Thanks for the workaround. Unfortunetly it doesnt work for me. I am using SQL Server 2008 (ssrs 2008) and what all are discussing is about SQL Server 2005. Can you please provide some details about SQL Server 2008 as well?Its a show stopper for us, client is complaining about it.Thanks,JaydeepI love walking in the rain b'coz no one see me crying
January 25th, 2010 10:34am

Hi Jaydeep , I am getting the same issue with SQL server 2008 .Did you find a solution for this . Regards , Ambika
Free Windows Admin Tool Kit Click here and download it now
October 12th, 2010 7:49pm

Hi @all, I have also the same issue with SQL Server 2008, which hotfix would work for this version? Regards Matthias
January 20th, 2011 11:13am

Hi Everyone, Like the previous two comments, I also have SQL 2008 and have encountered this issue. We have installed SQL 2008 Service Pack 2 to our Reporting Server but this still has not fixed the problem. The issue only happens when trying to print from a non-adminstrator PC. We've tried installing it on the user PC as administrator but once the user logs back in and tries to print they get the same error message. Any solution would be much appreciated! Regards, Josh
Free Windows Admin Tool Kit Click here and download it now
January 26th, 2011 8:23pm

In an open Report you Could check the ReportViewer Version, by Viewing the Sourcecode of the Report in the IE. In the sourcecode you have to search for the following lines: <script src="/Reserved.ReportViewerWebControl.axd?OpType=Resource&amp;Version=8.0.50727.42&amp;Name=Scripts.ReportViewer.js"> In this example the version is 8.0.50727.42. The correct version to print is: 8.0.50727.1843 or newer. In my cas the problem was, even though we are using SQL Server 2008 our business application (MS Dynamics CRM 4.0) has a Report Viewer Component of SQL 2005 installed on the application server! So we had to update this component on the crm application server. ReportViewer Redistributable 2005 SP1 GDIPLUS.DLL http://www.microsoft.com/downloads/en/details.aspx?familyid=0dfaf300-2b53-4678-a779-0d805ddfe538&displaylang=en
February 6th, 2011 4:00pm

Hi all, This is the simplest way. Do following step(Win7): - Login to computer with local admin and delete folder: Downloaded Program Files in C:\Windows - Re-create folder Downloaded Program Files and set it's permission can modify by everyone - Turn off User Account Control - Run cmd and regsvr32 rsclientprint.dll - Print report in admin account 1 time. It's work!
Free Windows Admin Tool Kit Click here and download it now
July 15th, 2011 6:04am

This last "fix" is great for one computer but what do you do for 100,000+ computers that visit our website and need to print reports?
November 16th, 2011 6:35pm

Hi, We are having the problem with SQL2008 x64 and CRM 2011 with Rollup 5. Windows Server 2008 R2 x64 We are having the problem cause we applied GDR 1617 for SQL Server 2008 R2 (KB2494088) (64-bit) on the reporting server. When we checked the client print report version from client machine, we got the version as 10.0.30319.1 which we downloaded from "Program Files\Microsoft SQL Server\MSSQLSERVER\Reporting Services\ReportServer\bin" and registered the DLL file. Before we update this, we can load the client print control as well. Is there a way to solve the problem without uninstall the UPDATE? Could u please help me to go forward. Any help would be appreciated... Regards, Thanks in advance
Free Windows Admin Tool Kit Click here and download it now
November 24th, 2011 10:17pm

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics