Unable to download Windows 10 ADK - Error 0x80091007: Failed to verify hash of payload


I'm downloading from this page by clicking this link http://go.microsoft.com/fwlink/p/?LinkId=526740 at the very bottom, and then running adksetup.

No matter what I chose to install or download, I get "An error occurred while downloading Documentation" on several PCs from several different ISPs

The logs

[0F80:22CC][2015-07-14T13:49:18]w343: Prompt for source of package: package_ToolkitDocumentation_x86_en_us, payload: package_ToolkitDocumentation_x86_en_us, path: C:\Users\vsterkin\Downloads\Installers\Toolkit Documentation-x86_en-us.msi
[0F80:22CC][2015-07-14T13:49:18]i000: package_ToolkitDocumentation_x86_en_us
[0F80:22CC][2015-07-14T13:49:18]i000: package_ToolkitDocumentation_x86_en_us to http://download.microsoft.com/download/8/1/9/8197FEB9-FABE-48FD-A537-7D8709586715/adk/Installers/Toolkit Documentation-x86_en-us.msi
[0F80:22CC][2015-07-14T13:49:18]i338: Acquiring package: package_ToolkitDocumentation_x86_en_us, payload: package_ToolkitDocumentation_x86_en_us, download from: http://download.microsoft.com/download/8/1/9/8197FEB9-FABE-48FD-A537-7D8709586715/adk/Installers/Toolkit Documentation-x86_en-us.msi
[1010:00AC][2015-07-14T13:49:20]e000: Error 0x80091007: Hash mismatch for path: C:\ProgramData\Package Cache\.unverified\package_ToolkitDocumentation_x86_en_us, expected: C00FE10B81B6AEB6E641C66B6EB0B4019E1795E2, actual: 9E825AE91B68DE7D49D8633D7393C14EDE7AA812
[1010:00AC][2015-07-14T13:49:20]e000: Error 0x80091007: Failed to verify hash of payload: package_ToolkitDocumentation_x86_en_us
[1010:00AC][2015-07-14T13:49:20]e310: Failed to verify payload: package_ToolkitDocumentation_x86_en_us at path: C:\ProgramData\Package Cache\.unverified\package_ToolkitDocumentation_x86_en_us, error: 0x80091007. Deleting file.
[1010:00AC][2015-07-14T13:49:20]e000: Error 0x80091007: Failed to cache payload: package_ToolkitDocumentation_x86_en_us
[0F80:22CC][2015-07-14T13:49:20]i000: ERROR: Failed to verify the integrity of payload [package_ToolkitDocumentation_x86_en_us] for Package package_ToolkitDocumentation_x86_en_us
[0F80:22CC][2015-07-14T13:49:20]i000: RetryManager: No more retry for cache verification error on payload [package_ToolkitDocumentation_x86_en_us]
[0F80:22CC][2015-07-14T13:49:20]e314: Failed to cache payload: package_ToolkitDocumentation_x86_en_us from working path: C:\Users\vsterkin\AppData\Local\Temp\{c3926595-79af-4f8a-9816-2dc9493fdd83}\package_ToolkitDocumentation_x86_en_us, error: 0x80091007.
[0F80:0EF8][2015-07-14T13:49:20]e000: Error 0x80091007: Failed while caching, aborting execution.

The logs reflect several retries with the same result (the last attempt is shown above). 

Please address the issue.


July 14th, 2015 10:20am

I too am having the same problem. There must be a problem with the content as I've tried from many different network configurations.



Free Windows Admin Tool Kit Click here and download it now
July 14th, 2015 4:14pm

I just tried on both my Windows 7 system and my new Windows 10 Preview.  No matter what options I choose, I get the same error.

My preferred method that I tested most was to download the files to install onto another computer.  The progress bar never moves anywhere, and the software mentioned Documentation as what it was trying to download when it errors out.

July 14th, 2015 4:52pm


It seems like there is a problem with ADK file, please be paint and waiting for this problem fix.

Free Windows Admin Tool Kit Click here and download it now
July 15th, 2015 3:32am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics