Unable to connect to WMI (r) on remote machine "SCCMCLIENT03"
Hi!I'm in the process of configuring the XP firewall to support the Client Push installation method that SCCM offers. At the moment I'm quite happy with the result. The SCCM client agentsare installedproperly on my reference machines.To secure that the WMI functionality is up and running I have (prior to the client agent installation) run wbemtest with following parameter (from server to client, and vice versa):\\host\root\cimv2I successfully contacted that specific namespace on both ends. But when I trace the log I find the following error which still indicates that something is wrong:CWmi::Connect(): ConnectServer(Namespace) failed. - 0x8004100eSMS_CLIENT_CONFIG_MANAGER2009-03-10 11:12:141704 (0x06A8)---> Unable to connect to WMI (r) on remote machine "SCCMCLIENT03", error = 0x8004100e.SMS_CLIENT_CONFIG_MANAGER2009-03-10 11:12:141704 (0x06A8)Why do I get this? What am I missing here? I got the feeling of WMI functioning the way it should. Any hints on this one?In an MSDN-article (http://msdn.microsoft.com/en-us/library/aa389286(VS.85).aspx) I read the following lines:"If the user account that is on Computer A is not an administrator on Computer B, but the user account has Remote Enable permission on Computer B"Those lines are part of an article which describes how to configure Remote administrations properly. For that to work, does the computer account of my Central Site Server has to be part of the local administrators group on every client?Regards,FredrikCCM.logSubmitted request successfullySMS_CLIENT_CONFIG_MANAGER2009-03-10 11:12:132408 (0x0968)Getting a new request from queue "Incoming" after 100 millisecond delay.SMS_CLIENT_CONFIG_MANAGER2009-03-10 11:12:132408 (0x0968)======>Begin Processing request: "TI11WDUE", machine name: "SCCMCLIENT03"SMS_CLIENT_CONFIG_MANAGER2009-03-10 11:12:131704 (0x06A8)---> Trying each entry in the SMS Client Remote Installation account listSMS_CLIENT_CONFIG_MANAGER2009-03-10 11:12:131704 (0x06A8)---> Attempting to connect to administrative share '\\SCCMCLIENT03.spost.nu\admin$' using account 'spost.nu\SA-SCCM_ClientPush'SMS_CLIENT_CONFIG_MANAGER2009-03-10 11:12:131704 (0x06A8)Received request: "HPS6133J" for machine name: "SCCMCLIENT02" on queue: "Incoming".SMS_CLIENT_CONFIG_MANAGER2009-03-10 11:12:132408 (0x0968)Stored request "HPS6133J", machine name "SCCMCLIENT02", in queue "Processing".SMS_CLIENT_CONFIG_MANAGER2009-03-10 11:12:132408 (0x0968)---> Connected to administrative share on machine SCCMCLIENT03.spost.nu using account 'spost.nu\SA-SCCM_ClientPush'SMS_CLIENT_CONFIG_MANAGER2009-03-10 11:12:131704 (0x06A8)---> Attempting to make IPC connection to share <\\SCCMCLIENT03.spost.nu\IPC$>SMS_CLIENT_CONFIG_MANAGER2009-03-10 11:12:131704 (0x06A8)---> Searching for SMSClientInstall.* under '\\SCCMCLIENT03.spost.nu\admin$\'SMS_CLIENT_CONFIG_MANAGER2009-03-10 11:12:131704 (0x06A8)---> System OS version string "5.1.2600" converted to 5,10SMS_CLIENT_CONFIG_MANAGER2009-03-10 11:12:141704 (0x06A8)---> Service Pack version from machine "SCCMCLIENT03" is 3SMS_CLIENT_CONFIG_MANAGER2009-03-10 11:12:141704 (0x06A8)CWmi::Connect(): ConnectServer(Namespace) failed. - 0x8004100eSMS_CLIENT_CONFIG_MANAGER2009-03-10 11:12:141704 (0x06A8)---> Unable to connect to WMI (r) on remote machine "SCCMCLIENT03", error = 0x8004100e.SMS_CLIENT_CONFIG_MANAGER2009-03-10 11:12:141704 (0x06A8)---> Creating \ VerifyingCopying exsistance of destination directory \\SCCMCLIENT03\admin$\system32\ccmsetup.SMS_CLIENT_CONFIG_MANAGER2009-03-10 11:12:141704 (0x06A8)---> Copying client files to \\SCCMCLIENT03\admin$\system32\ccmsetup.SMS_CLIENT_CONFIG_MANAGER2009-03-10 11:12:141704 (0x06A8)---> Copying file "d:\Program Files\Microsoft Configuration Manager\bin\I386\MobileClient.tcf" to "\\SCCMCLIENT03\admin$\system32\ccmsetup\MobileClient.tcf"SMS_CLIENT_CONFIG_MANAGER2009-03-10 11:12:141704 (0x06A8)---> Copying file "d:\Program Files\Microsoft Configuration Manager\bin\I386\ccmsetup.exe" to "\\SCCMCLIENT03\admin$\system32\ccmsetup\ccmsetup.exe"SMS_CLIENT_CONFIG_MANAGER2009-03-10 11:12:141704 (0x06A8)---> Created service "ccmsetup" on machine "SCCMCLIENT03".SMS_CLIENT_CONFIG_MANAGER2009-03-10 11:12:151704 (0x06A8)----- Started a new CCR processing thread. Thread ID is 0xc6c. There are now 2 processing threadsSMS_CLIENT_CONFIG_MANAGER2009-03-10 11:12:152408 (0x0968)Submitted request successfullySMS_CLIENT_CONFIG_MANAGER2009-03-10 11:12:152408 (0x0968)Getting a new request from queue "Incoming" after 100 millisecond delay.SMS_CLIENT_CONFIG_MANAGER2009-03-10 11:12:152408 (0x0968)Found CCR "yb2xbq0a.CCR" in queue "Incoming".SMS_CLIENT_CONFIG_MANAGER2009-03-10 11:12:152408 (0x0968)======>Begin Processing request: "HPS6133J", machine name: "SCCMCLIENT02"SMS_CLIENT_CONFIG_MANAGER2009-03-10 11:12:153180 (0x0C6C)---> Trying the 'best-shot' account which worked for previous CCRs (index = 0x0)SMS_CLIENT_CONFIG_MANAGER2009-03-10 11:12:153180 (0x0C6C)---> Attempting to connect to administrative share '\\SCCMCLIENT02.spost.nu\admin$' using account 'spost.nu\SA-SCCM_ClientPush'SMS_CLIENT_CONFIG_MANAGER2009-03-10 11:12:153180 (0x0C6C)Received request: "YB2XBQ0A" for machine name: "SCCMCLIENT01" on queue: "Incoming".SMS_CLIENT_CONFIG_MANAGER2009-03-10 11:12:152408 (0x0968)Stored request "YB2XBQ0A", machine name "SCCMCLIENT01", in queue "Processing".SMS_CLIENT_CONFIG_MANAGER2009-03-10 11:12:152408 (0x0968)---> Started service "ccmsetup" on machine "SCCMCLIENT03".SMS_CLIENT_CONFIG_MANAGER2009-03-10 11:12:161704 (0x06A8)---> Deleting SMS Client Install Lock File '\\SCCMCLIENT03.spost.nu\admin$\SMSClientInstall.S01'SMS_CLIENT_CONFIG_MANAGER2009-03-10 11:12:161704 (0x06A8)---> Completed request "TI11WDUE", machine name "SCCMCLIENT03".SMS_CLIENT_CONFIG_MANAGER2009-03-10 11:12:161704 (0x06A8)Deleted request "TI11WDUE", machine name "SCCMCLIENT03"SMS_CLIENT_CONFIG_MANAGER2009-03-10 11:12:161704 (0x06A8)<======End request: "TI11WDUE", machine name: "SCCMCLIENT03".SMS_CLIENT_CONFIG_MANAGER2009-03-10 11:12:161704 (0x06A8)======>Begin Processing request: "YB2XBQ0A", machine name: "SCCMCLIENT01"SMS_CLIENT_CONFIG_MANAGER2009-03-10 11:12:161704 (0x06A8)---> Trying the 'best-shot' account which worked for previous CCRs (index = 0x0)SMS_CLIENT_CONFIG_MANAGER2009-03-10 11:12:161704 (0x06A8)---> Attempting to connect to administrative share '\\SCCMCLIENT01.spost.nu\admin$' using account 'spost.nu\SA-SCCM_ClientPush'SMS_CLIENT_CONFIG_MANAGER2009-03-10 11:12:161704 (0x06A8)Submitted request successfullySMS_CLIENT_CONFIG_MANAGER2009-03-10 11:12:172408 (0x0968)
March 10th, 2009 6:40am

FredrikSE said: The SCCM client agentsare installedproperly on my reference machines.[...]CWmi::Connect(): ConnectServer(Namespace) failed. - 0x8004100eSMS_CLIENT_CONFIG_MANAGER2009-03-10 11:12:141704 (0x06A8)---> Unable to connect to WMI (r) on remote machine "SCCMCLIENT03", error = 0x8004100e.SMS_CLIENT_CONFIG_MANAGER2009-03-10 11:12:141704 (0x06A8)---> Creating \ VerifyingCopying exsistance of destination directory \\SCCMCLIENT03\admin$\system32\ccmsetup.SMS_CLIENT_CONFIG_MANAGER2009-03-10 11:12:141704 (0x06A8)---> Copying client files to \\SCCMCLIENT03\admin$\system32\ccmsetup.SMS_CLIENT_CONFIG_MANAGER2009-03-10 11:12:141704 (0x06A8)---> Copying file "d:\Program Files\Microsoft Configuration Manager\bin\I386\MobileClient.tcf" to "\\SCCMCLIENT03\admin$\system32\ccmsetup\MobileClient.tcf"SMS_CLIENT_CONFIG_MANAGER2009-03-10 11:12:141704 (0x06A8)---> Copying file "d:\Program Files\Microsoft Configuration Manager\bin\I386\ccmsetup.exe" to "\\SCCMCLIENT03\admin$\system32\ccmsetup\ccmsetup.exe"SMS_CLIENT_CONFIG_MANAGER2009-03-10 11:12:141704 (0x06A8)---> Created service "ccmsetup" on machine "SCCMCLIENT03".SMS_CLIENT_CONFIG_MANAGER2009-03-10 11:12:151704 (0x06A8)The error translates to "WBEM_E_INVALID_NAMESPACE". But it seems that client push was initiated/completed successfully? If so, I wouldn't worry about those lines in the log. Either the computer account of the pushing site or the client push account have to be member of the admins group on the clients.
Free Windows Admin Tool Kit Click here and download it now
March 10th, 2009 7:06am

Thanks for quick reply!Then I will disregard those lines in the log file. Right now my SCCM policy is configured to distribute a client push account as well as a security group (including the Site Server computer account) to the local admins group on the clients. I should be good to go then.
March 10th, 2009 7:10am

You would think they would have fixed this problem in SCCM 2012...nope!!! Still get a "CWmi::Connect(): ConnectServer(Namespace) failed. - 0x8004100e" when performing a Client Push even when everything is configured properly (Rights and Firewall) . True, the client installs properly but it would be nice if someone would explain why the error occurs in the first place...simply telling us to "Ignore the error"? You can do better than that!!!
Free Windows Admin Tool Kit Click here and download it now
February 8th, 2012 5:17pm

It's trying to connect to determine if the client is already installed and healthy on the client system which by default means that it should not continue installing. Thus, this is expected and working as designed.Jason | http://myitforum.com/myitforumwp/community/members/jasonsandys/ | Twitter @JasonSandys
February 8th, 2012 7:19pm

Here is what is in my ccmsetup.log <![LOG[GetSSLCertificateContext failed with error 0x87d00280]LOG]!><time="16:19:22.341+240" date="04-04-2012" component="ccmsetup" context="" type="3" thread="984" file="ccmsetup.cpp:5356"> <![LOG[GetHttpRequestObjects failed for verb: 'GET', url: 'HTTPS://TEST-SCCM.copt.local/CCM_Client/ccmsetup.cab']LOG]!><time="16:19:22.341+240" date="04-04-2012" component="ccmsetup" context="" type="3" thread="984" file="httphelper.cpp:942"> <![LOG[DownloadFileByWinHTTP failed with error 0x87d00280]LOG]!><time="16:19:22.341+240" date="04-04-2012" component="ccmsetup" context="" type="3" thread="984" file="httphelper.cpp:1076"> <![LOG[CcmSetup failed with error code 0x87d00280]LOG]!><time="16:19:22.341+240" date="04-04-2012" component="ccmsetup" context="" type="1" thread="3496" file="ccmsetup.cpp:9454"> And in my ccm.log: ---> Attempting to connect to administrative share '\\SCCMCLIENTTEST1\admin$' using account 'corporate\sccmadmin'~ $$<SMS_CLIENT_CONFIG_MANAGER><04-04-2012 16:09:19.338+240><thread=2708 (0xA94)> ---> The 'best-shot' account has now succeeded 1 times and failed 0 times. $$<SMS_CLIENT_CONFIG_MANAGER><04-04-2012 16:09:19.400+240><thread=2708 (0xA94)> ---> Connected to administrative share on machine SCCMCLIENTTEST1 using account 'corporate\sccmadmin'~ $$<SMS_CLIENT_CONFIG_MANAGER><04-04-2012 16:09:19.400+240><thread=2708 (0xA94)> ---> Attempting to make IPC connection to share <\\SCCMCLIENTTEST1\IPC$> ~ $$<SMS_CLIENT_CONFIG_MANAGER><04-04-2012 16:09:19.400+240><thread=2708 (0xA94)> ---> Searching for SMSClientInstall.* under '\\SCCMCLIENTTEST1\admin$\'~ $$<SMS_CLIENT_CONFIG_MANAGER><04-04-2012 16:09:19.405+240><thread=2708 (0xA94)> ---> System OS version string "6.1.7601" converted to 6.10 $$<SMS_CLIENT_CONFIG_MANAGER><04-04-2012 16:09:19.778+240><thread=2708 (0xA94)> CWmi::Connect(): ConnectServer(Namespace) failed. - 0x8004100e~ $$<SMS_CLIENT_CONFIG_MANAGER><04-04-2012 16:09:19.826+240><thread=2708 (0xA94)> ---> Unable to connect to WMI (root\ccm) on remote machine "SCCMCLIENTTEST1", error = 0x8004100e
Free Windows Admin Tool Kit Click here and download it now
April 4th, 2012 4:34pm

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics