UDI Web Serice Issue
Hi I am trying to connect to the udi web service and have an issue when trying to connect. the url is http://localhost/UDI/OSDConfigService/OSDConfig.svc All permissions etc look fine, any ideas ? "It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level" in asp.net
October 5th, 2010 1:10pm

ok spent all day trying to fix this :( all looks fine, I now get a HTTP Error 401.2 - You are not authorized to view this page due to invalid authentication headers. I have tried logging on anonamously, windows integration etc and I get the same error, any ideas ? Guess its some IIS7 setting I have incorrectly setup.
Free Windows Admin Tool Kit Click here and download it now
October 5th, 2010 5:23pm

Have you seen the known issues for UDI? Below is an excerpt take a look and see if this is applicable. This has been the only problem i have ever had with UDI web service. · If you receive error 404.3 when browsing to the UDI Designer web service, this error is typically the result of the Windows Communication Foundation (WCF) multipurpose Internet mail extensions (MIME) type not being registered correctly. To register the WCF MIME type on the web server, go to %Windir%\Microsoft.NET\Framework\v3.0\Windows Communication Foundation. From an elevated command prompt, run ServiceModelReg.exe –I to register the MIME type for the .svc extension, which the web service requires.Thanks, Brandon
October 6th, 2010 12:43am

yes have seen that and checked all the known issues, must be something up with my IIS setup.
Free Windows Admin Tool Kit Click here and download it now
October 6th, 2010 11:07am

OK managed to resolve this but not quite sure how ! I reinstalled the UDI webservice and choose the virtual directory name as OSDConfigService and it now works ok.
October 7th, 2010 2:52pm

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics