Target Audience field on Web Parts
Hi Guys I hope you can help. I have two separate Sharepoint web applications in two different regions (they are independant of eachother). If I edit a page and modify any WebPart on the page on one server, the "Target Audiences" field is displayed at the bottom of the properties in the Advanced section. Great! However, on the second web app, if I edit a page and modify a WebPart(including the standard MS webparts), I do not see the "Target Audiences" field. For some reason it is not available. I have tried several things to get it to appear, including enabling audience targetting on the lists themselves, ensuring the Target Audiences column still exists, enabling Audience targetting on the WebParts gallery etc. Several audiences exist, as well as imported users. The fieldappears onlists & navigation etc, but just not on the WebPart properties. Any idea why this field is not available? Thanks in advance. Col
March 30th, 2008 7:36pm

Hey Col, I am also experiencing a similar problem. My site was using audience targeting fine, i rebooted my front end server and now I can no longer target web parts to audiences, the option has disappeared in the web parts. But only for that application. Did you end up resolving your issue?ThanksCarlaCarla
Free Windows Admin Tool Kit Click here and download it now
November 26th, 2008 7:49am

Actually. rebooting the server was all that was required. Not sure what happened there but it seems to be fixed.CheersCarla
November 26th, 2008 8:27am

So I know this is an old thread... However, for me it was lacking an alternate access mapping. I typically worked on my development server remotely, using the FQDN. However, I was actually working from home using just the computer name. SharePoint happily responded, with no "apparent" error messages. However, in the log files I was seeing: Invalid URL: http://servername. You may also need to update any alternate access mappings referring to http://FQDN. Help on this error: simply added the servername AAM, and audiences (including the field on the web part toolpane) were working again.Hope that helps somebody out.william
Free Windows Admin Tool Kit Click here and download it now
April 5th, 2009 10:54pm

Moving to admin.Not programming.WSS FAQ sites: WSS 2.0: WSS 3.0 and MOSS 2007: Total list of WSS 3.0 and MOSS 2007 Books (including foreign language titles)
April 6th, 2009 9:09am

I had the same problem, and a reboot solved the issue. But this cannot be t he solution, since I will not be able to reboot a producitve system as I want...! Are there any news concerning this problem around?
Free Windows Admin Tool Kit Click here and download it now
October 8th, 2009 10:08am

Instead of rebooting, I have found that you can just restart the Windows SharePoint Services Administration service followed by an iisreset. This is definitely a strange issue though. I wish I knew why it was happening.Corey Roth blog: twitter:
November 10th, 2009 10:11pm

I've got the same problem, but with SharePoint Server 2010 beta 2 and rebooting does not help. Does anyone know another solution?
Free Windows Admin Tool Kit Click here and download it now
January 26th, 2010 5:04pm

Same issue: Its on a production machine running RTM bits. Audience targeting in enabled on the corresponding list. The ListView webpart is added to page along with other. Hit advance and nothing shows Reboot does not appear to fix issue. I remember this happening in 2007 when SSP wasnt configured. However that should be a moot point in 2010... Anyone on the product team have an idea? Correction, anyone period have any potential resolutions for this?( already tried reboot).
July 8th, 2010 5:04pm

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics