Software package will not install

Hi, I have software package that will not install as a package from SCCM . It uses install script so it has a setup.iss file .

When I run the program locally with elevated commmand promt the command line works fine and software is installed.


c:\software\setup.exe /s /f1c:\software\setup.iss

When I run the batch file locally it runs fine too with elevated command prompt

%~dp0setup.exe /s /f1%~dp0setup.iss

Locally when I run the program with LOCAL SYSTEM command propmt , it fails.

Errors are related to software install codes and not specific to SCCM. Though I understand it is probably not the best place to post  this problem but may be someone has faced this problem before.

I get error code=-3

To eliminate access issue to going to distribution point with $computername account , I split the package and have first part copy the files to local computer and then second package run the program.

It still fails.

So , I try to run the program from Task sequence as a command line , it still fails..

Any suggestions....bueller ...

  • Edited by PicSee Tuesday, January 14, 2014 8:43 PM
January 14th, 2014 11:42pm

cmd.exe /c setup.exe /s /f1%cd%\setup.iss
Free Windows Admin Tool Kit Click here and download it now
January 15th, 2014 3:14pm

I tried running a command line from Task sequence with f2 option , launching Task sequence manually and the command works !! Thanks Jason for the link . I used following to test from a one command task sequence

c:\software\setup.exe /s /f1c:\software\setup.iss /f2c:\setup.log

However when  I add the exact command line in OSD task sequence as a step it fails . 

Only difference I can think of is -  during OSD no user is logged in while when I launch the task sequence manually (one with only one command line) with a non admin user it works.

Thanks Jorgen and Kamala , I tried your suggestions but it did not work.

January 16th, 2014 12:08am

Are you using a package for this? If so, what exactly is the command-line that you are using in the program?
Free Windows Admin Tool Kit Click here and download it now
January 16th, 2014 4:18am

Hi Picsee,

I have a question why you are installing it from c:\software\setup.exe  ?( why you are doing like this ie copying the source from SCCM cache to this path  in  C drive wherein you can do the execution from the Cache only with the command which i provided) the command which you used and the command which i gave seems to be same ,mine will look for the content in the sccm cache folder where as your's will look for the content in the C drive folder path ,i don't think this is the good method to the deployment.

why you need to execute from a path in C drive, when you can do it from the CACHE which is the main reason for SCCM tool for deployment otherwise you can use just a batch file by manual copy and can install right ?

January 16th, 2014 12:58pm

Hi Kamala, I was copying to files down to c drive to isolate the issue of access denied which I had received during package testing. Though I agree package should run like you described.

Thanks for your help.

Free Windows Admin Tool Kit Click here and download it now
January 16th, 2014 2:35pm

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics