Software package will not install

Hi, I have software package that will not install as a package from SCCM . It uses install script so it has a setup.iss file .

When I run the program locally with elevated commmand promt the command line works fine and software is installed.


c:\software\setup.exe /s /f1c:\software\setup.iss

When I run the batch file locally it runs fine too with elevated command prompt

%~dp0setup.exe /s /f1%~dp0setup.iss

Locally when I run the program with LOCAL SYSTEM command propmt , it fails.

Errors are related to software install codes and not specific to SCCM. Though I understand it is probably not the best place to post  this problem but may be someone has faced this problem before.

I get error code=-3

To eliminate access issue to going to distribution point with $computername account , I split the package and have first part copy the files to local computer and then second package run the program.

It still fails.

So , I try to run the program from Task sequence as a command line , it still fails..

Any suggestions....bueller ...

  • Edited by PicSee 15 hours 28 minutes ago
January 14th, 2014 3:48pm


have you tried running it in a task sequence running under a user account? that has saved me in some rare situations.


Free Windows Admin Tool Kit Click here and download it now
January 14th, 2014 4:11pm

Try adding the /f2 option (for logging) to the command-line:
January 14th, 2014 5:58pm

Did you tried running with the help of allow user interaction also

cmd.exe /c %~dp0setup.exe /s /f1%~dp0setup.iss.

Free Windows Admin Tool Kit Click here and download it now
January 15th, 2014 6:15am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics