Site backup failed

Hi Team ,

Recently I am facing a problem take an backup of my SCCM 2012 server. it gives error like "[error code: 21, error message: The device is not ready." the mysterious thing is that during backup if i opened the destination folder ,under sitedb folder i can see the SCCM db but after few minutes later it will automatically deleted and showing this error. Below some few points for our environment.

SCCM 2012 , Cluster DB , backup location stored on same server . disk space free 580 gb.


  • Edited by tushard Monday, May 25, 2015 3:13 PM
May 25th, 2015 3:12pm

I would strongly recommend that you disable the built-in SCCM backup feature, and start using native SQL Backup (Or any 3rd. party backup that you prefer).

Here is a great post by Steve Thompson, that explains why this is important, and how to configure it:
https://stevethompsonmvp.wordpress.com/2013/06/07/sql-server-backup-recommendations-for-configuration-manager/

Free Windows Admin Tool Kit Click here and download it now
May 26th, 2015 6:19am

I have tried to do the task as suggested by you with no luck. 

May 27th, 2015 10:56am

Thanks for the help but is this a bug , because without using the default option of SCCM 2012 is this a good approach to bypass it.
Free Windows Admin Tool Kit Click here and download it now
May 27th, 2015 10:58am

Why is a SQL-native backup also not working? That is another supported option to backup/restore a site.
May 27th, 2015 2:10pm

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics