Sharepoint configuration - WSS search error
Hello, I have successfully installed SharePoint2007 on Windows 2008 R2 STD 64 bit OS. I have a dedicated SQL server (Actually it is a cluster). Trying to configure Windows Sharepoint Server Search service and getting the error. First I was getting Unknown error. After that I updated the web.config for more error logs (<SafeMode MaxControls="200" CallStack="true" and <customErrors mode="Off" />). And I found new error that request is getting time out. The database is indeed getting created that means the credentials are good and I can see that in logs that credentials are verified. So, I think it is because of the IIS or website config issue. Also, want to mention that the SharePoint Central Administration is too slow to respond. Whenever I click to open any page, it take too long to respond. I thought first time this happens, but since last two days I haven't seen any improvement. SharePoint server is a VM and Database server is Physical server. No firewall in between right now. Please help. Thank you. Ronak Bhatt
May 16th, 2012 12:00pm

It would be useful to see the text of the exception you circled in your second image. From the "Request timed out" error you see in SharePoint and the SQL-related exception in your ULS logs it sounds to me like the connections from SharePoint to SQL Server are timing out before the queries return results. On the SQL Server, do you see anything in the error log or any errors in the event logs? Jason Warren Infrastructure Specialist Habanero Consulting Group habaneroconsulting.com/blog
Free Windows Admin Tool Kit Click here and download it now
May 16th, 2012 12:53pm

I checked the logs on SQL Cluster and haven't noticed any error or warning. I believe the same - the connection is timing out. And as the SharePoint Central Administration website is also slow I think the IIS is the issue but I don't know how to fix that. I read so many articles for the slow sharepoint site and IIS but cannot figure out where to start or how to fix. Is the IE 8 browser can be the issue? Ronak Bhatt
May 16th, 2012 1:15pm

Can you describe your farm a bit? How many servers? What are their roles? What are their hardware specs (processors and speed, memory, disk size and type, network. Nothing too detailed, just to see if there are any obvious performance bottlenecks)? I don't think it's IIS or the client side, the issue looks like the SharePoint server is timing out when connecting to the database server. Jason Warren Infrastructure Specialist Habanero Consulting Group habaneroconsulting.com/blog
Free Windows Admin Tool Kit Click here and download it now
May 18th, 2012 4:40pm

Yes, Today I involved one of our network guys and he also found that IIS is fast. It is the connection timing out just like what you mentioned. Environment: Just two servers. Both server currently are on same network. No firewall in between. SharePoint Server: ( Web server/Search Query indexing - I haven't configured search/indexing yet, only Web server configured) Windows 2008 R2 Std 64 bit. VMware Virtual Machine - 8 GB Memory - 2xvCPU ( 2.16 GHz each) - 40 GB C: drive IIS 7, .NET 3.5.1 Database Server: Windows 2003 R2 Ent SP2 Windows Cluster - SQL Cluster Microsoft SQL Server 2005Ronak Bhatt
May 18th, 2012 4:59pm

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics