SharePoint with LDAP ?
I saw a SharePoint demo in Quebec city yesturday.... It is a great product, I need to get this....! But... We don't use Active directory because we are in a Novell Environement... There is no way we'll change it for now ! Could SharePoint adapted to work on a LDAP Network...? LDAP and AD are a bit similar....
January 12th, 2007 7:55pm

I assume you are talking about SharePoint 2007. If so, it does support LDAP authentication by using the LDAP membership provider. Here's a link to a sampl....
Free Windows Admin Tool Kit Click here and download it now
January 13th, 2007 11:06pm

Mike Harsh has a comprehensive list web.config entries for different authentication provider on his blog. You can access the post below: Hope this helps cheers
January 14th, 2007 4:48pm

Hello,I also tried to use a LDAP identification, but I don't get something :To consult the content of LDAP annuary, you must have some credentials in order to log in it. But I don't find WHERE I must put the authentification informations...The content of the URL from technet doesn't specify a login/password for the LDAP annuary but I need one, because my LDAP is not Microsoft. I already put the right content in de 2 wb.config files (administration site and the site authenticated)Has someone a good tutorial with a LDAP other than Microsoft ?Thanks
Free Windows Admin Tool Kit Click here and download it now
March 2nd, 2007 12:41pm

If I understand correctly, you are not able to authenticate the LDAP for verification of credentials. Check out whether the identity of the Application Pool under which the web application is running has the rights for verification with the LDAP.
June 7th, 2007 1:26pm

I am getting the same error with LDAP. Having credential problem. Proper Edit web.config file of both Central Admin as well as web application. go to central admin ->authentication provider and put the correct selection and give membership provider name as well as role provider. then go to site collection administrator where through people picker i searched my name and found user with new membership. added user through policy for web application. iisreset . i opened the site redirected to login page. But when i put user name and password here the message comes like "The server could not sign you in. Make sure your user name and password are correct, and then try again. " why it not logging me in..? why it dont take credential for specified user from web application? I searched here and there and almost read out whole the blogs to get the solution. what exactly i am missing or what ? Abhishek
Free Windows Admin Tool Kit Click here and download it now
July 18th, 2007 10:06am

Hi, I have the same problem and what I found out: LDAPMembeshipProvider didnt use any credentials for connecting to LDAP. It simply does unauthenticated bind and search for username which have to be loged. If it find the user, then use username and try log to LDAP with user credentials. BUT as you see the first one search bind to LDAP is NOBODY. Someone should modify the provider to use authentificated connection to LDAP. Please somebody clever to do it? Thanks Petr
July 29th, 2007 2:36pm

Thanks i can understand what u want to problem is i find the user through search dialog box having name LdapMemberShip:abhishek.singh. and authorized also that user to primary site collection administrator. It means LdapMembership providor is correctly configured to web.config. my question is if user is found in primary site collection administrator in central administration they why same user is not able to logged in through web application. thx abhishek
Free Windows Admin Tool Kit Click here and download it now
August 17th, 2007 3:44pm

I am having the same problem. Does anyone know how to fix this or if there is a work around?
October 24th, 2007 7:38pm

Can I give rights on my SHAREPOINT 2003 areas using LDAP Please suggest possible ways out.
Free Windows Admin Tool Kit Click here and download it now
November 29th, 2007 5:34pm

Hi Abishek, Did you ever find the solution because I am having the same issue. I can't login using the ldap credentials eventhough I was able to search and assign the same user as the administrator from Central admin. Please let me know. Thanks,
February 9th, 2011 2:37pm

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics