SharePoint SP1 with August Cumulative Fails

Installed SP Foundation SP1 thne SP Server SP1, also installed August Foundation Cumulative Update and the Server CU.

While running the Configuration Wizard the upgrade bombs.

10/12/2011 06:37:41  1  INF                          A NotifyEventArgs event received in TaskNotifyEventHandler. Task: applicationcontent NotifyEventArgs.EventCriticalityType: Installing the SharePoint Web Application content files... Message: info
10/12/2011 06:37:41  1  INF                          Acquiring the reader lock to retrieve the state
10/12/2011 06:37:41  1  INF                          Releasing the reader lock to retrieve the state
10/12/2011 06:37:41  1  INF                          Acquiring the reader lock to retrieve the state
10/12/2011 06:37:41  1  INF                          Releasing the reader lock to retrieve the state
10/12/2011 06:37:41  1  INF                          Updating the task notification additional message label
10/12/2011 06:37:41  1  INF                          Not running in high contrast, so we will paint the background with our trademarked image
10/12/2011 06:37:41  1  INF                        Leaving function ConfigurationProgressForm.InvokeTaskNotifyEventHandler
10/12/2011 06:37:41  13  INF                        Sleeping an extra 1 ms so things don't go too fast for the user for this task
10/12/2011 06:37:41  1  INF                        Not running in high contrast, so we will paint the background with our trademarked image
10/12/2011 06:37:41  13  INF                      Leaving function PsconfigBaseForm.TaskNotifyEventHandler
10/12/2011 06:37:41  13  INF                    Leaving function TaskBase.FireTaskNotify
10/12/2011 06:37:41  13  INF                  Leaving function TaskBase.OnTaskNotify
10/12/2011 06:37:42  1  INF                  Not running in high contrast, so we will paint the background with our trademarked image
10/12/2011 06:37:42  1  INF                  Not running in high contrast, so we will paint the background with our trademarked image
10/12/2011 06:37:42  1  INF                  Not running in high contrast, so we will paint the background with our trademarked image
10/12/2011 06:37:42  1  INF                  Not running in high contrast, so we will paint the background with our trademarked image
10/12/2011 06:37:42  1  INF                  Not running in high contrast, so we will paint the background with our trademarked image
10/12/2011 06:37:42  1  INF                  Not running in high contrast, so we will paint the background with our trademarked image
10/12/2011 06:37:44  13  ERR                  Task applicationcontent has failed with an unknown exception
10/12/2011 06:37:44  13  ERR                  Exception: System.NullReferenceException: Object reference not set to an instance of an object.
   at Microsoft.SharePoint.Administration.SPAspConfigurationFile.ApplyActionToXmlDocument(XmlDocument xdAction, XmlDocument xd, String sourceFileName, SupportedXmlDocutmentActions supportedActions)
   at Microsoft.SharePoint.Administration.SPAspConfigurationFile.MergeWebConfig(XmlDocument xdWebConfig, String fileMask)
   at Microsoft.SharePoint.Administration.SPWebService.ApplyApplicationContentToLocalServer()
   at Microsoft.SharePoint.PostSetupConfiguration.ApplicationContentTask.Run()
   at Microsoft.SharePoint.PostSetupConfiguration.TaskThread.ExecuteTask()

Any help would be appreciated.

October 12th, 2011 4:44pm

reboot the server and then rerun configuration wizard
Free Windows Admin Tool Kit Click here and download it now
October 12th, 2011 5:19pm

I've done that, I've also stopped the Sharepoint 2010 Timer, SharePoint 2010 Administration, Sharepoint 2010 Tracing and Search Services and ran the Wizard. I've started the services as well and the Wizard continues to fail.

 

The environment is highly customized, with Masterpages, Layouts, webparts, CSS and the like.

From the error it appears that the Wizard is attempting to make a change to the Web.Config. Am I correct in assuming this?

October 12th, 2011 5:31pm

Take a look in your ULS logs at around 06:37:44.  See if you can find what object it is attempting to manipulate (it may reference it prior to that error).
Free Windows Admin Tool Kit Click here and download it now
October 12th, 2011 6:30pm

****Process Monitor*****

READ - C:\inetpub\wwwroot\wss\VirtualDirectories\80\web.config
QUERYDIRECTORY - C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\CONFIG\webconfig.*.xml
CREATE, QUERY, READ, CLOSE - C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\CONFIG\WEBCONFIG.ACCSRV.XML
CREATE, QUERY, READ, CLOSE - C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\CONFIG\webconfig.dlc.xml
CREATE, QUERY, READ, CLOSE - C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\CONFIG\webconfig.ewr.xml
CREATE, QUERY, READ, CLOSE - C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\CONFIG\webconfig.extended.search.xml
CREATE, QUERY, READ, CLOSE - C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\CONFIG\webconfig.filtercontrols.xml
CREATE, QUERY, READ, CLOSE - C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\CONFIG\webconfig.ipfs.xml
CREATE, QUERY, READ, CLOSE - C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\CONFIG\webconfig.mosschart.xml
CREATE, QUERY, READ, CLOSE - C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\CONFIG\webconfig.osrv.xml
CREATE, QUERY, READ, CLOSE - C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\CONFIG\webconfig.pps.xml
CREATE, QUERY, READ, CLOSE - C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\CONFIG\webconfig.prfpgs.xml
CREATE, QUERY, READ, CLOSE - C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\CONFIG\Webconfig.rs.xml
CREATE, QUERY, READ, CLOSE - C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\CONFIG\webconfig.sps.xml
REGOPENKEY - HKCU\Software\Classes\CLSID\{0A29FF9E-7F9C-4437-8B11-F424491E3931}\InprocServer32, NAME NOT FOUND
REGOPENKEY - HKCR\CLSID\{0A29FF9E-7F9C-4437-8B11-F424491E3931}\InprocServer32
REGQUERYVALUE - HKCR\CLSID\{0A29FF9E-7F9C-4437-8B11-F424491E3931}\InprocServer32\(Default) , the name is MSCOREE.DLL

After this psconfigui.exe tries to find the psconfigui.pdb file and then begins writing to the dump file.


*****SharePoint ULS Log*****

Looking in the sharepoint logs I see this and it appears to throw the GUID Error for each the web.configs captured by Process Monitor.

10/12/2011 07:41:42.78  psconfigui.exe (0x10D8)                  0x0FF0 SharePoint Foundation          Topology                       886y High     An action in C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\config\webconfig.sps.xml does not contain an id attribute with a unique guid value.  This action may be performed repeatedly, causing duplicate entries in the web.config. 
10/12/2011 07:41:42.80  psconfigui.exe (0x10D8)                  0x0FF0 SharePoint Foundation          Topology                       5aug Medium   Releasing a server lock by name 
10/12/2011 07:41:42.80  psconfigui.exe (0x10D8)                  0x0FF0 SharePoint Foundation          Topology                       5auh Medium   Successfully released a server lock. type = [Upgrade], server=[MOSS-WFE-02], object=[] 
10/12/2011 07:41:48.53  psconfigui.exe (0x10D8)                  0x0338 SharePoint Foundation          Topology                       aae1 Medium   Updating server locks. 
10/12/2011 07:41:48.53  psconfigui.exe (0x10D8)                  0x0338 SharePoint Foundation          Topology                       aae2 Medium   Successfully updated [0] server locks. pid=[4312] 

To the end of Sharepoint Log.

*****PSCDIagnostic*****

10/12/2011 07:41:42  15  ERR                  Task applicationcontent has failed with an unknown exception
10/12/2011 07:41:42  15  ERR                  Exception: System.NullReferenceException: Object reference not set to an instance of an object.
   at Microsoft.SharePoint.Administration.SPAspConfigurationFile.ApplyActionToXmlDocument(XmlDocument xdAction, XmlDocument xd, String sourceFileName, SupportedXmlDocutmentActions supportedActions)
   at Microsoft.SharePoint.Administration.SPAspConfigurationFile.MergeWebConfig(XmlDocument xdWebConfig, String fileMask)
   at Microsoft.SharePoint.Administration.SPWebService.ApplyApplicationContentToLocalServer()
   at Microsoft.SharePoint.PostSetupConfiguration.ApplicationContentTask.Run()
   at Microsoft.SharePoint.PostSetupConfiguration.TaskThread.ExecuteTask()

 

Process Monitor shows a query for allthe files in the Hive\Config starting with webconfig and ending the xml,

QUERYDIRECTORY - C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\CONFIG\webconfig.*.xml

poking around in the Hive\Config I see more files after the webconfig.sps.xml file, so I'm thinking the problem is with the merge of the webconfig.sps.xml????

 

October 12th, 2011 6:49pm

The SharePoint Configuration Wizard was attempting to merge the following file C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\CONFIG\webconfig.sps.xml with the C:\inetpub\wwwroot\wss\VirtualDirectories\80\web.config. Some of the entries in the webconfig.sps.xml already existed in the web.config. I merged the files manually, removed the conflicting items from the webconfig.sps.xml and the upgraded was able to complete.

 

 

Free Windows Admin Tool Kit Click here and download it now
November 1st, 2011 6:24pm

This is very painful situation .I was stuck on this till 2days and did goggling a lot.But didn't get the solution .I tried so many ways but no success .So finally I removed all the config and XML files from the C:\Program Files\Common Files\microsoft shared\Web Server Extensions\15\CONFIG and run the PSConfig wizard again.This time got success finally .really unexpected.

  • Proposed as answer by manu7143 3 hours 18 minutes ago
November 20th, 2014 6:53pm

One of the custom web.config files was out-dated and not removed on that server .(location of the config files: C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\15\CONFIG)

FIX:I have moved all the  config files and XML files temporarily to a separate folder and then ran configuration wizard and it did pas with no issues.  Later i copied them back.


Free Windows Admin Tool Kit Click here and download it now
February 7th, 2015 3:52am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics