SharePoint 3.0 Service Unavailable
When I tried to open Central Admin page, I got Service Unavailable error. The strange thing is it worked fine before.I then google the solution, one thing mentioned that you have to add STS_WPG into your group. I then checked the user group from computer management, It only contains IIS_WPG, no STS_WPG. I don't know why it was not there.I also noticed that when I tried to browse the Central Admin, the app pool got automatically stopped. My app pool use predefined account "NETWORK SERVICE".Please help me. '
February 17th, 2010 9:49pm

It sounds as if you have several things going on with your server. It would be near impossible for us to debug your server without getting on the server and trouble shooting it. I would recommen the following:1. Identify what changed between when it worked and when it didn't2. Find out why the App pool is terminating - this is more than likely the issue as to why the site isn't working. You will need to review: - SharePonit Logs - IIS Logs - Event ViewerLook for specific errors that have to do with that IIS site or APP Pool and troubleshoot.I hope this helps-Jeff DeVerter, MCSERackspaceblog:
Free Windows Admin Tool Kit Click here and download it now
February 17th, 2010 11:49pm

Thanks for your help Jeff.Below is part of the Event logs: Application pool 'SharePoint - 14190' is being automatically disabled due to a series of failures in the process(es) serving that application pool. For more information, see Help and Support Center File Name iisres.dllFile Version 6.0.3790.1830Product Name Internet Information ServicesSource W3SVCI also checked the sharepoint logs, I did not understand what those words means.Also, my sharepoint hosts by x64 IIS server.
February 18th, 2010 12:18am

Hello, Can you access any of your SharePoint sites or is it just Central Administration?Have you recently did any upgrades/patches/hotfixes? I have run across an issue where a Microsoft KB article is breaking SharePoint environments. A colleague of mine wrote a great post about it here: Caravajal MCTS SharePoint Help
Free Windows Admin Tool Kit Click here and download it now
February 18th, 2010 12:28am

No, none of them are working. I just checked with our system admin, and he comfirmed that he did run patches last week. I guess that may be the reason.Per the link, it says just uninstall the evil KB973917 and reinstalled SP2 for Windows Server 2003. Do you think that will fix it?Thanks for your time and patient
February 18th, 2010 12:56am

Hi, From your post, your application pool run under predefined account "NETWORK SERVICE". Try to change the Identity from network services to Domain\Administrator account. Reset IIS and check whether you are able to browse the Central admin. You can try to reinstall Windows Server 2003 SP2 and add the domain account to the aforementioned local groups(IIS_WPG, WSS_WPG and WSS_RESTRICTED_WPG) on the server, then check the result. If the steps above can’t resolve your issue, try to follow the following KB article to synchronize service account passwords, then check the effect. How to change service accounts and service account passwords in SharePoint Server 2007 and in Windows SharePoint Services 3.0 Hope this helps. Rock WangRock Wang MSFT
Free Windows Admin Tool Kit Click here and download it now
February 19th, 2010 6:50am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics