Setup Windows Azure Workflow - Add-WFHost error "WF_Management/WFTOPIC" and token provider service


i want to install the new windows azure workflow manager and service bus on my sharepoint 2013 server.

All works fine in setup. I got the Powershell-Script from the wizard and configured it to meet my requierments.
I start it and get to the last point "add-wfhost".
Here i got following error:

VERBOSE: [12.12.2012 09:30:13]: Validating input and configuration parameters.
VERBOSE: [12.12.2012 09:30:14]: Installing auto-generated certificate.
VERBOSE: [12.12.2012 09:30:16]: Granting 'Log on as Service' privilege to the RunAs account.
VERBOSE: [12.12.2012 09:30:16]: Workflow Manager configuration starting.
VERBOSE: [12.12.2012 09:30:19]: Configuring Workflow Manager runtime settings.
Add-WFHost : Could not successfully create management Service Bus entity 'WF_Management/WFTOPIC' with multiple retries within a timespan of 00:02:05.7914488.. The exception of the last retry is: The 
token provider service was not avaliable when obtaining a token for 'https://myServer.sps2013.local:9355/WorkflowDefaultNamespace/$STS/Windows/'.. 
At C:\Users\wawsrv\Documents\workflowconfiguration.ps1:42 char:1
+ Add-WFHost -WFFarmDBConnectionString 'Data Source=myServer.sps2013.local;Initia ...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : OperationStopped: (:) [Add-WFHost], TimeoutException
    + FullyQualifiedErrorId : WFRuntimeSettingFailed,Microsoft.Workflow.Deployment.Commands.AddWFHost

I installed it on a sharepoint 2013 box server (AD, DNS, SQL and SP on one maschin).
I know this is not supported, but it should work. Im loged in as the service account for the workflow. I've granted the domain admin rights and sql sysadmin /dbowner rights.

Now my answer is:

It is not the "normal" error with the wf_management/WFTOPIC. What is this token provider service and why he tries the port 9355. I dont use ssl, so how can i change the request url or how do i have to set it up correct?

Thx alot on this!

December 12th, 2012 8:58am


The problem is not the token service, but the gateway.

I found it in the event logs of the system. My server was unable to get its own website. After disabling proxy and setup gateway correct, all works fine and i've managed it to run workflow manager.

Now i got the new workflow engine up and runnin gon single-server sharepoint box :)

  • Marked as answer by ragesoft Wednesday, December 12, 2012 3:20 PM
Free Windows Admin Tool Kit Click here and download it now
December 12th, 2012 3:20pm

When you say 'setup gateway correctly' what do you mean?

How was your gateway setup and what did you change?

I have the same problem, and despite removing all proxy settings, i am still having this issue. I can navigate fine to the 'WorkflowDefaultNamespace' and get a RSS Feed type of page, but when i add the $STS/Windows Virtual Directories, i get a 400 Bad Request. 

March 10th, 2014 10:49am

In my case also same issue, removed the proxy and it worked.
Free Windows Admin Tool Kit Click here and download it now
November 4th, 2014 10:16am

Thanks Yogesha
January 23rd, 2015 3:46pm

I removed the proxy but did not work. Any Suggestion?
Free Windows Admin Tool Kit Click here and download it now
April 10th, 2015 1:56pm

I disabled the proxy settings but continue with the problem, any suggestion?
April 10th, 2015 2:12pm

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics