SSRS Upload File with SSL enabled problem
Hi,I'm having a problem with uploading files about 100KB and larger in SSRS 10.0.2531.0 with SSL enabled (I'm running the Express Edition with Advanced Services). Oddly enough, I don't receive any errors/problems/time-outs if the file is less than about 100KB (with SSL enabled).Symptoms:After about 1 minuteof clicking the "Upload File" button in SSRS Report Manager, I receive this error - again with files about 100KB in size withReport Manager using an https:// url:The underlying connection was closed: An unexpected error occurred on a send.I don't seem to have a problem saving a 105KB.rdl file straight from Report Builder 2.0 to the instance in question (URL is: I'm not running IIS.- The Authentication type is set to RSWindowsNTLM in the rsreportserver.config file.- I've properly obtained and configureda computer certificate from our domain's CA (using the certificates mmc). Since I'm running SSRS with a service account, I had to use the winhttpcertcfg tool to allow the service account to read the local machine's cert store. - I've configured the Web Service and Report Manager URLs with RSCM (Reporting Services Configuration Manager). The URLs defined include unsecured http on port 80 and SSL on http port 443 (URLs are defined for the FQDN) i.e. , - I've tried all the values for "SecureConnectionLevel" in the rsreportserver.config file (valid values are '0|1|2|3' - I rebooted everytime I made a change to make sure the new setting was taken). Reference Link: I do seems to make a difference to get the "Upload File" button to work with 100KB or larger files when SSL is enabled.If I change "SecureConnectionLevel" to '0' and use the http port 80 URL for Report Manager, the "Upload File" button works fine. I'm about to just settle for a non-secured, internal SSRS deployment without SSL. Anybody have any insight?Thanks in advance.
August 31st, 2009 11:57pm

I don't know if there is a size limit with the Express Edition, but it sounds like a timeout issue more than an SSL issue to me. More than 1 minute to upload 100 KB sounds like a lot. Have you tried loading the reports locally or using a faster connection? Just food for thought...
Free Windows Admin Tool Kit Click here and download it now
September 1st, 2009 12:11am

I'm on our internal 100Mbit LANand yes I've also tried loading a report directly from the server hosting the SSRS difference unfortunately. The specific combination of enabling SSL and uploading a file 100KB or larger in size replicates the problem.I read this thread as well: unfortuantely, it didn't help because the solution was to effectly disable SSL which isn't what I'm trying to do.I may have found a lead here:;EN-US;915599. I'm going to investigate further.Thanks for the input.
September 1st, 2009 1:59am

The information in KB915599 is interesting, but I still have no resolution. I'm on a tight timeline and I'm going to set "SecureConnectionLevel" to '0' and removing the SSL binding in RSCM to get my project done. I really do think this is a bug in SSRS. Good luck to anyone else with this issue.
Free Windows Admin Tool Kit Click here and download it now
September 2nd, 2009 2:45am

I would love to know if anybody else has information about this... I have the exact same issue/error and the only thing that works for me is to continually re-configure SSRS to work with port 80, make my changes and then re-configure it again back to 443/SSL (which is a huge pain). My setup is a little different. I'm using Basic Auth and SSRS is running as the builtin network service account. It would be a bit easier if I could just have two different rsreportserver.config files (one for 80 and one for 443) switch them out and restart the service but that doesn't seem to work. Something else is happening (outside of the .config file) when you unbind and bind the web service and report manager urls...
December 29th, 2009 9:21pm

I have a similar problem with the this error message:"System.Net.WebException: The underlying connection was closed: An unexpected error occurred on a send. ---> System.IO.IOException: Unable to write data to the transport connection: An established connection was aborted by the software in your host machine. ---> System.Net.Sockets.SocketException: An established connection was aborted by the software in your host machine at ..."In my case I have 2 SSRS reports, one is about 100k and the other is about 257k. The smaller one deploys fine from VS and Report Manager in IE, but the larger one will not deploy from either. It worked once after several retries, but has not worked at all since then. the above post, I tried changing the registry setting for Http.sys MaxRequestBytes as a DWORD = 2097152 but still have the problem. I've tried quite a few things now and can't resolve it.
Free Windows Admin Tool Kit Click here and download it now
February 11th, 2010 1:44am

PROBLEM SOLVED for me. I formatted the forementioned PC and reinstalled Windows XP, SPs, SQL Server, SPs, Visual Studio, SPs in that order. The only thing missing from the new configuration is IIS Services and IIS manager but I don't know if this has anything to do with the problem described.
March 26th, 2010 1:26pm

Anyone had luck with this issue? I have the same problem, I can only upload max 95kb files. Unfortunately some of the rdl files are much bigger. Smaller files can be uploaded almost instantly, but if the size is more than 95k, I only get the dreaded "The underlying connection was closed: An unexpected error occurred on a send" error. I was digging articles and forums for 2 days now, the solutions from MS are for .NET 1.1 issues + there is a patch for that. Unfortunately reinstalling the server or using unsecure protocols aren't options for us. I'm using windows 2008, IIS v6.0, ASP.NET 2.0.50727.0, plenty of hw resources.. Thanks in advance.
Free Windows Admin Tool Kit Click here and download it now
April 24th, 2010 1:23am

I had a smiliar problem and the article below has helped me: "add a registry key named "MaxRequestBytes" to HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\HTTP\Parameters, which I did, and then restarted the appropriate services. Since I still had the issue I kept looking for a solution, and as it turns out, "MaxRequestBytes" should not be added as a registry key, but as a DWORD value" after adding MaxRequestBytes and restarting the server - the problem was resolved
May 18th, 2010 10:41pm

Just to clarify (because I was confused with this): Adding the above registry setting should be done on the Server machine, not on your local machine. Also, I didn't need to "restart the server" (don't have permission here to do that). Just adding the registry setting solved the problem for me. Thanks aedna and Nasser!
Free Windows Admin Tool Kit Click here and download it now
December 2nd, 2010 11:28am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics