SSRS 2008 Conditional Column Visibility Whitespace Issue
Hi Everyone,I am using IIF statements to show/hide tablix columns based upon a parameter value. These statements are used as expressions in the visibility properties for the columns.If the parameter value is one that causes the column to be hidden, the coulmn does not appear on the report, but there is whitespace in its place.I have used this functionality very frequently in SSRS 2005 without the whitespace issue. The 2005 report automagically closed this whitespace up by moving the column to the right of the hidden one to now be adjacent to the column to the left of the hidden one at rendering. This is what i need to happen now in 2008.Has anyone else experienced this? If so, would you please share your solution? I am getting extremely frustrated by this...Thanks!!
October 29th, 2009 11:47pm

If I understand this situation correctly, then I'd recommend the following steps that should resolve this:1. in the grouping pane, click on thesmall black triangle and select "Advanced Mode" to show static members in the grouping pane2. under the column groupings, you should now see a list of gray "(Static)" items. Select the item that represents the column that you want to conditionally hide. Once selected, the property grid window should show the tablix member properties for that static column. In those tablix member properties, make sure to set the Visibility.Hidden expression to the desired conditionBy doing this, you will hide the entire static column tablix member and as a resultthe whitespace will disappear.HTH,RobertRobert Bruckner This posting is provided "AS IS" with no warranties, and confers no rights.
Free Windows Admin Tool Kit Click here and download it now
October 30th, 2009 8:33am

Is it possible to hide columns to the left of the detail data? We have a report with up to 4 optional groups and would like to hide the column with the group name in it if nothing is selected. The column visibility options are unavailable on columns to the left of the detail data and it doesn't appear that there is a column group for them even when Advanced Mode is enabled. We can "hide" the column but it doesn't adjust the spacing and leaves the "hidden" column there. Thanks!
September 10th, 2010 9:37pm

In srss2008 I have found that if I conditionally hide columns of data using the visibilty settings in properties pane of the column, this hides the data but it leaves white space. If you select the column, right click and use column visibilty settings I don't get white space... new to SQL server reporting
Free Windows Admin Tool Kit Click here and download it now
September 28th, 2010 1:35pm

Hi Guys, you need change the report properties>consume container whitespace as True and checkout the result. Thanks & Regards, Veeren Chowdary.
November 10th, 2010 6:25am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics