SSRS 2005 - Extra Data (Characters) after SQL result
Hi, I ran into a snag with Reporting Services 2005. When I run a query in RS against SQL it returns me a result with some additional data (characters) + bunch of spaces!! So here is an example: my query returns a varchar, when I run it in SQL it is fine and returns me: "SHRIMP 5 SAMPLE" When I run it SSRS in the Data tab, I get "SHRIMP 5 SAMPLE E NET WT 5 SAMPLE " (extra data and bunch of spaces) It does it for all results. The extra characters are absolutelly unrelated to this record BTW so I have no clue where it's picking those up from! Here is what I tried so far without any luck: -I made sure the database is correct and I'm connecting to the correct source. -I created a brand new solution with a new report and inserted this pretty simple Query "Select Descr1 from Table where ObjectID=1234" -Tried different methods for the Datasets: stored procedure and text. -Tried Googling this problem and looked everywhere for 1 day, whata waste of time! :( BTW, I have to use RS 2005 becasue we have old Sharepoint and that's where I have to publish. Thanks!!
October 18th, 2010 8:52pm

Can you please post your query that you are running in SQL and in SSRS Data Tab?
Free Windows Admin Tool Kit Click here and download it now
October 18th, 2010 9:00pm

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics