SCUP 2011 publishing fails with error:  Failed to sign package; error was: 2148081670

Hi,

I have a SCUP 2011 installed on the same machine has SCCM 2012 and WSUS. I installed and configured SCUP 2011, as shown in this video http://www.youtube.com/watch?v=fyEGWSFWyy0. Everything was ok, but after upgrading to SCCM 2012 R2, i'm unable to publish to the update server.

Every single publishing attempt fails with error:

   at Scup.Wizards.PublishOperation.Start()         01/01/1601 00:00:00    33730480 (0x202AFB0)
   at Scup.Wizards.PublishProgressPage.DoWork(Object sender, DoWorkEventArgs e)         01/01/1601 00:00:00    33730480 (0x202AFB0)
   at System.ComponentModel.BackgroundWorker.WorkerThreadStart(Object argument)         01/01/1601 00:00:00    33730480 (0x202AFB0)
   at System.Runtime.Remoting.Messaging.StackBuilderSink._PrivateProcessMessage(IntPtr md, Object[] args, Object server, Object[]& outArgs)         01/01/1601 00:00:00    33730480 (0x202AFB0)
   at System.Runtime.Remoting.Messaging.StackBuilderSink.AsyncProcessMessage(IMessage msg, IMessageSink replySink)         01/01/1601 00:00:00    33730480 (0x202AFB0)
   at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)         01/01/1601 00:00:00    33730480 (0x202AFB0)
   at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)         01/01/1601 00:00:00    33730480 (0x202AFB0)
   at System.Threading.QueueUserWorkItemCallback.System.Threading.IThreadPoolWorkItem.ExecuteWorkItem()         01/01/1601 00:00:00    33730480 (0x202AFB0)
   at System.Threading.ThreadPoolWorkQueue.Dispatch()    Updates Publisher    27/11/2013 16:04:52    6 (0x0006)
PublishItem: InvalidException occurred during publishing: Failed to sign package; error was: 2148081670    Updates Publisher    27/11/2013 16:04:52    6 (0x0006)
Publish: A fatal error occurred during publishing :Signature verification exception during publish, verify the WSUS certificates and advanced timestamp setting are properly configured.    Updates Publisher    27/11/2013 16:04:52    6 (0x0006)
Publish: Background processing completed.    Updates Publisher    27/11/2013 16:04:52    1 (0x0001)

I have deleted and generate new self-signed WSUS certs, and i have imported them to the appropriated cert stores.

I have checked and double-checked the posts about this subject on this forum, but haven't found any working solution.

Appreciate all the help u guys can give me.

Best regards,

Adriano

November 28th, 2013 6:30pm

Hi,

If all the certificates are in the correct stores on the site server.

Have you looked at this Exception occurred during publishing.

Step by step Guide by Jason T.Lewis System Center Updates Publisher Signing Certificate Requirements

 

Free Windows Admin Tool Kit Click here and download it now
November 29th, 2013 11:03am

Hi,

I did everything like it's explained on the first link....Still not working. Since i have self-signed wsus cert, the 2nd link doesn't apply to my situation.

Any ideias?

December 3rd, 2013 7:05pm

Hi,

Please try applying the update below for this issue.

System Center Update Publisher does not publish customized updates to a computer if WSUS 3.0 SP2 and the .Net Framework 4.0 are installed

http://support.microsoft.com/%3Fkbid%3D2530678

Have you looked at this

System Center Update Publisher 2011 and Windows Server 2012

http://blogs.msdn.com/b/minfangl/archive/2012/12/01/system-center-update-publisher-2011-and-windows-server-2012.aspx

Free Windows Admin Tool Kit Click here and download it now
December 4th, 2013 6:29am

Hi, 

Sorry for not having give feedback on this, but i totally gave up on scup with sccm 2012 r2, and started to update machines deploying adobe and other updates as applications.

But now i finally figured out and solved the problem about scup/wsus/sccm 2012 r2.

For me the answer was this post a friend of mine sent me today:

http://blogs.technet.com/b/wsus/archive/2013/08/15/wsus-no-longer-issues-self-signed-certificates.aspx

By changing the registry and generating a new cert (and deploying it to the 2 additional cert stores) it now works.

Hope it helps others.

January 20th, 2014 7:52am

Hi,

Glad to hear that and thanks for your feedback.

Have a nice day.

Regards.
Free Windows Admin Tool Kit Click here and download it now
January 20th, 2014 9:08pm

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics