SCOM 2012 Beta RPC over NAT
I'm trying to install SCOM 2012 Beta and I am having some issues getting it to talk to my DB Server. I have all ports open between my DB (NAT IP) and SCOM Server, it can connect to SQL 08 R2 on 1433 fine however it has errors trying to analyze the DB server. [13:53:57]: Always: :DatabaseConfigurationPage: Attempting to connect to database using server\instance otdb00. If we need it, the port is 1433 [13:53:57]: Debug: :MSSQLSERVER on server otdb00 is in a running state [13:53:57]: Info: :Info:Opening/Testing Sql Connection on otdb00, port: [13:53:57]: Debug: :Connection was not open. We will try to open it. [13:53:57]: Debug: :SqlConnectionReady returned True. [13:53:57]: Info: :GetSqlVersion: Collecting SQL Instance information for otdb00 [13:53:57]: Error: :GetSqlVersion(): Threw Exception.Type: System.Runtime.InteropServices.COMException, Exception Error Code: 0x800706BA, Exception.Message: The RPC server is unavailable. (Exception from HRESULT: 0x800706BA) [13:53:57]: Error: :StackTrace: at System.Runtime.InteropServices.Marshal.ThrowExceptionForHRInternal(Int32 errorCode, IntPtr errorInfo) at System.Management.ManagementScope.InitializeGuts(Object o) at System.Management.ManagementScope.Initialize() at System.Management.ManagementObjectSearcher.Initialize() at System.Management.ManagementObjectSearcher.Get() at Microsoft.EnterpriseManagement.OperationsManager.Setup.Common.SetupValidationHelpers.GetSqlVersion(String sqlServerInstance) [13:53:57]: Always: :Current Version of SQL=0.0 Required Version=10.1.0.0 [13:53:57]: Info: :Info:Using DB command timeout = 1800 seconds. [13:53:57]: Info: :Info:Using DB command timeout = 1800 seconds. [13:53:57]: Info: :The SQL Collation is valid. [13:53:57]: Info: :Info:DatabaseConfigurationPage: DB connection attempt completed. [13:53:57]: Info: :Info:DatabaseConfigurationPage: DB connection attempt completed. The DB server is on a 10. address with a natted public IP for communication with servers outside the 10. range. The servers in the 10. range can communicate with WMI/RPC on the DB server just fine but the SCOM server seems to bug out. Tried using wbemtest, wmimgmt, and wmic with the same issue. I also tried creating an entry in hosts for the shortname using the NAT IP.
August 26th, 2011 2:01pm

Is there any way that you could test without the NAT IP feature?Anders Bengtsson | Microsoft PFE | blog at http://www.contoso.se
Free Windows Admin Tool Kit Click here and download it now
September 1st, 2011 6:51am

If you are using static NAT, with the correct port configuration you should be able to get this to work. If NAT is dynamic, this will definitely fail.Pete Zerger, MVP-OpsMgr and SCE | http://www.systemcentercentral.com
October 15th, 2011 9:35am

I'm also receiving the same error with SCOM 2012 RTM, Backend is SQL 2008 R2 build is 10.50.2796.0Thanks, Shehatovich
Free Windows Admin Tool Kit Click here and download it now
October 16th, 2012 10:51am

it would be best to start a new thread, with information about your specific error, as well as where your getting the error, like setup, ms setup and a screen shot. this thread is over a year old and should be closed.Scott Moss MVP (Operations Manager) President - System Center Virtual Users Group |Vice President - Atlanta Southeast Management Users Group (ATL SMUG) Please remember to click Mark as Answer on the post that helps you! my new blog om2012.wordpress.com
October 18th, 2012 9:34am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics