SCE 2010 Publisher Certificate Renew not working

Hi Guys,

we have several Windows Server 2008 R2 with System Center Essentials 2010. The Self Signed Certificates of the oldest SCE Server are now about to expire. After some research i tried in a (small) environment to renew the certificates with the UpdatePublisherCert.exe from the SDK. I get the following output:

Updates publisher certificates and re-signs all software packages.
Copyright 2010 Microsoft Corporation.  All rights reserved.
Saving policy configuration parameters...
Can not find Policy key in registry SOFTWARE\Microsoft\System Center Essentials\
Uninstalling the policy...
Deleting certificates from the store...
Deleting certificates from file system...
Reconfiguring the policy...
Re-signing the packages. This will take long time. Please wait...
Update Server is null. We can not proceed.
Successfully re-signed the packages.

Since ist not the first time i run this exe he can't find the policy because its already deleted. The problem is this part: "Update Server is null. We can not proceed." The old certificates have been deleted but no new ones have been created. With the consequence that Windows Update is not longer working on the Clients/Server and several errors in the Event log of the SCE.

Can you tell me the reason of this error and how to fix it? Before i run the exe in bigger environments i have to be sure that it is working without errors.

Best regards,


May 29th, 2015 9:04am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics