SCCM SQL Permissions Error
Hi All, Bit of a confusing one here so hopefully someone can assist. SCCM has been working perfectly for the past few months, but recently I have noticed some errors being logged in both SMS_HIERARCHY_MANAGER and SMS_SITE_SYSTEM_STATUS_SUMMARIZER, with the latter erroring every minute with the following message:- "Microsoft SQL Server reported SQL message 297, severity 16: [42000][297][Microsoft][ODBC SQL Server Driver][SQL Server]The user does not have permission to perform this action. Please refer to your SMS documentation, SQL documentation, or the Microsoft Knowledge Base for further troubleshooting information." I've had a search through the event logs and no error messages are being logged on the SQL server. The only recent change was that we had a separate issue where the site server's computer account had to be re-created, but as far as I can tell this is in all correct local admin groups, SQL permissions on the database etc. Tried running through a site-reset to no avail. All SCCM aspects still work fine, and so it's not impacting use on a day to day basis, but I'd like to clear this up if at all possible. All suggestions appreciated. Regards, Neil
October 7th, 2010 1:45pm

Have you rebooted the site server since adding it back to the security group(s) granting it local admin privileges and SQL sysadm rights?Jason | http://myitforum.com/cs2/blogs/jsandys | http://blogs.catapultsystems.com/jsandys/default.aspx | Twitter @JasonSandys
Free Windows Admin Tool Kit Click here and download it now
October 7th, 2010 3:25pm

Hi Jason, Yes, all servers have been rebooted multiple times time since the changes.
October 7th, 2010 3:53pm

If you are positive that the site system's server account is a local admin on the SQL Server and a sysadm in SQL Server, then it might be time to call CSS.Jason | http://myitforum.com/cs2/blogs/jsandys | http://blogs.catapultsystems.com/jsandys/default.aspx | Twitter @JasonSandys
Free Windows Admin Tool Kit Click here and download it now
October 7th, 2010 3:56pm

I had a horrible thought you were going to say that Jason. I've just double checked the permissions and it's still throwing the errors so I'll call CSS now. Thanks anyway! Neil
October 7th, 2010 4:29pm

Hello Neil, If there's any solution, we’d love to hear your feedback about it. By sharing your experience you can help other community members facing similar problems. Thanks,Yog Li -- Please remember to click Mark as Answer on the post that helps you, and to click Unmark as Answer if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
Free Windows Admin Tool Kit Click here and download it now
October 15th, 2010 10:23am

I have the same error... Did you have it resolved? Thanks, -AlexAlex Ignatenko | MCTS:UC Voice, Virtualisation, SCCM | MCSE: Security | MCITP:Server 2008
October 19th, 2010 8:47pm

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics