SCCM Reporting Services Error
I am getting the following error when i run Reports of reporting services from the SCCM console. SQL 2008 is hosted on the Seperate machine with Windows server 2008 R2. "An error occurred during client rendering. An error has occurred during report processing. (rsProcessingAborted) Cannot impersonate user for data source 'AutoGen__5C6358F2_4BB6_4a1b_A16E_8D96795D8602_'. (rsErrorImpersonatingUser) Log on failed. (rsLogonFailed) For more information about this error navigate to the report server on the local server machine, or enable remote errors "
April 21st, 2010 2:33am

Hi, Have you changed the password of the reporting user account ?Bechir Gharbi. MCSA, MCSE M+S, MCITP Server/Enterprise Administrator, MCT, MCTS Configuration Manager/Forefront (Time Zone : GMT+1)
Free Windows Admin Tool Kit Click here and download it now
April 21st, 2010 10:59am

No i Didnt change the password....
April 22nd, 2010 3:15am

Hello Friend, You have not configured the roles for the Domain Group/Users. To do that launch the Report manager URL(http://<SERVER name>/Reports) with a user having administrative priviledges on the server. Useually members of BUILTIN\Administrators on server has full rights. On the home page of Report Server, Click on properties tab. You will see the relation between Domain Group/Users and roles. Assign the roles to users there and You will be able to run. By default, torun a repoprt a user need to be added to browser role. Please let us know if this helped. Thanks, Sudhi. Cheers, Sudhiiiii.....
Free Windows Admin Tool Kit Click here and download it now
April 22nd, 2010 7:54am

If the issue still persists after following Sudeesh's suggestion, please try to check this step: 1. On the server hosting the DPM SQL server database - Open up the Local users and Groups and double-click the group named DPMDBReaders$Machine_Name 2. There should be an account named DPMR$machine_name 3. Go to Administrative Tools-->Local Security Policy. 4. On the left hand side, go to Security Settings-->Local Policies-->User Rights Assignment. 5. Double-click on "Allow log on locally". 6. Click on "Add User or Group" and add the DPMR$Machine_Name account. Click OK. Hope it helps.
April 22nd, 2010 11:47pm

This looks like a data source configuration issue. How is your data source configured? There are several options: a) Use Integrated Windows security b) Use stored credentials c) No credentials Which option are you using and I can help you troubleshoot further. Thanks, Bhaskar
Free Windows Admin Tool Kit Click here and download it now
April 23rd, 2010 5:30pm

Thanks For reply I Have Used "Credentials Stored securely in the report server". The user account that i use is local admin on the SQL Server and SCCM Server.
April 28th, 2010 7:15am

Thanks for all, I found the issue.In the Data source authentication of Report Server properties,i didnt check the "Impersonate the authenticated user after the connection has been made to the data source" I checked it. It started working.. Thanks for all
Free Windows Admin Tool Kit Click here and download it now
April 28th, 2010 7:20am

In my case I've changed the expired password of the user account stored in "Credentials stored securely in the report server" . :-)lara
July 19th, 2012 6:25am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics