SCCM RTM Client install hangs on BCD.MOF
I am having an intermittent issue which appears to be isolated to Lenovo systems running Windows 2000. We are attempting to upgrade the clients on these systems from SMS 2003 to SCCM 2007 so that we can then target them with OSD to migrate them to Vista. This goes smoothly on many systems but on some the installation hangs at the point of the installation where WMI registrations take place. Specifically I have narrowedit down to the point where the installation tries to mofcomp BCD.MOF. When the problem occurs then installation gets stuck here indefinitely. If I break out of the installation and manually try to run mofcomp BCD.MOF, mofcomp hangs. The only way out at this point seems to be to break out of ccmsetup, rebuild the WMI repository, relaunch ccmsetup and that usually fixes it. Problem is I have thousands of Lenovos with Windows 2000 and I am afraid I will see this on many systems. I heard of a similar instance and it was suggested to pre-run MOFCOMP BCD.MOF on the system while SMS 2003 is present. I have actually had some success with this but still some systems hand during the mofcomp. Any ideas on this strange problem? I only need the client to upgrade and remain healthy long enough to target it with an OS upgrade to Vista. Also I only have this problem when the OS is Windows 2000. When upgrading a Vista or XP system from SMS 2003 to SCCM 2007, I never have this problem.
June 28th, 2008 6:20am

I have no suggestions other than to open a case with product support. Sounds very system specific.
Free Windows Admin Tool Kit Click here and download it now
July 1st, 2008 5:42pm

hi,i have the same problem with hp pc*s and w2k pro!
November 20th, 2008 12:57am

Maybe mofcomp.log in %windir%\system32\wbem\Logs can tell you more ...
Free Windows Admin Tool Kit Click here and download it now
November 20th, 2008 2:56am

if you try to manually compileBCD.MOF does it hang? ie. mofcomp bcd.mof if you look in %windir%\system32\wbem\logs\mofcomp.log do you see errors after the part where it performs mofcomp bcd.mof or possibly the log just stops there and does not move forward indicating it is hung? Is it happening on many systems or just a few? Certain models?
November 20th, 2008 7:01am

I'm new to this thread, but I have the same problem. My answer to the question about the mofcomp bcd.mof is YES - there are many errors from many attempts.
Free Windows Admin Tool Kit Click here and download it now
December 12th, 2008 3:50pm

We also have the same issue. Found this in mofcomp.log :An error occurred while opening the namespace for object 1 defined on lines 3 - 6Error Number: 0x8004100e, Facility: WMIHere are lines 3-6instance of __Win32Provider as $BcdProv { Name = "BcdProv"; CLSID = "{f8a56d3e-e304-4a9f-a916-5187019d7759}";};More information about BCD store : there a WMI expertthat can help?
May 27th, 2009 5:26am

Exactly the same problem as Mitch53 except the hardware is HP and DELL Optiplex desktops on w2k pro. mofcomp.exe just hangs on "Parsing MOF: bcd.mof" Anyone ? Thanks
Free Windows Admin Tool Kit Click here and download it now
August 10th, 2009 11:55am

Create a separate mof file with the following 2 lines:#pragma namespace ("\\\\.\\Root\\wmi")#pragma deleteclass("WMIBinaryMofResource", nofail)Compile it (mofcomp) on the windows 2000 system prior to upgrading the client to SCCM. This should prevent the WMI hang. We only saw this on newer hardware running Windows 2000 Pro. Was never an issue on older hardware. One impoertant note, this problem can recur. I would do this at the point where you are ready to upgradethe OS. If you perform this workaround and leave the client as a Windows 2000 system, running a repair or upgrading the client again (ie client service pack) will cause the WMI hang to occur again. You would have to reapply the above mof fle again.
August 20th, 2009 2:23pm

Tried this but doesn't stop the hang for me? I mofcomped it, restarted the system, tried pushing the sccm client to the system and it gets hung in the same place. Terry
Free Windows Admin Tool Kit Click here and download it now
March 25th, 2010 12:50pm

Update: I had to open a support case with Microsoft. Not really any help. They had me try compiling the bcd.mof ahead of time manually. Didn't work. The next solution was to just create a mst to skip the mof compile altogether. I guess this will work as a work around for now. After quite a bit of research and testing I still don't understand what this does on a Windows 2000 or even a XP system? BCD from what I can tell only relates to Vista and Windows 7? So not sure why the SCCM Client install always puts the files down and compiles the BCD provider even on a Windows 2000 system? Not sure why all these Lenvovo's are failing with it though? Seems to be something in WMI doesn't like it for whatever reason. Anyway, I would recommend to Microsoft if it isn't needed on W2K\XP systems to have the client be smart enough to know to skip those parts on those systems. Terry
March 31st, 2010 12:10am

>The next solution was to just create a mst to skip the mof compile altogether. Could you please explain how exactly that mst file should be prepared ? Maybe anyone else could also help if mattw112 is not available.
Free Windows Admin Tool Kit Click here and download it now
March 20th, 2012 10:56am

Wow been a couple years... If you have a tool to create MSTs, just open that with the client.msi and go to the section where it does that action and remove it. But it is more complex than that. I ended up writing a big script that part of it was if the machine was a W2k machine then drop the mst and use that in the command line. Otherwise don't... If you post your email address I can also just send you the mst I still have it.
March 20th, 2012 12:25pm

Thanks! Please, send it to ujeen1980(at)gmail(dot)com
Free Windows Admin Tool Kit Click here and download it now
March 21st, 2012 4:03am

Happened only on one of my XP machines, i just created an empty file i called it bcd.mof and i stored it on the wbem folder, restarted ccmsetup.exe and everything worked fine.
July 18th, 2012 7:20am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics