Strict Standards: Non-static method Settings::setHostName() should not be called statically in C:\website\www.networksteve.com\enterprise\_lib\AutoConfig.php on line 20

Strict Standards: Non-static method Settings::addHostAlias() should not be called statically in C:\website\www.networksteve.com\enterprise\_lib\AutoConfig.php on line 22

Strict Standards: Non-static method Settings::setSiteRoot() should not be called statically in C:\website\www.networksteve.com\enterprise\_lib\AutoConfig.php on line 28

Strict Standards: Non-static method Settings::setDsn() should not be called statically in C:\website\www.networksteve.com\enterprise\_site\Config.php on line 16

Strict Standards: Non-static method Settings::setTitle() should not be called statically in C:\website\www.networksteve.com\enterprise\_site\Config.php on line 19

Strict Standards: Non-static method Settings::setDescription() should not be called statically in C:\website\www.networksteve.com\enterprise\_site\Config.php on line 20

Strict Standards: Non-static method Settings::setSiteRoot() should not be called statically in C:\website\www.networksteve.com\enterprise\_site\Config.php on line 24

Strict Standards: Non-static method Settings::setShowDeleted() should not be called statically in C:\website\www.networksteve.com\enterprise\_site\Config.php on line 31

Strict Standards: Non-static method Settings::setRecentTopicsDuration() should not be called statically in C:\website\www.networksteve.com\enterprise\_site\Config.php on line 36

Strict Standards: Non-static method Settings::test() should not be called statically in C:\website\www.networksteve.com\enterprise\_lib\Init.php on line 28

Strict Standards: Non-static method Skin::test() should not be called statically in C:\website\www.networksteve.com\enterprise\_lib\Init.php on line 29

Strict Standards: Non-static method Settings::getSkin() should not be called statically in C:\website\www.networksteve.com\enterprise\_lib\Skin.php on line 102

Strict Standards: Non-static method Settings::getSiteRoot() should not be called statically in C:\website\www.networksteve.com\enterprise\_lib\Init.php on line 32

Strict Standards: Non-static method Settings::getDsn() should not be called statically in C:\website\www.networksteve.com\enterprise\_lib\Init.php on line 35

Strict Standards: Non-static method Form::field() should not be called statically in C:\website\www.networksteve.com\enterprise\_lib\Init.php on line 39

Strict Standards: Non-static method Form::fieldExists() should not be called statically, assuming $this from incompatible context in C:\website\www.networksteve.com\enterprise\_lib\Entity\User.php on line 92

Strict Standards: Non-static method Form::fieldExists() should not be called statically in C:\website\www.networksteve.com\enterprise\topic.php on line 15

Strict Standards: Non-static method Form::field() should not be called statically in C:\website\www.networksteve.com\enterprise\topic.php on line 17

Strict Standards: Non-static method Settings::getShowDeleted() should not be called statically, assuming $this from incompatible context in C:\website\www.networksteve.com\enterprise\_lib\Entity\Topic.php on line 139

Strict Standards: Non-static method Entity_Post::queryPosts() should not be called statically in C:\website\www.networksteve.com\enterprise\topic.php on line 21

Strict Standards: Non-static method Settings::getShowDeleted() should not be called statically in C:\website\www.networksteve.com\enterprise\_lib\Entity\Post.php on line 111

Strict Standards: Non-static method Skin::showHeader() should not be called statically in C:\website\www.networksteve.com\enterprise\topic.php on line 23

Strict Standards: Non-static method Skin::includeFile() should not be called statically in C:\website\www.networksteve.com\enterprise\_lib\Skin.php on line 46

Strict Standards: Non-static method Settings::getSkin() should not be called statically in C:\website\www.networksteve.com\enterprise\_lib\Skin.php on line 91
SCCM Agent Setup without Domain Membership ? (Network Steve Forum)
SCCM Agent Setup without Domain Membership ?
Hi, we're using WDS to install all our clients automated. Also the SCCM Agent will be installed. At the end of all software installations the computer will be joined to Domain. The question I have: Does it makes sense to install the SCCM Agent during the client is not yet member of the domain or should it be installed *after* joining the domain (eg. Logon Script) ? An "issue" for me is: The SCCM Agent needs about several hours (sometimes days) till he's ready to use (till the user is able to install software for example). My goal is to get the SCCM Agent to run as soon as possible after the WDS Setup. The client has been installed with WDS, the Agent is running immediately, the user can install additional software and the Agent will inventory this fresh installed computer. Any ideas or suggestion to speeding up the Agent to run ?
September 28th, 2011 8:49am

It does not matter when the client will be installed from a technical point of view. The ConfigMgr client can also be installed on workgroup computers (keep in mind that there's the need for an SLP then). "Sometimes hours, sometimes days" sounds like you're having another issue. It depends on the concept of how you're going to distribute software (collection update cycles, discovery cycles etc).Torsten Meringer | http://www.mssccmfaq.de
Free Windows Admin Tool Kit Click here and download it now
September 28th, 2011 8:54am

I like to go with SUP based Client installation. Client Installation Planning Worksheet http://technet.microsoft.com/en-us/library/bb632611.aspx How to obtain 100 % ConfigMgr Client Installation http://blogs.technet.com/b/configmgr/archive/2008/05/14/how-to-obtain-100-configmgr-client-installation.aspx Overview of Configuration Manager Client Deployment http://technet.microsoft.com/en-us/library/bb633063.aspx How to Install Configuration Manager Clients Using Software Update Point Based Installation http://technet.microsoft.com/en-us/library/bb633194.aspx This posting is provided "AS IS" with no warranties or guarantees, and confers no rights. |Please remember to click Mark as Answer on the post that helps you, and to click Unmark as Answer if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
September 28th, 2011 9:07am

As Torsten is saying it do not take hours or days to install the client. If you want to make sure that clients are installed then I suggest using a startup script not a logon script. You have an example script here - http://blogs.catapultsystems.com/jsandys/archive/2010/12/30/updated-configmgr-startup-script.aspx it can be applied in your AD in less than 10 minutes.Kent Agerlund | My blogs: http://blog.coretech.dk/author/kea/ and http://scug.dk/ | Twitter @Agerlund | Linkedin: /kentagerlund
Free Windows Admin Tool Kit Click here and download it now
September 28th, 2011 9:08am

As Torsten is saying it do not take hours or days to install the client. If you want to make sure that clients are installed then I suggest using a startup script not a logon script. You have an example script here - http://blogs.catapultsystems.com/jsandys/archive/2010/12/30/updated-configmgr-startup-script.aspx it can be applied in your AD in less than 10 minutes.Kent Agerlund | My blogs: http://blog.coretech.dk/author/kea/ and http://scug.dk/ | Twitter @Agerlund | Linkedin: /kentagerlund
September 28th, 2011 9:08am

Hi Torsten, thanks for the quick reply. Probably the SCCM agent finds immediately the site, but if I have a look in tab of "Actions" in "Configuration Manager" in Control Panel I only see two values: "Machine Policy Retrieval & Evaluation Cycle" and "User Policy Retrieval & Evaluation Cycle". On a working computer there are much more values like "File Collection Cycle", "Hardware Inventory Cycle" and "Software Inventory Cycle". And in "Run Advertised Programs", the title is still "IT Organization" and not our customized title. It takes too long till everything is everything okay, it works, but not immediately like I want... One example: Two days ago a client was fresh installed and the Agent was ready to use after 1 hour (also too long for me...) Yesterday I've installed another computer, since then he's online but the Agent is not yet ready... What's going wrong here ?
Free Windows Admin Tool Kit Click here and download it now
September 28th, 2011 9:10am

Thanks Kent, This looks as a really good scriptThis posting is provided "AS IS" with no warranties or guarantees, and confers no rights. |Please remember to click Mark as Answer on the post that helps you, and to click Unmark as Answer if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
September 28th, 2011 9:38am

You would have to examine the logs then. The client was not able to retrieve policies from the MP if there are only the two actions are available. See LocagtionServices.log, ClientLocation.log and ccmexec.log. BTW: Why don't you use ConfigMgr OSD to install the clients?Torsten Meringer | http://www.mssccmfaq.de
Free Windows Admin Tool Kit Click here and download it now
September 28th, 2011 9:39am

You would have to examine the logs then. The client was not able to retrieve policies from the MP if there are only the two actions are available. See LocagtionServices.log, ClientLocation.log and ccmexec.log. BTW: Why don't you use ConfigMgr OSD to install the clients?Torsten Meringer | http://www.mssccmfaq.de
September 28th, 2011 9:39am

Hi Torsten, thanks for the quick reply. Probably the SCCM agent finds immediately the site, but if I have a look in tab of "Actions" in "Configuration Manager" in Control Panel I only see two values: "Machine Policy Retrieval & Evaluation Cycle" and "User Policy Retrieval & Evaluation Cycle". On a working computer there are much more values like "File Collection Cycle", "Hardware Inventory Cycle" and "Software Inventory Cycle". And in "Run Advertised Programs", the title is still "IT Organization" and not our customized title. It takes too long till everything is everything okay, it works, but not immediately like I want... One example: Two days ago a client was fresh installed and the Agent was ready to use after 1 hour (also too long for me...) Yesterday I've installed another computer, since then he's online but the Agent is not yet ready... What's going wrong here ? We got the exact same problem here. Sometimes it takes an hour and sometimes it takes days for the client to start deploying applications. Wat can I do to speed this process up?
Free Windows Admin Tool Kit Click here and download it now
October 6th, 2011 6:41am

You have to find the cause for the delay. How are you building the collections? Do they make use of discovery data (AD system group disocvery -> check the interval)? How often are they updated? How often is the client pulling policies? Is the client working? Is the site / MP working? Any (advertisement) status messages? Does that BITS download take a long time?Torsten Meringer | http://www.mssccmfaq.de
October 6th, 2011 6:48am

You have to find the cause for the delay. How are you building the collections? Do they make use of discovery data (AD system group disocvery -> check the interval)? How often are they updated? How often is the client pulling policies? Is the client working? Is the site / MP working? Any (advertisement) status messages? Does that BITS download take a long time?Torsten Meringer | http://www.mssccmfaq.de
Free Windows Admin Tool Kit Click here and download it now
October 6th, 2011 1:46pm


Strict Standards: Non-static method Settings::getRecentTopicsLimit() should not be called statically, assuming $this from incompatible context in C:\website\www.networksteve.com\enterprise\_lib\Entity\Topic.php on line 121

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics

Strict Standards: Non-static method Skin::showFooter() should not be called statically in C:\website\www.networksteve.com\enterprise\topic.php on line 119

Strict Standards: Non-static method Skin::includeFile() should not be called statically in C:\website\www.networksteve.com\enterprise\_lib\Skin.php on line 56

Strict Standards: Non-static method Settings::getSkin() should not be called statically in C:\website\www.networksteve.com\enterprise\_lib\Skin.php on line 91