RuntimeBroker.exe takes up all CPU

I just upgraded from Windows 7 to Windows 10

When doing my monthly backup today, the Laptop basically froze all other applications, other than my Explorer.exe copy, which is doing my copy of files from a network drive to a USB local device.

On Windows 7 there was no issue (on the same hardware obviously) and the copy took about 30 mins to complete.

On Windows 10, CPU was running 100% and although the copy was progressing, it was very slowly going through the file names and no other applications would launch (e.g. even launching taskmgr took about 1 min to come up)

The culprit was RuntimeBroker.exe which was using 50-60% CPU constantly.   When I killed this process, the copy sped up considerably and all other applications would launch normally

Although I understand what RuntimeBroker.exe is doing, it is not acceptable for my normal working processes for it to take so much CPU so either need to fix the issue or disable it

1.  I found some references to disabling the process completely.  Is this safe, or am I open to security risks

2.  If it needs to be left enabled, what can be done to prevent it screwing up my laptop every time I want to copy files


July 31st, 2015 3:35am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics